Modify

Opened 2 years ago

Closed 2 years ago

#21417 closed defect (duplicate)

Openwrt crash when Asus WL500gP-v1 under load

Reported by: ciprian.alexan Owned by: developers
Priority: normal Milestone:
Component: packages Version: Chaos Calmer 15.05
Keywords: crash load stress Cc:

Description

Openwrt CHAOS CALMER (15.05, r46767) is running on Asus WL500gP v1
Router is connected to the internet through PPPoE
One on the wired stations in LAN starts torrent downloading.
As this is a poplar torrent, there are plenty of sources to download from, it's only the router limiting the traffic.
Download speed starts increasing until the maximum of about 2-3 MBps
Download speed remains stable for 3-5 minutes when router crash.
Router reboot and it comes up.
Download resumes, speeds up, and few minutes later router crash again.
This cycle continues as log as the download is running.
If download stops, router stays up for days serving light internet traffic.

This is the serial console output the router crashes:

[  431.860000] Unhandled kernel unaligned access[#1]:
[  431.860000] CPU: 0 PID: 1061 Comm: hostapd Not tainted 3.18.20 #1
[  431.860000] task: 816039d8 ti: 80fbe000 task.ti: 80fbe000
[  431.860000] $ 0   : 00000000 1000dc00 81c6e000 00200000
[  431.860000] $ 4   : 0fcd9eae 81a07e60 00000001 00000024
[  431.860000] $ 8   : 00200200 00100100 00000001 ffffff80
[  431.860000] $12   : 08011880 1451533b 00000000 0000ee44
[  431.860000] $16   : 81c6e000 00000001 81a06c20 802c5a78
[  431.860000] $20   : 81a06aa0 80340000 80345dd8 00000002
[  431.860000] $24   : 00000000 8006eddc                  
[  431.860000] $28   : 80fbe000 80fbf980 00000008 801d8db4
[  431.860000] Hi    : 00000000
[  431.860000] Lo    : 0000006c
[  431.860000] epc   : 800742d4 0x800742d4
[  431.860000]     Not tainted
[  431.860000] ra    : 801d8db4 0x801d8db4
[  431.860000] Status: 1000dc03 KERNEL EXL IE 
[  431.860000] Cause : 00800010
[  431.860000] BadVA : 0fcd9eae
[  431.860000] PrId  : 00029006 (Broadcom BMIPS3300)
[  431.860000] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat b43legacy b43 ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERAg
[  431.860000] Process hostapd (pid: 1061, threadinfo=80fbe000, task=816039d8, tls=7722b440)
[  431.860000] Stack : 81a06c20 801d8e28 802f0000 802c5a78 81a06c20 802f08a0 802f0000 801d8e64
          0000000a 81a07e60 802f08a0 802f0000 81a06c20 801e6764 80fbf9b8 80fbf9b8
          0000000a 0000000e 00000003 80345de0 0000000a 00000001 00000101 80024794
          816039d8 81603a08 00000000 00000001 802ef788 8003f070 00400140 00003383
          1000dc01 000001ff 80b800a0 81685de0 00010000 80fbff08 00000104 00000010
          ...
[  431.860000] Call Trace:[<801d8e28>] 0x801d8e28
[  431.860000] [<801d8e64>] 0x801d8e64
[  431.860000] [<801e6764>] 0x801e6764
[  431.860000] [<80024794>] 0x80024794
[  431.860000] [<8003f070>] 0x8003f070
[  431.860000] [<800249a0>] 0x800249a0
[  431.860000] [<80024a58>] 0x80024a58
[  431.860000] [<8027c1c8>] 0x8027c1c8
[  431.860000] [<801df0a4>] 0x801df0a4
[  431.860000] [<801d15d4>] 0x801d15d4
[  431.860000] [<80007728>] 0x80007728
[  431.860000] [<800af690>] 0x800af690
[  431.860000] [<802909bc>] 0x802909bc
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<800af0ec>] 0x800af0ec
[  431.860000] [<81bca068>] 0x81bca068 [ppp_generic@81bc8000+0x4f10]
[  431.860000] [<81a50dc4>] 0x81a50dc4 [nf_conntrack@81a50000+0xb2d0]
[  431.860000] [<81bca238>] 0x81bca238 [ppp_generic@81bc8000+0x4f10]
[  431.860000] [<801ea264>] 0x801ea264
[  431.860000] [<801d8c30>] 0x801d8c30
[  431.860000] [<800415c8>] 0x800415c8
[  431.860000] [<801df650>] 0x801df650
[  431.860000] [<8020ee8c>] 0x8020ee8c
[  431.860000] [<801ea7a0>] 0x801ea7a0
[  431.860000] [<80281508>] 0x80281508
[  431.860000] [<8004a5d0>] 0x8004a5d0
[  431.860000] [<800afae4>] 0x800afae4
[  431.860000] [<801d282c>] 0x801d282c
[  431.860000] [<801e7ee0>] 0x801e7ee0
[  431.860000] [<801e8054>] 0x801e8054
[  431.860000] [<801c22a4>] 0x801c22a4
[  431.860000] [<80de0600>] 0x80de0600 [ath9k@80de0000+0x14280]
[  431.860000] [<80de0600>] 0x80de0600 [ath9k@80de0000+0x14280]
[  431.860000] [<80de3a98>] 0x80de3a98 [ath9k@80de0000+0x14280]
[  431.860000] [<800af37c>] 0x800af37c
[  431.860000] [<800afd18>] 0x800afd18
[  431.860000] [<800517dc>] 0x800517dc
[  431.860000] [<800037a8>] 0x800037a8
[  431.860000] [<80010102>] 0x80010102
[  431.860000] 
[  431.860000] 
Code: 24a53740  0801d06d  00003021 <8c820000> 3042c000  10400003  00801821  0801cf3c  00000000 
[  432.260000] ---[ end trace 0cfb7e7df5132df7 ]---
[  432.280000] Kernel panic - not syncing: Fatal exception in interrupt
[  432.280000] Rebooting in 3 seconds..

or

d
[  247.650000] Unhandled kernel unaligned access[#1]:
[  247.650000] CPU: 0 PID: 3 Comm: ksoftirqd/0 Not tainted 3.18.20 #1
[  247.650000] task: 8181c008 ti: 81826000 task.ti: 81826000
[  247.650000] $ 0   : 00000000 1000dc01 803a2ce0 00200000
[  247.650000] $ 4   : c0421105 00000001 00000f08 00000001
[  247.650000] $ 8   : ffffffad 00000001 00000002 e2902500
[  247.650000] $12   : 32371080 147e3a17 00000000 00009f43
[  247.650000] $16   : 803a2ce0 00000001 80f96aa0 8154cb40
[  247.650000] $20   : 00000100 00000000 80e79720 80e78b00
[  247.650000] $24   : 00000000 8001d818                  
[  247.650000] $28   : 81826000 81827da8 81b3c038 801d8db4
[  247.650000] Hi    : 00000048
[  247.650000] Lo    : 00000000
[  247.650000] epc   : 800742d4 0x800742d4
[  247.650000]     Not tainted
[  247.650000] ra    : 801d8db4 0x801d8db4
[  247.650000] Status: 1000dc03 KERNEL EXL IE 
[  247.650000] Cause : 00800010
[  247.650000] BadVA : c0421105
[  247.650000] PrId  : 00029006 (Broadcom BMIPS3300)
[  247.650000] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat b43legacy b43 ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERAg
[  247.650000] Process ksoftirqd/0 (pid: 3, threadinfo=81826000, task=8181c008, tls=00000000)
[  247.650000] Stack : 80f96aa0 801d8e28 000001e0 8150dda0 80f96aa0 81b3c010 80dd3610 801d8e64
          80e79720 81b3c010 00000064 80e79720 80e79720 80de0658 00000030 801e87fc
          81948c48 802f08a0 00000002 00000000 80e7a534 802f08a8 80e7a0c4 00000001
          802ef338 00000000 00000100 80340000 80345dd8 00000006 00000018 80024f14
          00000009 80345de4 0000000a 00000001 00000100 00000004 80345df0 0000000a
          ...
[  247.650000] Call Trace:[<801d8e28>] 0x801d8e28
[  247.650000] [<801d8e64>] 0x801d8e64
[  247.650000] [<80de0658>] 0x80de0658 [ath9k@80de0000+0x14280]
[  247.650000] [<801e87fc>] 0x801e87fc
[  247.650000] [<80024f14>] 0x80024f14
[  247.650000] [<80024794>] 0x80024794
[  247.650000] [<8003e7b8>] 0x8003e7b8
[  247.650000] [<8003afec>] 0x8003afec
[  247.650000] [<800248f4>] 0x800248f4
[  247.650000] [<8003afec>] 0x8003afec
[  247.650000] [<8003b120>] 0x8003b120
[  247.650000] [<8003afec>] 0x8003afec
[  247.650000] [<800382b0>] 0x800382b0
[  247.650000] [<8003c0b4>] 0x8003c0b4
[  247.650000] [<800381d4>] 0x800381d4
[  247.650000] [<800014a8>] 0x800014a8
[  247.650000] 
[  247.650000] 
Code: 24a53740  0801d06d  00003021 <8c820000> 3042c000  10400003  00801821  0801cf3c  00000000 
[  247.930000] ---[ end trace b58c4a1c099613aa ]---
[  247.950000] Kernel panic - not syncing: Fatal exception in interrupt
[  247.950000] Rebooting in 3 seconds..

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by ciprian.alexan

[  573.810000] CPU 0 Unable to handle kernel paging request at virtual address 28b1ad70, epc == 800742d4, ra == 801d8db4
[  573.820000] Oops[#1]:
[  573.820000] CPU: 0 PID: 3 Comm: ksoftirqd/0 Not tainted 3.18.20 #1
[  573.820000] task: 8181c008 ti: 81826000 task.ti: 81826000
[  573.820000] $ 0   : 00000000 1000dc00 8063e800 00200000
[  573.820000] $ 4   : 28b1ad70 80ea50e0 ffffffff 00000024
[  573.820000] $ 8   : 00200200 00100100 00000001 ffffff80
[  573.820000] $12   : 0002e11a 00000000 00000000 00000000
[  573.820000] $16   : 8063e800 00000001 80f287a0 802c5a78
[  573.820000] $20   : 81f5e560 80340000 80345dd8 00000002
[  573.820000] $24   : 00000000 8006eddc                  
[  573.820000] $28   : 81826000 81827df0 00000008 801d8db4
[  573.820000] Hi    : 00000000
[  573.820000] Lo    : 0000006c
[  573.820000] epc   : 800742d4 0x800742d4
[  573.820000]     Not tainted
[  573.820000] ra    : 801d8db4 0x801d8db4
[  573.820000] Status: 1000dc03 KERNEL EXL IE 
[  573.820000] Cause : 00800008
[  573.820000] BadVA : 28b1ad70
[  573.820000] PrId  : 00029006 (Broadcom BMIPS3300)
[  573.820000] Modules linked in: ath9k ath9k_common pppoe ppp_async iptable_nat b43legacy b43 ath9k_hw ath pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 mac80211 ipt_REJECT ipt_MASQUERAg
[  573.820000] Process ksoftirqd/0 (pid: 3, threadinfo=81826000, task=8181c008, tls=00000000)
[  573.820000] Stack : 80f287a0 801d8e28 802f0000 802c5a78 80f287a0 802f08a0 802f0000 801d8e64
          0000000a 80ea50e0 802f08a0 802f0000 80f287a0 801e6764 81827e28 81827e28
          0000000a 0000004e 00000013 80345de0 0000000a 00000001 00000100 80024794
          8003afec 802f0000 802ef750 802f8cd8 00000000 8003bc6c 04208040 00006af6
          81818080 802f2958 00000001 00000002 8003afec 802f0000 802ef750 802f8cd8
          ...
[  573.820000] Call Trace:[<801d8e28>] 0x801d8e28
[  573.820000] [<801d8e64>] 0x801d8e64
[  573.820000] [<801e6764>] 0x801e6764
[  573.820000] [<80024794>] 0x80024794
[  573.820000] [<8003afec>] 0x8003afec
[  573.820000] [<8003bc6c>] 0x8003bc6c
[  573.820000] [<8003afec>] 0x8003afec
[  573.820000] [<800248f4>] 0x800248f4
[  573.820000] [<8003afec>] 0x8003afec
[  573.820000] [<8003b120>] 0x8003b120
[  573.820000] [<8003afec>] 0x8003afec
[  573.820000] [<800382b0>] 0x800382b0
[  573.820000] [<8003c0b4>] 0x8003c0b4
[  573.820000] [<800381d4>] 0x800381d4
[  573.820000] [<800014a8>] 0x800014a8
[  573.820000] 
[  573.820000] 
Code: 24a53740  0801d06d  00003021 <8c820000> 3042c000  10400003  00801821  0801cf3c  00000000 
[  574.100000] ---[ end trace c8b72e58a8e27393 ]---
[  574.110000] Kernel panic - not syncing: Fatal exception in interrupt
[  574.110000] Rebooting in 3 seconds..

comment:2 Changed 2 years ago by anonymous

nobody really cares lately maintaining software for old hardware which is how open source came to life in the first place. 90% of the open source revenue comes from $$ companies that only care for new brown products which means that open source is in deep brown trouble.

lack of new open source contributors and hesitation from old established hackers to gladly accept them aboard is also a factor of this brown situation.

comment:3 Changed 2 years ago by anonymous

the lack of effective organization on managing and maintaining collaborative work is the main problem (leak) of open source. most established hackers are too busy passionately promoting themselves rather than orchestrating the community to grow stronger and healthier.

and of course this input can go to /dev/null since it's irrelevant with the ticket. or is it not?

comment:4 Changed 2 years ago by rmilecki

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #11091

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.