Modify

Opened 2 years ago

Closed 2 years ago

#21411 closed defect (not_a_bug)

mt7621.dtsi compile error with lastest trunk.

Reported by: anonymous Owned by: developers
Priority: high Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description

@47929

I have tried dirclean but still encounter this:

rm -f /home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/mt7621-kernel.bin
cp /home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/vmlinux /home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/mt7621-kernel.bin
cc -E -nostdinc -x assembler-with-cpp -I/home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/linux-4.3/arch/mips/boot/dts -I/home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/linux-4.3/arch/mips/boot/dts/include -undef -DDTS -o /home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/mt7621-kernel.bin.dtb.tmp ../dts/MT7621.dts
/home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/linux-4.3/scripts/dtc/dtc -O dtb -i../dts/ -o /home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/mt7621-kernel.bin.dtb /home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/mt7621-kernel.bin.dtb.tmp
Error: ../dts/mt7621.dtsi:1.1-9 syntax error
FATAL ERROR: Unable to parse input tree
make[5]: * /home/Openwrt/trunk_151216/build_dir/target-mipsel_1004kc+dsp_musl-1.1.11/linux-ramips_mt7621/mt7621-kernel.bin Error 1
make[5]: Leaving directory `/home/Openwrt/trunk_151216/target/linux/ramips/image'
make[4]:
* [install] Error 2
make[4]: Leaving directory `/home/Openwrt/trunk_151216/target/linux/ramips'
make[3]: * [install] Error 2
make[3]: Leaving directory `/home/Openwrt/trunk_151216/target/linux'
make[2]:
* [target/linux/install] Error 2
make[2]: Leaving directory `/home/Openwrt/trunk_151216'
make[1]: * /home/Openwrt/trunk_151216/staging_dir/target-mipsel_1004kc+dsp_musl-1.1.11/stamp/.target_install Error 2
make[1]: Leaving directory `/home/Openwrt/trunk_151216'
make:
* [world] 错误 2
➜ trunk_151216 git:(master) ✗

I tried removing this line #include <dt-bindings/interrupt-controller/mips-gic.h>,but encounter another error. please fix it.

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r47937

comment:2 Changed 2 years ago by anonymous

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still the same problem after r47937

comment:3 follow-up: Changed 2 years ago by nbd

Any modifications in your tree? I can't reproduce this and I know quite a few other people that can also compile this stuff just fine.
Did you try making a fresh checkout?

comment:4 in reply to: ↑ 3 Changed 2 years ago by anonymous

Replying to nbd:

Any modifications in your tree? I can't reproduce this and I know quite a few other people that can also compile this stuff just fine.
Did you try making a fresh checkout?

I've tried make dirclean.I compile it with GCC 4.8 with linaro enhancement not default 5.2

comment:5 Changed 2 years ago by anonymous

After making a fresh checkout,compile ok.You may close this.

comment:6 Changed 2 years ago by blogic

  • Resolution set to not_a_bug
  • Status changed from reopened to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.