Modify

Opened 2 years ago

Last modified 21 months ago

#21408 new defect

802.11r Does Not Work

Reported by: J1mbo Owned by: developers
Priority: normal Milestone:
Component: packages Version: Chaos Calmer 15.05
Keywords: hostapd, 802.11r Cc:

Description

After enabling 802.11r, clients are unable to roam and no traffic with ethertypes 0x88C7 or 0x890D are observed from the LAN interface of the APs concerned. Disabling 802.11r roaming (by full four-way handshake) works as usual.

In this configuration, OpenWRT is providing access points only; layer-3 functionality is handled elsewhere.

APs: TP-Link TL-WR710N x2 and NetGear WR604 x1. All are 2.4GHz single-stream with 15.05.
Network: VLAN1 - internal network, VLAN4 - guest
Security - 802.1X, dynamic VLANs implemented.
Client: iPad Air, IOS 9.2

Network (from the WN604):
[code]
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '0t 1 2 3 4'

config 'switch_port'

option port '1'
option pvid '1'

config 'switch_port'

option port '2'
option pvid '1'

config 'switch_port'

option port '3'
option pvid '1'

config 'switch_port'

option port '4'
option pvid '1'

config switch_vlan

option device 'switch0'
option vlan '4'
option ports '0t 1t'

config interface 'vlan1'

option ifname 'eth1.1'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '10.0.1.19'
option netmask '255.255.255.0'
option gateway '10.0.1.1'
option dns '10.0.1.50'
option ip6assign '60'

config interface 'vlan4'

option ifname 'eth1.4'
option type 'bridge'

[/code]

Wireless:
[code]
config wifi-device radio0

option type mac80211
option channel 1
option hwmode 11g
option path 'pci0000:00/0000:00:00.0'
option htmode HT40+
list ht_capab 'SHORT-GI-20'
list ht_capab 'SHORT-GI-40'
list ht_capab 'TX-STBC'
list ht_capab 'RX-STBC1'
list ht_capab 'DSSS_CCK-40'
option txpower '12'
option country 'GB'
option disabled 0

config wifi-iface

# 'Network' SSID
option device radio0
option mode ap
option ssid Network
option dtim_period '1'
option short_preamble '1'
option wmm '1'
option max_listen_interval '10'

# 802.1X
option encryption 'wpa2'
option server '10.0.1.50'
option key '[removed]'
option own_ip_addr '10.0.1.19'
option dynamic_vlan '2'
option 'vlan_tagged_interface' 'eth1'
option 'vlan_bridge' 'br-vlan'
option 'vlan_naming' '0'
option wpa_key_mgmt 'WPA-EAP FT-EAP'

# 802.11i Pre-Authentication
option rsn_preauth '1'
option rsn_preauth_interfaces 'br-vlan1 br-vlan4'
option rsn_preauth_autoconf_bridge '1'

# 802.11r Fast Roaming
option ieee80211r '1'
option nasid '04a151b240b1'
option pmk_r1_push '1'
option ft_bridge 'br-vlan1'

# WN604
#list r0kh '04:a1:51:b2:40:b1,04a151b240b1,010102030405060708090a0b0c0d0e0f'
#list r1kh '04:a1:51:b2:40:b1,00:00:4f:57:72:74,010102030405060708090a0b0c0d0e0f'
# 710N-1
list r0kh 'c0:4a:00:ab:e7:0e,c04a00abe70e,010102030405060708090a0b0c0d0e0f'
list r1kh 'c0:4a:00:ab:e7:0e,00:00:4f:57:72:74,010102030405060708090a0b0c0d0e0f'
# 710N-2
list r0kh 'c0:4a:00:ab:fa:ec,c04a00abfaec,010102030405060708090a0b0c0d0e0f'
list r1kh 'c0:4a:00:ab:fa:ec,00:00:4f:57:72:74,010102030405060708090a0b0c0d0e0f'

option passive_scan_interval '60'

[/code]

BSSIDs are:
WN604: 04:a1:51:b2:40:b1
710N-1: c0:4a:00:ab:e7:0e
710N-2: c0:4a:00:ab:fa:ec

WN604 ifconfig:
[code]
br-vlan1 Link encap:Ethernet HWaddr 00:24:B2:DB:3F:54

inet addr:10.0.1.19 Bcast:10.0.1.255 Mask:255.255.255.0
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:335592 errors:0 dropped:5570 overruns:0 frame:0
TX packets:31637 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:35465504 (33.8 MiB) TX bytes:6721069 (6.4 MiB)

br-vlan4 Link encap:Ethernet HWaddr 00:24:B2:DB:3F:54

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:6572 errors:0 dropped:4640 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:422406 (412.5 KiB) TX bytes:0 (0.0 B)

eth1 Link encap:Ethernet HWaddr 00:24:B2:DB:3F:54

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9135761 errors:0 dropped:2 overruns:0 frame:0
TX packets:5524418 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1166688885 (1.0 GiB) TX bytes:3133285570 (2.9 GiB)
Interrupt:5

eth1.1 Link encap:Ethernet HWaddr 00:24:B2:DB:3F:54

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:9115399 errors:0 dropped:312 overruns:0 frame:0
TX packets:5519801 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:9590763654 (8.9 GiB) TX bytes:3110975516 (2.8 GiB)

eth1.4 Link encap:Ethernet HWaddr 00:24:B2:DB:3F:54

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:20357 errors:0 dropped:0 overruns:0 frame:0
TX packets:4617 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1415606 (1.3 MiB) TX bytes:212382 (207.4 KiB)

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:356 errors:0 dropped:0 overruns:0 frame:0
TX packets:356 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:51264 (50.0 KiB) TX bytes:51264 (50.0 KiB)

wlan0 Link encap:Ethernet HWaddr 04:A1:51:B2:40:B1

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:200 errors:0 dropped:0 overruns:0 frame:0
TX packets:264 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:18330 (17.9 KiB) TX bytes:78511 (76.6 KiB)

wlan0.1 Link encap:Ethernet HWaddr 04:A1:51:B2:40:B1

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:126696 errors:0 dropped:0 overruns:0 frame:0
TX packets:184067 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:92589322 (88.2 MiB) TX bytes:161351381 (153.8 MiB)

[/code]

Attachments (0)

Change History (6)

comment:1 Changed 2 years ago by anonymous

any news on this?

comment:2 Changed 2 years ago by anonymous

No one is interested?

comment:3 Changed 2 years ago by jow

Report it upstream to hostapd developers.

comment:4 Changed 23 months ago by anonymous

how to report to hostapd developers?

comment:5 Changed 23 months ago by hauke

You can register to the hostapd mailing list and write a mail to them. jow is probably talking about this topic: http://lists.infradead.org/pipermail/hostap/2016-March/035236.html You can provide them with the requested logs.

comment:6 Changed 21 months ago by ivanich

IIRC, wpan-mini doesn't support 802.11r, try to replace wpad-mini with CONFIG_PACKAGE_wpad=y and CONFIG_PACKAGE_hostapd-common=y

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.