Modify

Opened 2 years ago

Last modified 2 years ago

#21335 new defect

Not ipv6 connection from LAN

Reported by: maxyamus@… Owned by: developers
Priority: normal Milestone:
Component: other Version: Chaos Calmer 15.05
Keywords: Cc:

Description

Hello,

I'm having trouble to connect or ping out to any ipv6 addresses from LAN, though no problem from router itself.
My configs:

network:

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config globals 'globals'
        option ula_prefix 'fde4:fb6d:41aa::/48'

config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option netmask '255.255.255.0'
        option ipaddr '192.168.11.1'
        #option gateway '0.0.0.0'
        option dns '208.67.220.222 208.67.222.220 208.67.220.220 208.67.222.222 8.8.8.8'
        option bridge 'true'
        option ip6assign '60'

config interface 'wan'
        option ifname 'eth1'
        option bridge 'false'
        option proto 'dhcp'
        option broadcast '1'
        option peerdns '0'
        option dns '208.67.220.222 208.67.222.220 208.67.220.220 208.67.222.222'

config interface 'wan61'
        option ifname '@wan'
        option proto '6rd'
        option peeraddr '68.114.165.1'
        option ip6prefix '2602:100::'
        option ip6prefixlen '32'
        option dns '2001:4860:4860::8888 2001:4860:4860::8844'
        option ip4prefixlen '0'
        option ipaddr 'xx.xx.xx.xx'


firewall is standard, no changes, except one open port for ssh.

dhcp:
config dhcp 'lan'
        option interface 'lan'
        option start '100'
        option limit '150'
        option leasetime '12h'
        list dns '2001:4860:4860::8888'
        list dns '2001:4860:4860::8844'
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '1'

config dhcp 'wan'
        option interface 'wan'
        option ignore '1'

routes on router:

ip -6 r s
default from 2602:100:18ab:67b0::/64 via ::68.114.165.1 dev 6rd-wan61  proto static  metric 4096 
default from 2602:100::/32 via ::68.114.165.1 dev 6rd-wan61  proto static  metric 4096 
::/96 dev 6rd-wan61  proto kernel  metric 256 
2602:100:18ab:67b0::/64 dev br-lan  proto static  metric 1024 
unreachable 2602:100:18ab:67b0::/64 dev lo  proto static  metric 2147483647  error -128
2602:100::/32 dev 6rd-wan61  proto kernel  metric 256 
fde4:fb6d:41aa::/64 dev br-lan  proto static  metric 1024 
unreachable fde4:fb6d:41aa::/48 dev lo  proto static  metric 2147483647  error -128
fe80::/64 dev eth0  proto kernel  metric 256 
fe80::/64 dev br-guest  proto kernel  metric 256 
fe80::/64 dev br-lan  proto kernel  metric 256 
fe80::/64 dev wlan0  proto kernel  metric 256 
fe80::/64 dev eth1  proto kernel  metric 256 

ifstat wan61:

{
	"up": true,
	"pending": false,
	"available": true,
	"autostart": true,
	"uptime": 911,
	"l3_device": "6rd-wan61",
	"proto": "6rd",
	"updated": [
		"addresses",
		"routes",
		"prefixes"
	],
	"metric": 0,
	"delegation": true,
	"ipv4-address": [
		
	],
	"ipv6-address": [
		{
			"address": "2602:100:18ab:67b0::1",
			"mask": 32
		}
	],
	"ipv6-prefix": [
		{
			"address": "2602:100:18ab:67b0::",
			"mask": 64,
			"class": "wan61",
			"assigned": {
				"lan": {
					"address": "2602:100:18ab:67b0::",
					"mask": 64
				}
			}
		}
	],
	"ipv6-prefix-assignment": [
		
	],
	"route": [
		{
			"target": "::",
			"mask": 0,
			"nexthop": "::68.114.165.1",
			"metric": 4096,
			"source": "2602:100:xxx:xxx::1\/32"
		},
		{
			"target": "::",
			"mask": 0,
			"nexthop": "::68.114.165.1",
			"metric": 4096,
			"source": "2602:100:xxx:xxx::\/64"
		}
	],
	"dns-server": [
		"2001:4860:4860::8888",
		"2001:4860:4860::8844"
	],
	"dns-search": [
		
	],
	"inactive": {
		"ipv4-address": [
			
		],
		"ipv6-address": [
			
		],
		"route": [
			
		],
		"dns-server": [
			
		],
		"dns-search": [
			
		]
	},
	"data": {
		
	}
}

client:

>ip -6 r s
2602:100:18ab:67b0::/64 dev wlan0  proto kernel  metric 256  expires 7008sec mtu 1280
fde4:fb6d:41aa::/64 dev wlan0  proto kernel  metric 256  expires 7008sec mtu 1280
fe80::/64 dev wlan0  proto kernel  metric 256  mtu 1280
default via fe80::2cb0:5dff:fe82:e865 dev wlan0  proto ra  metric 1024  expires 1608sec hoplimit 64

ip -6 a s
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qlen 1000
    inet6 2602:100:18ab:67b0:xxxx:xxx:xxxx:2030/64 scope global mngtmpaddr dynamic 
       valid_lft 6870sec preferred_lft 1470sec
    inet6 fde4:fb6d:41aa:0:2677:3ff:feef:2030/64 scope global mngtmpaddr dynamic 
       valid_lft 6870sec preferred_lft 1470sec
    inet6 fe80::2677:3ff:feef:2030/64 scope link 
       valid_lft forever preferred_lft forever

>ping6 -c 10 ipv6.google.com
PING ipv6.google.com(ord08s13-in-x01.1e100.net) 56 data bytes

--- ipv6.google.com ping statistics ---
10 packets transmitted, 0 received, 100% packet loss, time 8999ms

>traceroute6 ipv6.google.com
traceroute to ipv6.google.com (2607:f8b0:4009:807::1001), 30 hops max, 80 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *


Same story for any windows client.

Please advice what am I missing.

Thank you.

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by cardoe@…

I have two identical Netgear WNDR3700v4's with Chaos Calmer on them. One of them has the default LAN and WLAN bridged together, I'll call it router A. Router A is using DHCPv6 to get a /64 from my ISP. On that setup IPv6 is working great.

On router B I have LAN and WLAN on separate network segments. Router B is using DHCPv6 to get a /56 from the same ISP. On that setup LAN is getting the first /64 and WLAN is getting the 2nd /64. IPv6 from the LAN is working great while IPv6 from the WLAN does not work. I've tested this on Mac OS X and Linux and both are unable to get out over WLAN but are able over LAN (I've confirmed they're getting new IPs from the correct pool when I change devices).

Given this and the original reporter's issue I wonder if OpenWRT does not have an issue when the ISP returns back something other than a /64 but this is just a jump to conclusion.

comment:2 Changed 2 years ago by 7f

I have the same problem, my router is running chaos calmer r47895 and I have native IPv6 connection.

The router can ping IPv6, but the computer in LAN can't.

My dhcp option is:

config dhcp 'lan'
	option interface 'lan'
	option start '100'
	option limit '150'
	option leasetime '12h'
	option ra 'server'
	option dhcpv6 'server'
	option ra_management '1'
	option ndp 'relay'
	list dhcp_option '6,192.168.1.1,114.114.114.114'
	option ra_default '1'

When I used chaos calmer r46812 with same settings there was no problem.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.