Modify

Opened 2 years ago

Last modified 2 years ago

#21323 new defect

Wan interface goes down after getting ip address from VDSL ISP

Reported by: d.buffa@… Owned by: developers
Priority: high Milestone:
Component: base system Version: Chaos Calmer 15.05
Keywords: Cc:

Description

Hi,

I'm not sure it's openwrt bug or provider and I know that's a borderline situation for ticketing but I have not received any response on the forum and surely is not a correct behaviour... some days ago all it's working fine, now the wan interface goes down after receiving correct ip address from isp

Mon Sep  7 07:02:51 2015 daemon.info pppd[2299]: PPP session is 8007
Mon Sep  7 07:02:51 2015 daemon.warn pppd[2299]: Connected to 88:a2:5e:17:be:be via interface ptm0.835
Mon Sep  7 07:02:51 2015 kern.info kernel: [  215.184000] pppoe-wan: renamed from ppp0
Mon Sep  7 07:02:51 2015 daemon.info pppd[2299]: Using interface pppoe-wan
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: Connect: pppoe-wan <--> ptm0.835
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: PAP authentication succeeded
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: peer from calling number 88:A2:5E:17:BE:BE authorized
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: local  IP address 80.116.255.192
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: remote IP address 192.168.100.1
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: primary   DNS address 85.37.17.17
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: secondary DNS address 85.38.28.72
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: local  LL address fe80::a86f:f111:5a2e:ae95
Mon Sep  7 07:02:51 2015 daemon.notice pppd[2299]: remote LL address fe80::02a0:a50f:fc86:8004
Mon Sep  7 07:02:51 2015 daemon.info pppd[2299]: IPV6CP terminated by peer
Mon Sep  7 07:02:52 2015 daemon.notice netifd: Network device 'pppoe-wan' link is up
Mon Sep  7 07:02:52 2015 daemon.notice netifd: Interface 'wan6' is enabled
Mon Sep  7 07:02:52 2015 daemon.notice netifd: Network alias 'pppoe-wan' link is up
Mon Sep  7 07:02:52 2015 daemon.notice netifd: Interface 'wan6' has link connectivity 
Mon Sep  7 07:02:52 2015 daemon.notice netifd: Interface 'wan6' is setting up now
Mon Sep  7 07:02:52 2015 daemon.notice netifd: Interface 'wan' is now up
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: reading /tmp/resolv.conf.auto
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using local addresses only for domain lan
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using nameserver 85.37.17.17#53
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using nameserver 85.38.28.72#53
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: reading /tmp/resolv.conf.auto
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using local addresses only for domain lan
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using nameserver 85.37.17.17#53
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using nameserver 85.38.28.72#53
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using nameserver 85.37.17.17#53
Mon Sep  7 07:02:52 2015 daemon.info dnsmasq[990]: using nameserver 85.38.28.72#53
Mon Sep  7 07:02:52 2015 daemon.notice netifd: Interface 'wan' has lost the connection

This afternoon I'll move to the remote site where I have DSL endpoint in order to do some test, there is something I can do to have a more verbose log or to acquire more usefull information?

Thanks in advance
D.

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by mkresin

Is this report related to your other report /ticket/21319.html?

Please link the forum topic and provide more information:

  • which device/platform is affected?
  • which version of OpenWrt are you using
  • have you changed anything (e.g. new OpenWrt version)
  • is it just the pppoe connection that dies or do you loose the vdsl connection (sync) as well (check with /etc/init.d/dsl_control status)
Last edited 2 years ago by mkresin (previous) (diff)

comment:2 Changed 2 years ago by d.buffa@…

No,

the report /ticket/21319.html? is because having problems I tried also the last DD from trunk, and in this way I have no DSL sync and so no ppoe negotiation, a very regression indeed...

Answer to your question, in order:

  • lantiq TP-Link TD-W8970
  • last Chaos Calmer (tried build from source and also the published one http://downloads.openwrt.org/chaos_calmer/15.05/lantiq/xrx200/)
  • no, but when i have dsl working I used an old trunk build, I don't remember wich version... probably isp has changed something, what I know is that with the isp modem connection is working and I have it too with openwrt...
  • seems pppoe that dies... vdsl sync remain, I'll check /etc/init.d/dsl_control status

This is the forum thread https://forum.openwrt.org/viewtopic.php?id=61357

This afternoon I'm ready to test on the remote site for this and 21319 case, so tell me what can I do in order to take usefull information.

Thank you
D.

comment:3 Changed 2 years ago by d.buffa@…

I can confirm that vdsl sync does not die, this is the output of /etc/init.d/dsl_control status command

Chipset:                Lantiq-VRx Unknown
Line State:             UP [0x801: showtime_tc_sync]
Data Rate:              54.000 Mb/s / 10.800 Mb/s
Line Attenuation:       8.9dB / 0.0dB
Noise Margin:           15.8dB / 14.2dB
Line Uptime:            2m 15s

There is something wrong after pppoe authentication, as I wrote in the most detailed post about DD test https://dev.openwrt.org/ticket/21319#comment:7

Thanks
D.

comment:4 Changed 2 years ago by d.buffa@…

Solution proposed in another ticket https://dev.openwrt.org/ticket/21319#comment:16 solve the problem. I have not tested with CC but i think that is the same issue.

I think you can close

Thanks

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.