Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#21320 closed defect (not_a_bug)

802.1ac has not worked on TP-LINK Archer c7 v2.0 for at least a month, maybe longer

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

My 802.11ac network has been completely disabled in these builds for at least the last month or perhaps even longer. It looks like some kind of wireless firmware error (perhaps QCA988X-related?)  Judging by the trunk build log this might have started around r47454 or shortly before, I think? Either way, none of the the recent builds, including the most recent, r47772 allow me to use 802.11ac though 802.11n still works fine. I believe below is the relevant portion of the system log indicating the error. Note, this does not occur on the working build I am currently on (r46849). I have attached the buggy system log as well as a log from a r46849 where 802.11ac works properly.

Sun Dec  6 10:03:13 2015 kern.warn kernel: [   11.584480] ath10k_pci 0000:01:00.0: Falling back to user helper
Sun Dec  6 10:03:13 2015 kern.err kernel: [   11.676037] firmware ath10k!cal-pci-0000:01:00.0.bin: firmware_loading_store: map pages failed
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   11.684987] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-5.bin failed with error -2
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   11.695865] ath10k_pci 0000:01:00.0: Falling back to user helper
Sun Dec  6 10:03:13 2015 kern.err kernel: [   11.770500] firmware ath10k!QCA988X!hw2.0!firmware-5.bin: firmware_loading_store: map pages failed
Sun Dec  6 10:03:13 2015 kern.err kernel: [   11.779775] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA988X/hw2.0/firmware-5.bin': -11
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   11.789906] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-4.bin failed with error -2
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   11.800758] ath10k_pci 0000:01:00.0: Falling back to user helper
Sun Dec  6 10:03:13 2015 kern.err kernel: [   11.876610] firmware ath10k!QCA988X!hw2.0!firmware-4.bin: firmware_loading_store: map pages failed
Sun Dec  6 10:03:13 2015 kern.err kernel: [   11.885884] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA988X/hw2.0/firmware-4.bin': -11
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   11.896011] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-3.bin failed with error -2
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   11.906872] ath10k_pci 0000:01:00.0: Falling back to user helper
Sun Dec  6 10:03:13 2015 kern.err kernel: [   11.982419] firmware ath10k!QCA988X!hw2.0!firmware-3.bin: firmware_loading_store: map pages failed
Sun Dec  6 10:03:13 2015 kern.err kernel: [   11.991697] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA988X/hw2.0/firmware-3.bin': -11
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   12.001822] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware-2.bin failed with error -2
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   12.012683] ath10k_pci 0000:01:00.0: Falling back to user helper
Sun Dec  6 10:03:13 2015 kern.err kernel: [   12.088771] firmware ath10k!QCA988X!hw2.0!firmware-2.bin: firmware_loading_store: map pages failed
Sun Dec  6 10:03:13 2015 kern.err kernel: [   12.098045] ath10k_pci 0000:01:00.0: could not fetch firmware file 'ath10k/QCA988X/hw2.0/firmware-2.bin': -11
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   12.108170] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/QCA988X/hw2.0/firmware.bin failed with error -2
Sun Dec  6 10:03:13 2015 kern.warn kernel: [   12.118855] ath10k_pci 0000:01:00.0: Falling back to user helper
Sun Dec  6 10:03:13 2015 kern.err kernel: [   12.206983] firmware ath10k!QCA988X!hw2.0!firmware.bin: firmware_loading_store: map pages failed
Sun Dec  6 10:03:13 2015 kern.err kernel: [   12.216066] ath10k_pci 0000:01:00.0: could not fetch firmware (-11)
Sun Dec  6 10:03:13 2015 kern.err kernel: [   12.222463] ath10k_pci 0000:01:00.0: could not fetch firmware files (-11)
Sun Dec  6 10:03:13 2015 kern.err kernel: [   12.229353] ath10k_pci 0000:01:00.0: could not probe fw (-11)

Attachments (1)

broken_and_working_log.txt (37.0 KB) - added by anonymous 2 years ago.

Download all attachments as: .zip

Change History (5)

Changed 2 years ago by anonymous

comment:1 Changed 2 years ago by anonymous

Nevermind. I FINALLY managed to fix this. The problem is that /lib/firmware is completely empty. I fixed it by creating the directory: /lib/firmware/ath10k/QCA988X/hw2.0

and using firmware-5.bin_10.2.4.70.14-2 (renamed to firmware-5.bin) and board.bin from https://github.com/kvalo/ath10k-firmware/tree/master/QCA988X as hinted at in this ticket

comment:2 Changed 2 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

you need to select ath10k-firmware-qca988x (or install it via opkg)

comment:3 Changed 2 years ago by anonymous

There is no package ath10k-firmware-qca988x.

root@OpenWrt:~# opkg update
...
root@OpenWrt:~# opkg install ath10k-firmware-qca988x
Unknown package 'ath10k-firmware-qca988x'.
Collected errors:
 * opkg_install_cmd: Cannot install package ath10k-firmware-qca988x.

comment:4 Changed 2 years ago by nbd

what version of openwrt is this?

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.