Modify

Opened 11 years ago

Closed 9 years ago

Last modified 4 years ago

#2126 closed enhancement (wontfix)

new package: msniff

Reported by: jake1981@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: new package msniff Cc:

Description

msniff is a tool for sniffing messages sent and received by msn messenger. Here's diff to add it to packages..

Attachments (4)

msniff.diff (86.1 KB) - added by jake1981@… 11 years ago.
msniff.diff
msniff.2.diff (17.0 KB) - added by jake1981@… 11 years ago.
this one works
msniff.3.diff (2.1 KB) - added by jake1981@… 11 years ago.
fixed, previous diff contained something not necessary for this package..
msniff-0.1.3.tar.gz (4.4 KB) - added by jake1981@… 11 years ago.
copy this file to net/msniff/files after using latest diff..

Download all attachments as: .zip

Change History (12)

Changed 11 years ago by jake1981@…

msniff.diff

comment:1 in reply to: ↑ description Changed 11 years ago by jake1981@…

compile of msniff depends on 2 other libraries provided by author of msniff. There would had been better way to do it, but I made a patch that adds missing depends, files are exactly the same that would outcome if you'd download sources for those 2 libraries and unpack them in root of msniff build directory.

comment:2 Changed 11 years ago by florian

  • Milestone changed from Kamikaze 7.07 to Kamikaze

comment:3 Changed 11 years ago by jake1981@…

This package is useless. It compiles nicely and seems to work without any problems, except that it is not doing what it is supposed to do. I made some testing, I tryied this package on my kamikaze system and it wasn't able to capture messages from MSN, I then compiled in natively on my kamikaze to verify that problem is not with my package, same results, then I compiled it on my x86 gentoo linux and executed while I started tmsnc on another console and none of messages were captured.

I have previous version (0.1.0) on my other wrt as natively compiled, it works very nicely and is even smaller binary than this is, unfortunately it is not available on author's website and therefore I cannot make package from that version.

It is also possible that I don't know how to properly use this software(problem with user, not with software), but in 30 minutes I was not able to find out why messages are not captured. Maybe I should check sources..

I am not sure if this package should or should not be included in packages, there seems to be nothing wrong with this software in a way that it doesn't have errors or happen to be unstable or anything, but my first impression of it was that it doesn't do anything.

comment:4 Changed 11 years ago by florian

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2128

comment:5 Changed 11 years ago by anonymous

It's not a duplicate, it another program that does the same thing..

Changed 11 years ago by jake1981@…

this one works

Changed 11 years ago by jake1981@…

fixed, previous diff contained something not necessary for this package..

Changed 11 years ago by jake1981@…

copy this file to net/msniff/files after using latest diff..

comment:6 Changed 11 years ago by jake1981@…

  • Resolution duplicate deleted
  • Status changed from closed to reopened

latest diff with msniff-0.1.3.tar.gz in files directory of package works perfectly.

Unfortunately this version is not available in internet, so if someone is not going to host it, it must be served locally. Although it could be extracted and included in files directory because it contains less than 10 files and some of those aren't even necessary for compilation (but 2 is needed)

Maybe I'll do that later, unfortunately I'm little bit busy currently..

comment:7 Changed 9 years ago by florian

  • Resolution set to wontfix
  • Status changed from reopened to closed

This program now requires (version 0.2.0) at least 3 libraries by the same guy to work, so I will not add this for the moment.

comment:8 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.