Modify

Opened 11 years ago

Closed 11 years ago

Last modified 6 years ago

#2115 closed defect (wontfix)

syslog error entry: [opening netlink]: Failed setsockopt: Protocol not available. (non-critical)

Reported by: jake1981@… Owned by: developers
Priority: normal Milestone:
Component: other Version:
Keywords: netlink setsockopt protocol not available non-critical Cc:

Description

When you first build and install kamikaze from trunk it usually lacks 2 packages: hotplug2 and udevtrigger. It will boot and work just fine without these 2, but syslog will have entry about missing hotplug2. So we install hotplug2, after a reboot syslog informs that we are missing file again, udevtrigger, so we will install that too. No longer files missing but a new entry in syslog is found:

[opening netlink]: Failed setsockopt: Protocol not available. (non-critical)

Router will boot and work just fine with this error in syslog, but I still think, it's an error so it should be fixed. I have no information about it's origin, except that it's caused by net scripts of hotplug2. This error propably occurs on other routers as well, but I have tested existency of this error with wrt54gs v1 and v4 running 2.4 version of kernel.

It's easy to re-producy, build kamikaze from trunk, install hotplug2 and udevtrigger(udevtrigger is not an option in buildroot's menuconfig, you need to add it by hand to .config file) and set your syslog to start at 01 (before boot script).

I used syslog-ng, but syslogd should produce same error also. To be able to set your syslog to start at 01, you need to change it's initscript. Before starting it, add:
mkdir -p /var/log

As normally boot script(which is executed later) is creating this dir. Also if you want to use syslog-ng, you should edit boot script and comment out these 3 rows:
config_get log_ip "$cfg" log_ip
syslogd -C16 ${log_ip:+-L -R $log_ip}
klogd

Attachments (0)

Change History (1)

comment:1 Changed 11 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

We wrote code that is meant to be working with both 2.4 and 2.6 kernels. Netlink is a 2.6 feature, and therefore, syslog will catch this error.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.