Modify

Opened 11 years ago

Closed 8 years ago

Last modified 4 years ago

#2108 closed defect (obsolete)

ixp4xx has maximum squashfs or jffs2 rootfs size of 8M

Reported by: lschweiss Owned by: rwhitby
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Kamikaze trunk
Keywords: Cc:

Description

This problem appears to be because the NSLU2 image is always built, but for Gateworks boards many have 16 and 32 meg flash chips.

Probably best solution is to optionally not build the NSLU2 image.

Attachments (0)

Change History (11)

comment:1 Changed 10 years ago by kaloz

  • Owner changed from developers to rwhitby

Probably slugimage should only display a warning - still thinking on the real solution, tho..

comment:2 Changed 10 years ago by uniix@…

How to disable the build of NSLU2 image?

comment:3 Changed 10 years ago by uniix@…

I think this is more related to kernel 2.6.23 as when I tried to revert to 2.6.16 it worked. However when I tried to load module using insmod it returned an error "Illegal instruction".

comment:4 Changed 10 years ago by anonymous

are you using the default toolchain combo or enabled something else in developer options? the default is binutils 2.17+gcc 4.1.2

comment:5 Changed 10 years ago by uniix@…

I'm using binutils 2.18+gcc 4.1.2. Should I switch to binutils 2.17+gcc 4.1.2 instead?

comment:6 Changed 10 years ago by kaloz

That's a different issue then what the ticket was about then. Anyways, backported a fix in [10079].

comment:7 Changed 10 years ago by uniix@…

Thank you for the patch. Now the zImage is OK. However, after loading booting & while loading an Intel IXP-NPE driver the system hanged without any errors. FYI, I'm using kernel 2.6.23_14

comment:8 Changed 10 years ago by kaloz

Which board are you using? Is it an officially supported one? Please open a separate ticket for this issue.

comment:10 Changed 10 years ago by uniix@…

FYI, I already revert to use binutils 2.17 but that does not help.

comment:11 Changed 8 years ago by thepeople

  • Resolution set to obsolete
  • Status changed from new to closed
  • Version set to Kamikaze trunk

[patchteam] This seems obsolete, if it is still an issue please submit a new ticket.

comment:12 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.