Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#2107 closed defect (worksforme)

minicom does not compile

Reported by: ggp81 Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: kamikaze minicom buildroot compile error Cc:

Description

Minicom does not compile (tried on r7243 and 7.06). It sounds like a problem with termcap library functions.
This is my Buildroot output:

make -C minicom compile
make[3]: Entering directory `/home/mydir/kamikaze_7.06/package/minicom'
make -C /home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2
make[4]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2'
make  all-recursive
make[5]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2'
Making all in doc
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/doc'
make[6]: Nothing to be done for `all'.
make[6]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/doc'
Making all in extras
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
Making all in linux
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/linux'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/linux'
Making all in tables
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/tables'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/tables'
Making all in termcap
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/termcap'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/termcap'
Making all in terminfo
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/terminfo'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/terminfo'
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
make[7]: Nothing to be done for `all-am'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
make[6]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
Making all in man
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/man'
make[6]: Nothing to be done for `all'.
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
Making all in linux
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/linux'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/linux'
Making all in tables
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/tables'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/tables'
Making all in termcap
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/termcap'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/termcap'
Making all in terminfo
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/terminfo'
make[7]: Nothing to be done for `all'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras/terminfo'
make[7]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
make[7]: Nothing to be done for `all-am'.
make[7]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
make[6]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/extras'
Making all in man
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/man'
make[6]: Nothing to be done for `all'.
make[6]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/man'
Making all in po
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/po'
make[6]: Nothing to be done for `all'.
make[6]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/po'
Making all in lib
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/lib'
make[6]: Nothing to be done for `all'.
make[6]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/lib'
Making all in src
make[6]: Entering directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/src'
if mipsel-linux-uclibc-gcc -DHAVE_CONFIG_H -I. -I. -I..  -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/usr/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/usr/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/include -I../lib -DCONFDIR=\"/etc\" -DLOCALEDIR=\"/usr/share/locale\" -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/usr/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/usr/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/include -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/usr/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/include
-Wall -W -Os -pipe -mips32 -mtune=mips32 -funit-at-a-time -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/usr/include -I/home/mydir/kamikaze_7.06/staging_dir_mipsel/include -MT window.o -MD -MP -MF ".deps/window.Tpo" -c -o window.o window.c; \
        then mv -f ".deps/window.Tpo" ".deps/window.Po"; else rm -f ".deps/window.Tpo"; exit 1; fi
window.c: In function `outstr':
window.c:195: error: too many arguments to function `tputs'
window.c: In function `_gotoxy':
window.c:296: error: too many arguments to function `tgoto'
window.c:304: error: too many arguments to function `tgoto'
window.c:340: error: `BC' undeclared (first use in this function)
window.c:340: error: (Each undeclared identifier is reported only once
window.c:340: error: for each function it appears in.)
window.c:343: error: too many arguments to function `tgoto'
window.c: In function `wscroll':
window.c:846: error: too many arguments to function `tgoto'
window.c:857: error: too many arguments to function `tgoto'
window.c: In function `win_init':
window.c:1944: error: too many arguments to function `tgetent'
window.c:1956: error: too many arguments to function `tgetstr'
window.c:1965: error: too many arguments to function `tgetnum'
window.c:1969: error: too many arguments to function `tgetnum'
window.c:1975: error: too many arguments to function `tgetstr'
window.c:1976: error: too many arguments to function `tgetstr'
window.c:1977: error: too many arguments to function `tgetstr'
window.c:1978: error: too many arguments to function `tgetstr'
window.c:1979: error: too many arguments to function `tgetstr'
window.c:1980: error: too many arguments to function `tgetstr'
window.c:1981: error: too many arguments to function `tgetstr'
window.c:1982: error: too many arguments to function `tgetstr'
window.c:1983: error: too many arguments to function `tgetstr'
window.c:1984: error: too many arguments to function `tgetstr'
window.c:1985: error: too many arguments to function `tgetstr'
window.c:1986: error: too many arguments to function `tgetstr'
window.c:1987: error: too many arguments to function `tgetstr'
window.c:1988: error: too many arguments to function `tgetstr'
window.c:1989: error: too many arguments to function `tgetstr'
window.c:1990: error: too many arguments to function `tgetstr'
window.c:1991: error: too many arguments to function `tgetstr'
window.c:1992: error: too many arguments to function `tgetstr'
window.c:1993: error: too many arguments to function `tgetstr'
window.c:1994: error: too many arguments to function `tgetstr'
window.c:1995: error: too many arguments to function `tgetstr'
window.c:1996: error: too many arguments to function `tgetstr'
window.c:1997: error: too many arguments to function `tgetstr'
window.c:1998: error: too many arguments to function `tgetstr'
window.c:1999: error: too many arguments to function `tgetstr'
window.c:2000: error: too many arguments to function `tgetstr'
window.c:2001: error: too many arguments to function `tgetstr'
window.c:2002: error: too many arguments to function `tgetstr'
window.c:2003: error: too many arguments to function `tgetstr'
window.c:2004: error: too many arguments to function `tgetstr'
window.c:2005: error: `BC' undeclared (first use in this function)
window.c:2005: error: too many arguments to function `tgetstr'
window.c:2006: error: too many arguments to function `tgetstr'
window.c:2007: error: too many arguments to function `tgetstr'
window.c:2008: error: too many arguments to function `tgetstr'
window.c:2009: error: too many arguments to function `tgetstr'
window.c:2011: error: too many arguments to function `tgetstr'
window.c:2012: error: too many arguments to function `tgetstr'
window.c:2013: error: too many arguments to function `tgetstr'
window.c:2038: error: too many arguments to function `tgetflag'
window.c:2038: error: too many arguments to function `tgetflag'
window.c:2058: error: too many arguments to function `tgetnum'
window.c:2061: error: too many arguments to function `tgetflag'
window.c:2062: error: too many arguments to function `tgetflag'
window.c:2063: error: too many arguments to function `tgetflag'
make[6]: *** [window.o] Error 1
make[6]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/src'
make[5]: *** [all-recursive] Error 1
make[5]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2'
make[4]: *** [all] Error 2
make[4]: Leaving directory `/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2'
make[3]: *** [/home/mydir/kamikaze_7.06/build_mipsel/minicom-2.2-rc2/.built] Error 2
make[3]: Leaving directory `/home/mydir/kamikaze_7.06/package/minicom'
make[2]: *** [minicom-compile] Error 2
make[2]: Leaving directory `/home/mydir/kamikaze_7.06/package'
make[1]: *** [package/compile] Error 2
make[1]: Leaving directory `/home/mydir/kamikaze_7.06'
make: *** [world] Error 2

Attachments (0)

Change History (4)

comment:1 Changed 11 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce the bug, have you resolved the ncurses dependency ?

comment:2 Changed 11 years ago by anonymous

Now works for me too, but into ncurses Makefile I had to replace all "libncurses" occurences into "ncurses"

comment:3 Changed 11 years ago by ggp81

Now works for me too, but into ncurses Makefile I had to replace all "libncurses" occurences into "ncurses"

comment:4 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.