Modify

Opened 2 years ago

Last modified 2 years ago

#20986 new defect

5ghz not functioning on Archer C7 v2 with 15.05 factory bin

Reported by: spam@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Chaos Calmer 15.05
Keywords: ath10k Cc:

Description

I've just installed https://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/openwrt-15.05-ar71xx-generic-archer-c7-v2-squashfs-factory.bin

onto my Archer c7 v2. The wifi interface will not come up. Luci gui says it is enabled but has 0% tx power.

dmesg | grep ath10k says:

[   11.920000] ath10k_pci 0000:01:00.0: pci irq legacy interrupts 0 irq_mode 0 reset_mode 0
[   12.140000] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
[   12.150000] ath10k_pci 0000:01:00.0: Falling back to user helper
[   12.220000] firmware ath10k!cal-pci-0000:01:00.0.bin: firmware_loading_store: map pages failed
[   12.450000] ath10k_pci 0000:01:00.0: otp stream is empty, using board.bin contents
[   13.490000] ath10k_pci 0000:01:00.0: qca988x hw2.0 (0x4100016c, 0x043202ff) fw 10.2.4.45 api 4 htt 2.1 wmi 5 cal otp max_sta 128
[   13.500000] ath10k_pci 0000:01:00.0: debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[   23.810000] ath10k_pci 0000:01:00.0: otp stream is empty, using board.bin contents

iw list says:

Wiphy phy0
	max # scan SSIDs: 16
	max scan IEs length: 199 bytes
	Retry short limit: 7
	Retry long limit: 4
	Coverage class: 0 (up to 0m)
	Device supports AP-side u-APSD.
	Available Antennas: TX 0x7 RX 0x7
	Configured Antennas: TX 0x7 RX 0x7
	Supported interface modes:
		 * managed
		 * AP
		 * AP/VLAN
		 * monitor
	Band 2:
		Capabilities: 0x19e3
			RX LDPC
			HT20/HT40
			Static SM Power Save
			RX HT20 SGI
			RX HT40 SGI
			TX STBC
			RX STBC 1-stream
			Max AMSDU length: 7935 bytes
			DSSS/CCK HT40
		Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
		Minimum RX AMPDU time spacing: 8 usec (0x06)
		HT TX/RX MCS rate indexes supported: 0-23
		VHT Capabilities (0x338001b2):
			Max MPDU length: 11454
			Supported Channel Width: neither 160 nor 80+80
			RX LDPC
			short GI (80 MHz)
			TX STBC
			RX antenna pattern consistency
			TX antenna pattern consistency
		VHT RX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: MCS 0-9
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT RX highest supported: 0 Mbps
		VHT TX MCS set:
			1 streams: MCS 0-9
			2 streams: MCS 0-9
			3 streams: MCS 0-9
			4 streams: not supported
			5 streams: not supported
			6 streams: not supported
			7 streams: not supported
			8 streams: not supported
		VHT TX highest supported: 0 Mbps
		Frequencies:
			* 5180 MHz [36] (17.0 dBm)
			* 5200 MHz [40] (17.0 dBm)
			* 5220 MHz [44] (17.0 dBm)
			* 5240 MHz [48] (17.0 dBm)
			* 5260 MHz [52] (23.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 194 sec)
			  DFS CAC time: 60000 ms
			* 5280 MHz [56] (23.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 194 sec)
			  DFS CAC time: 60000 ms
			* 5300 MHz [60] (23.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 194 sec)
			  DFS CAC time: 60000 ms
			* 5320 MHz [64] (23.0 dBm) (no IR, radar detection)
			  DFS state: usable (for 194 sec)
			  DFS CAC time: 60000 ms
			* 5500 MHz [100] (disabled)
			* 5520 MHz [104] (disabled)
			* 5540 MHz [108] (disabled)
			* 5560 MHz [112] (disabled)
			* 5580 MHz [116] (disabled)
			* 5600 MHz [120] (disabled)
			* 5620 MHz [124] (disabled)
			* 5640 MHz [128] (disabled)
			* 5660 MHz [132] (disabled)
			* 5680 MHz [136] (disabled)
			* 5700 MHz [140] (disabled)
			* 5745 MHz [149] (30.0 dBm)
			* 5765 MHz [153] (30.0 dBm)
			* 5785 MHz [157] (30.0 dBm)
			* 5805 MHz [161] (30.0 dBm)
			* 5825 MHz [165] (30.0 dBm)
	valid interface combinations:
		 * #{ AP } <= 8,
		   total <= 8, #channels <= 1, STA/AP BI must match, radar detect widths: { 20 MHz (no HT), 20 MHz, 40 MHz, 80 MHz }

	HT Capability overrides:
		 * MCS: ff ff ff ff ff ff ff ff ff ff
		 * maximum A-MSDU length
		 * supported channel width
		 * short GI for 40 MHz
		 * max A-MPDU length exponent
		 * min MPDU start spacing

I've done opkg update && opkg upgrade kmod-ath10k. Not sure what else to do.

Attachments (0)

Change History (9)

comment:1 Changed 2 years ago by spam@…

I tried making a symlink to the firmware-4.bin with:

cd /lib/firmware/ath10k && ln -s QCA998X/hw2.0/firmware-4.bin cal-pci-0000:01:00.0.bin

It at least gave a different output:

[   11.920000] ath10k_pci 0000:01:00.0: pci irq legacy interrupts 0 irq_mode 0 reset_mode 0
[   13.290000] ath10k_pci 0000:01:00.0: firmware crashed! (uuid b04787af-4bc3-42e3-b09d-4f358ca50a97)
[   13.300000] ath10k_pci 0000:01:00.0: qca988x hw2.0 (0x4100016c, 0x043202ff) fw 10.2.4.45 api 4 htt 0.0 wmi 5 cal file max_sta 128
[   13.310000] ath10k_pci 0000:01:00.0: debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[   13.320000] ath10k_pci 0000:01:00.0: firmware register dump:
[   13.330000] ath10k_pci 0000:01:00.0: [00]: 0x4100016C 0x00000000 0x009BA406 0x000C048F
[   13.340000] ath10k_pci 0000:01:00.0: [04]: 0x009BA406 0x00060530 0x00000003 0x00000005
[   13.340000] ath10k_pci 0000:01:00.0: [08]: 0x00000002 0x00000000 0x00000009 0x8CE048CE
[   13.350000] ath10k_pci 0000:01:00.0: [12]: 0x00000009 0x00000000 0x00958360 0x0095836B
[   13.360000] ath10k_pci 0000:01:00.0: [16]: 0x00958080 0x0094085D 0x00000000 0x00000000
[   13.370000] ath10k_pci 0000:01:00.0: [20]: 0x409BA406 0x0040AB04 0x00000009 0x00000002
[   13.380000] ath10k_pci 0000:01:00.0: [24]: 0x8098772E 0x0040AB64 0x0000145A 0xC09BA406
[   13.390000] ath10k_pci 0000:01:00.0: [28]: 0x809849E2 0x0040AB94 0x00000001 0x00000000
[   13.390000] ath10k_pci 0000:01:00.0: [32]: 0x8098F22B 0x0040ABF4 0x0040E0F0 0x004062DC
[   13.400000] ath10k_pci 0000:01:00.0: [36]: 0x8098A1FD 0x0040AC44 0x0040ACA4 0x004062DC
[   13.410000] ath10k_pci 0000:01:00.0: [40]: 0x80988539 0x0040ACA4 0x004104C0 0x00400000
[   13.420000] ath10k_pci 0000:01:00.0: [44]: 0x8098A86B 0x0040AD44 0x004104C0 0x00000001
[   13.430000] ath10k_pci 0000:01:00.0: [48]: 0x809B4E60 0x0040AD84 0x004104C0 0x00000010
[   13.430000] ath10k_pci 0000:01:00.0: [52]: 0x809B1024 0x0040ADA4 0x00400000 0x00416C64
[   13.440000] ath10k_pci 0000:01:00.0: [56]: 0x809BEE09 0x0040ADE4 0x0040AE08 0x00411DD8
[   18.290000] ath10k_pci 0000:01:00.0: wmi unified ready event not received
[   18.390000] ath10k_pci 0000:01:00.0: could not init core (-145)
[   18.390000] ath10k_pci 0000:01:00.0: could not probe fw (-145)
[   18.480000] ath10k_pci 0000:01:00.0: cannot restart a device that hasn't been started

I also tried downloading the latest ath10k firmware from https://github.com/kvalo/ath10k-firmware/tree/master/QCA988X/10.2 based on https://wireless.wiki.kernel.org/en/users/Drivers/ath10k/firmware but got basically the same firmware dump.

comment:2 Changed 2 years ago by spam@…

Just tried flashing the sysupgrade image. Same dump as the original:

[   59.640000] ath10k_pci 0000:01:00.0: pci irq legacy interrupts 0 irq_mode 0 reset_mode 0
[   59.860000] ath10k_pci 0000:01:00.0: Direct firmware load for ath10k/cal-pci-0000:01:00.0.bin failed with error -2
[   59.870000] ath10k_pci 0000:01:00.0: Falling back to user helper
[   59.940000] firmware ath10k!cal-pci-0000:01:00.0.bin: firmware_loading_store: map pages failed
[   60.170000] ath10k_pci 0000:01:00.0: otp stream is empty, using board.bin contents
[   61.200000] ath10k_pci 0000:01:00.0: qca988x hw2.0 (0x4100016c, 0x043202ff) fw 10.2.4.45 api 4 htt 2.1 wmi 5 cal otp max_sta 128
[   61.210000] ath10k_pci 0000:01:00.0: debug 0 debugfs 1 tracing 0 dfs 1 testmode 1
[   71.970000] ath10k_pci 0000:01:00.0: otp stream is empty, using board.bin contents

comment:3 Changed 2 years ago by anonymous

I've had no problems with this HW+SW combination.
FW 10.2.4.45 ( and 10.2.4.48 from kvalo github) work fine.
You cant use the firmware-5 images with CC 15.05, only firmware-4 or earlier,
and it will use the highest numbered firmware-N.bin file it finds in the FW dir.

Probably a wlan config issue. Your dmesg and iw list look the same as mine except for
the country-specific regulatory details. What channel and width are you trying to use?

What are your radio0 settings in /etc/config/wireless?

Note that the HW doesnt support 160Mhz channel width but VHT80 is fine.

comment:4 Changed 2 years ago by spam@…

Thanks for the response.

I've tried:

channel 36 at 40hz and 80hz
channel 149 at 40hz and 80hz
channel auto at 80hz (which seems to choose channel 52)

Here's my /etc/config/wireless:

config wifi-device 'radio0'
        option type 'mac80211'
        option hwmode '11a'
        option path 'pci0000:01/0000:01:00.0'
        option country 'US'
        option channel 'auto'
        option htmode 'VHT80'
        option txpower '10'

config wifi-device 'radio1'
        option type 'mac80211'
        option hwmode '11g'
        option path 'platform/qca955x_wmac'
        option txpower '23'
        option country 'US'
        option htmode 'HT40'
        option channel '9'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'trash'
        option network 'trash'
        option encryption 'psk2'
        option key 'password2'

config wifi-iface
        option device 'radio1'
        option mode 'ap'
        option ssid 'net1'
        option network 'net1'
        option encryption 'psk2'
        option key 'password1'

config wifi-iface
        option device 'radio0'
        option mode 'ap'
        option ssid 'OpenWrt'
        option encryption 'none'
        option network 'net1'

I've tried txpower at 10 and 17 on radio0, also.

comment:5 Changed 2 years ago by spam@…

Finally got it after starting completely over. Thanks.

comment:6 Changed 2 years ago by anonymous

Im in the same boat.

@spam: How did you resolve it?

comment:7 Changed 2 years ago by dpk.com@…

Im in the same boat.

@spam: How did you resolve it?

comment:8 Changed 2 years ago by anonymous

Same here. I found some forum threads telling me to install the firmware via opkg, but there's no package for it. I'll try the github one when I come home, really hope that changes something.

comment:9 Changed 2 years ago by anonymous

Remove kmod-ath10k and install again. This fixed my 5ghz trouble 😊

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.