Modify

Opened 2 years ago

Last modified 2 years ago

#20985 new defect

Xiaomi MiWiFi Mini (openwrt-ramips-mt7620-miwifi) clients remain connected but consistently lose net access on 2.4GHz wifi after short period

Reported by: davidacampbell Owned by: developers
Priority: high Milestone: Designated Driver (Trunk)
Component: kernel Version: Trunk
Keywords: mt76 wifi 7620 Cc:

Description

I'm running fresh DESIGNATED DRIVER (Bleeding Edge, r47548) from https://downloads.openwrt.org/snapshots/trunk/ramips/mt7620/openwrt-ramips-mt7620-miwifi-mini-squashfs-sysupgrade.bin

The 2.4GHz networking works initially but -always- stops working after some short period. Router is close to the computer. Might be short period of inactivity. Short period is like 5 minutes or so.

Clients see the network still connected (not dropped) but no network access works, including ping to the router.

2.4GHz wireless is in N mode, channel 11, 20Mhz width, WPA2-PSK, auto cipher, country Australia.

Disconnect and reconnect by client restores access.

Only the boot messages are shown by dmesg, no new messages or crashes are visible when this problem happens.

This is from the boot:
[ 15.220000] mt76pci 0000:01:00.0: ASIC revision: 76120044
[ 15.250000] ROM patch build: 20141115060606a
[ 15.260000] Firmware Version: 0.0.00
[ 15.260000] Build: 1
[ 15.260000] Build Time: 201410061140
[ 15.290000] Firmware running!
[ 15.290000] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[ 15.310000] ip_tables: (C) 2000-2006 Netfilter Core Team
[ 15.330000] nf_conntrack version 0.5.0 (1969 buckets, 7876 max)
[ 15.420000] xt_time: kernel timezone is -0000
[ 15.440000] PPP generic driver version 2.4.2
[ 15.440000] NET: Registered protocol family 24
[ 15.470000] ieee80211 phy1: rt2x00_set_rt: Info - RT chipset 5390, rev 0500 detected
[ 15.470000] ieee80211 phy1: rt2x00_set_rf: Info - RF chipset 7620 detected
[ 15.480000] ieee80211 phy1: Selected rate control algorithm 'minstrel_ht'
[ 22.990000] 8021q: adding VLAN 0 to HW filter on device eth0

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by davidacampbell

bug 18931 also speaks of instability in the wifi

My phone reports the signal from the device as strong, both for 2.4GHz and 5Ghz

/etc/config/wireless has:

config wifi-device 'radio0'

option type 'mac80211'
option channel '36'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode 'VHT80'
option country 'AU'
option txpower '17'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option encryption 'psk2'
option key 'XXXXXXXXXXXXX'
option ssid 'xxxxxxxxxxx5G'

config wifi-device 'radio1'

option type 'mac80211'
option channel '11'
option hwmode '11g'
option path '10180000.wmac'
option htmode 'HT20'
option txpower '20'
option country 'AU'

config wifi-iface

option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid 'xxxxxxxxxxx'
option encryption 'psk2'
option key 'XXXXXXXXXXXXX'

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.