Modify

Opened 2 years ago

Closed 2 years ago

#20971 closed defect (fixed)

WDR4300 crashes at boot

Reported by: ivanich Owned by: developers
Priority: high Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

http://git.openwrt.org/?p=openwrt.git;a=commit;h=38efab35acd1d0c459d96d4a26a920390e3988ee

commit prevent router to boot, reverting above commit and it dependency http://git.openwrt.org/?p=openwrt.git;a=commit;h=db6331f79e23685d833508e996fa1db5e3a7a003 fixes boot.

Can't provide logs because I have no serial cable.

Attachments (0)

Change History (8)

comment:1 Changed 2 years ago by anonymous

[    0.000000] Linux version 4.1.13 (builduser@build_bot_030) (gcc version 5.2.0 (OpenWrt GCC 5.2.0 r47603) ) #1 Thu Nov 26 01:21:41 CET 2015
[    0.000000] bootconsole [early0] enabled
[    0.000000] CPU0 revision is: 0001974c (MIPS 74Kc)
[    0.000000] SoC: Atheros AR9344 rev 2
[    0.000000] Determined physical RAM map:
[    0.000000]  memory: 08000000 @ 00000000 (usable)
[    0.000000] Zone ranges:
[    0.000000]   Normal   [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Movable zone start for each node
[    0.000000] Early memory node ranges
[    0.000000]   node   0: [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Initmem setup node 0 [mem 0x0000000000000000-0x0000000007ffffff]
[    0.000000] Primary instruction cache 64kB, VIPT, 4-way, linesize 32 bytes.
[    0.000000] Primary data cache 32kB, 4-way, VIPT, cache aliases, linesize 32 bytes
[    0.000000] Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 32512
[    0.000000] Kernel command line:  board=TL-WDR4300  console=ttyS0,115200 rootfstype=squashfs,jffs2 noinitrd
[    0.000000] PID hash table entries: 512 (order: -1, 2048 bytes)
[    0.000000] Dentry cache hash table entries: 16384 (order: 4, 65536 bytes)
[    0.000000] Inode-cache hash table entries: 8192 (order: 3, 32768 bytes)
[    0.000000] Writing ErrCtl register=00000000
[    0.000000] Readback ErrCtl register=00000000
[    0.000000] Memory: 125744K/131072K available (2747K kernel code, 109K rwdata, 536K rodata, 180K init, 190K bss, 5328K reserved, 0K cma-reserved)
[    0.000000] SLUB: HWalign=32, Order=0-3, MinObjects=0, CPUs=1, Nodes=1
[    0.000000] NR_IRQS:83
[    0.000000] Clocks: CPU:560.000MHz, DDR:450.000MHz, AHB:225.000MHz, Ref:40.000MHz
[    0.000000] clocksource MIPS: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 6825930166 ns
[    0.000009] sched_clock: 32 bits at 280MHz, resolution 3ns, wraps every 7669584382ns
[    0.007497] Calibrating delay loop... 278.93 BogoMIPS (lpj=1394688)
[    0.080012] pid_max: default: 32768 minimum: 301
[    0.084575] Mount-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.090907] Mountpoint-cache hash table entries: 1024 (order: 0, 4096 bytes)
[    0.100190] clocksource jiffies: mask: 0xffffffff max_cycles: 0xffffffff, max_idle_ns: 19112604462750000 ns
[    0.110227] NET: Registered protocol family 16
[    0.115632] MIPS: machine is TP-LINK TL-WDR3600/4300/4310
[    0.124123] registering PCI controller with io_map_base unset
[    0.350527] PCI host bridge to bus 0000:00
[    0.354472] pci_bus 0000:00: root bus resource [mem 0x10000000-0x13ffffff]
[    0.361058] pci_bus 0000:00: root bus resource [io  0x0000]
[    0.366446] pci_bus 0000:00: root bus resource [??? 0x00000000 flags 0x0]
[    0.372987] pci_bus 0000:00: No busn resource found for root bus, will use [bus 00-ff]
[    0.380699] pci 0000:00:00.0: invalid calibration data
[    0.386009] pci 0000:00:00.0: BAR 0: assigned [mem 0x10000000-0x1001ffff 64bit]
[    0.393052] pci 0000:00:00.0: BAR 6: assigned [mem 0x10020000-0x1002ffff pref]
[    0.399982] pci 0000:00:00.0: using irq 40 for pin 1
[    0.405576] Switched to clocksource MIPS
[    0.410548] NET: Registered protocol family 2
[    0.415655] TCP established hash table entries: 1024 (order: 0, 4096 bytes)
[    0.422334] TCP bind hash table entries: 1024 (order: 0, 4096 bytes)
[    0.428489] TCP: Hash tables configured (established 1024 bind 1024)
[    0.434663] UDP hash table entries: 256 (order: 0, 4096 bytes)
[    0.440276] UDP-Lite hash table entries: 256 (order: 0, 4096 bytes)
[    0.446547] NET: Registered protocol family 1
[    0.451603] futex hash table entries: 256 (order: -1, 3072 bytes)
[    0.476040] squashfs: version 4.0 (2009/01/31) Phillip Lougher
[    0.481619] jffs2: version 2.2 (NAND) (SUMMARY) (LZMA) (RTIME) (CMODE_PRIORITY) (c) 2001-2006 Red Hat, Inc.
[    0.493350] io scheduler noop registered
[    0.497134] io scheduler deadline registered (default)
[    0.502249] Serial: 8250/16550 driver, 1 ports, IRQ sharing disabled
[    0.532219] serial8250.0: ttyS0 at MMIO 0x18020000 (irq = 11, base_baud = 2500000) is a 16550A
[    0.540504] console [ttyS0] enabled
[    0.540504] console [ttyS0] enabled
[    0.547529] bootconsole [early0] disabled
[    0.547529] bootconsole [early0] disabled
[    0.557664] m25p80 spi0.0: found s25fl064k, expected m25p80
[    0.563342] m25p80 spi0.0: s25fl064k (8192 Kbytes)
[    0.569079] spi0.0: no TP-Link header found
[    0.576975] switch0: Atheros AR8327 rev. 4 switch registered on ag71xx-mdio.0
[    0.642220] libphy: ag71xx_mdio: probed
[    1.236918] ag71xx ag71xx.0: connected to PHY at ag71xx-mdio.0:00 [uid=004dd034, driver=Atheros AR8216/AR8236/AR8316]
[    1.248377] eth0: Atheros AG71xx at 0xb9000000, irq 4, mode:RGMII
[    1.256797] NET: Registered protocol family 10
[    1.264654] NET: Registered protocol family 17
[    1.269300] bridge: automatic filtering via arp/ip/ip6tables has been deprecated. Update your scripts to load br_netfilter if you need this.
[    1.282149] Bridge firewalling registered
[    1.286362] 8021q: 802.1Q VLAN Support v1.8
[    1.292871] VFS: Cannot open root device "(null)" or unknown-block(0,0): error -6
[    1.300509] Please append a correct "root=" boot option; here are the available partitions:
[    1.308991] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
[    1.317371] ---[ end Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(0,0)
  CC      fs/sysfs/mount.o
In file included from drivers/mtd/mtd_blkdevs.c:29:0:
drivers/mtd/mtd_blkdevs.c: In function 'do_blktrans_request':
include/linux/blkdev.h:624:26: warning: switch condition has boolean value [-Wswitch-bool]
 #define rq_data_dir(rq)  (((rq)->cmd_flags & 1) != 0)
                          ^
drivers/mtd/mtd_blkdevs.c:100:9: note: in expansion of macro 'rq_data_dir'
  switch(rq_data_dir(req)) {
         ^

comment:2 Changed 2 years ago by adeschenes

I have the same problem with a build from the latest trunk on the Archer C7 v2 and another build I compiled 24 hours ago. Most likely a bunch of other TP-Link routers won't work.

comment:3 Changed 2 years ago by markuznw

Same issue on wdr4900, not booting with latest trunk. Had to revert back to the older r47468 which I was using before upgrade

comment:4 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r47664

comment:5 Changed 2 years ago by andre

  • Resolution fixed deleted
  • Status changed from closed to reopened

Still broken with r47670 on TP-LINK TD-W8970: The root device was not detected.

Reverting these revisions on top of r47670 makes it work again:
47624
47628
47626
47664
47665

Then it's detected and OpenWRT is properly booted:
[ 0.770270] m25p80 spi32766.0: found s25fl064k, expected en25q64
[ 0.774888] m25p80 spi32766.0: s25fl064k (8192 Kbytes)

comment:6 Changed 2 years ago by andre

see also #20975 for the very same issue, just from TP users

comment:7 Changed 2 years ago by bittorf@…

seems #20982 is related.

comment:8 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from reopened to closed

TD-W8970 is a different platform, and the issue is a different one.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.