Modify

Opened 2 years ago

Last modified 22 months ago

#20924 new defect

6in4 interface cannot receive any package when the peer_addr is provided by a wireless relay interface running under 'sta' mode.

Reported by: excelwang Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

6in4 interface cannot receive any package when the peer_addr is provided by a wireless relay interface running under 'sta' mode. However, the old 6in4, version number of which is '17-1', works well.

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by anonymous

Which Openwrt versions you are comparing? Are you now trying with trunk or with CC15.05?

6in4 had version 17 in BB14.07, while the current trunk has version 22 and CC15.05 has 21...

Could you provide more details about your network config. relevant parts of /etc/config/network and /etc/config/wireless

comment:2 Changed 2 years ago by excelwang

I am using CC15.05. I have managed to downgrade the 6in4 from version 22 to 17, then it resumed to work.

##/etc/config/network
...
config interface 'wan'

option proto 'dhcp'
option metric '0'
option hostname 'pc-2013297762233'
option peerdns '0'
option dns '8.8.8.8 8.8.4.4 223.5.5.5 223.6.6.6'

config interface 'wan6'

option proto '6in4'
option peeraddr '216.218.2xx.x'
option ip6addr '2001:470:xxxx::2/64'
option ip6prefix '2001:470:xxxx::/48'
option tunneled 'xxxx'
option username 'xxxx'
option password 'xxxx'
option ipaddr '159.226.189.215'

...

###/etc/config/wireless
...
onfig wifi-iface

option ssid 'CSTXXX'
option encryption 'wpa2'
option device 'radio1'
option mode 'sta'
option bossed 'XXXXXXXX'
option network 'wan'
option identity 'XXXXXXXX'
option password 'XXXXXXXX'
option eap_type 'peap'
option auth 'MSCHAPV2'

...

### output of ifconfig with 6in4 ver.17
6in4-wan6 Link encap:IPv6-in-IPv4

inet6 addr: 2001:470:xxxx::2/64 Scope:Global
inet6 addr: fe80::9fe2:bdd7/64 Scope:Link
UP POINTOPOINT RUNNING NOARP MTU:1280 Metric:1
RX packets:506950 errors:0 dropped:0 overruns:0 frame:0
TX packets:315770 errors:0 dropped:1 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:534681682 (509.9 MiB) TX bytes:52984987 (50.5 MiB)

...

wlan0 Link encap:Ethernet HWaddr XXXXXXXXXXXX

inet6 addr: fe80::bed1:77ff:fe09:1d6c/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:22141 errors:0 dropped:0 overruns:0 frame:0
TX packets:27555 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:1925388 (1.8 MiB) TX bytes:20413411 (19.4 MiB)

wlan1 Link encap:Ethernet HWaddr XXXXXXXXXXXX

inet addr:159.226.189.215 Bcast:159.226.189.255 Mask:255.255.255.0
inet6 addr: fe80::16fe:b5ff:fee1:488d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:668289 errors:0 dropped:0 overruns:0 frame:0
TX packets:414456 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:668640676 (637.6 MiB) TX bytes:82938124 (79.0 MiB)

wlan1-1 Link encap:Ethernet HWaddr XXXXXXXXXXXX

inet6 addr: fe80::bed1:77ff:fe09:1d6d/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:191417 errors:0 dropped:0 overruns:0 frame:0
TX packets:258609 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:36054391 (34.3 MiB) TX bytes:271348543 (258.7 MiB)

comment:3 in reply to: ↑ description Changed 2 years ago by excelwang

Replying to excelwang:

6in4 interface cannot receive any package when the peer_addr is provided by a wireless relay interface running under 'sta' mode. However, the old 6in4, version number of which is '17-1', works well.


Minor fix to the problem description: "...when the peer_addr is provided by a wireless relay..." --> "...when the ipaddr is provided by a wireless relay..."

comment:4 Changed 22 months ago by excelwang

This issue have been addressed in openwrt release 15.05.1, by assign the static route of the peeraddr to the target interface (the wireless relay network interface).

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.