Modify

Opened 2 years ago

Closed 2 years ago

#20826 closed defect (not_a_bug)

date (from busybox) +%k not working

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Designated Driver (Trunk)
Component: base system Version: Trunk
Keywords: Cc:

Description

BusyBox v1.23.2 (2015-10-30 01:50:37 CET) built-in shell (ash)

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

-----------------------------------------------------
DESIGNATED DRIVER (Bleeding Edge, r47280)
-----------------------------------------------------

  • 2 oz. Orange Juice Combine all juices in a
  • 2 oz. Pineapple Juice tall glass filled with
  • 2 oz. Grapefruit Juice ice, stir well.
  • 2 oz. Cranberry Juice

-----------------------------------------------------

root@OpenWrt:~# date +%k

root@OpenWrt:~#

Compile default profile to WNDR4300.

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by dibdot

not a bug: use date '+%H' instead

comment:2 Changed 2 years ago by anonymous

"date +%H": Yes - this option working to DD (trunk).
CC - working "date +%k" and "date +%H"...whel...
bug...or not bug ?

comment:3 Changed 2 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

%k is non-standard, and is not implemented by the musl libc

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.