Modify

Opened 2 years ago

Closed 2 years ago

#20819 closed defect (not_a_bug)

Alfa Hornet ART offset for Mac addresses and WiFI calibration data incorrect

Reported by: lsoltero Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Chaos Calmer 15.05
Keywords: Cc:

Description

Hello All,
I think there might be an issue with the ART address offset in the Alfa hornet board definition files in CC 15.05.
Alfa makes the hornet-ub and hornet-hsb (used in the Tube2h product) boards which come in 8M and 16M flash versions. The openwrt make system supports both flash models. However.. there is only one board definition file for each of the hornet-us and tube2h boards.
mach-hornet-ub.c is used for both the 8M and 16M of flash models of the hornet-ub board
mach-tube2h.c used in the 8M and 16M of flash models of the hornet-hsb/tube2h product.
for the 8M models the ART partition starts at 0x00f7f0000 and 0x00ff0000 for the 16M versions.
However...
mach-horent-ub.c has an offset of 0x1fff0000 hardcoded for the ART offset. here is a code snippet

u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);

ath79_init_mac(ath79_eth1_data.mac_addr,

art + HORNET_UB_MAC0_OFFSET, 0);

ath79_init_mac(ath79_eth0_data.mac_addr,

art + HORNET_UB_MAC1_OFFSET, 0);

ath79_register_wmac(art + HORNET_UB_CALDATA_OFFSET, NULL);

similarly the tube2h board file has an offset of 0x1ff7f0000 hardcoded in its board definition file file.
#define TUBE2H_ART_ADDRESS 0x1f7f0000

u8 *art = (u8 *) KSEG1ADDR(TUBE2H_ART_ADDRESS);
ath79_register_wmac(art + TUBE2H_CALDATA_OFFSET, NULL);
ath79_init_mac(ath79_eth0_data.mac_addr,

art + TUBE2H_LAN_MAC_OFFSET, 0);


Nowhere in the build system do I see where the ART offsets get modified when building the firmware for as specific board model.
My concern is that without the correct offset the WiFI calibration (and mac addresses) don't get initialized correctly.
Can anyone shed light on whether this is really a problem or if somewhere behind the openwrt build machinery these offsets are magically adjusted appropriately?
Thanks,
--luis

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by nbd

  • Resolution set to not_a_bug
  • Status changed from new to closed

This is not a bug. On smaller flash chips, the memory space aliases, meaning that the contents of 0x1f7f0000 and 0x1fff0000 refer to the same location.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.