Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20757 closed defect (not_a_bug)

New Hardware Revision 10 on TP-Link TL-WR841N(D)

Reported by: j.tuvix@… Owned by: developers
Priority: high Milestone:
Component: base system Version: Chaos Calmer 15.05
Keywords: wr841, v10 Cc:

Description

There is a new revision from TP-Link on the popular TL-WR841N(D), which has some problem, even if the hardware seems to be the same except for higher cpu speed.

There is a hacked firmware which just changes the header to make it compatible with the original firmware update process.

But the wifi reception is very bad. Maybe TP-Link changed the GPIOs for the amplifiers or something?

See these forum topics for more infos:

https://forum.openwrt.org/viewtopic.php?pid=294826

https://forum.openwrt.org/viewtopic.php?pid=292409

And please backport the fix to 15.05, thanks in advance!

Attachments (3)

02.jpg (155.3 KB) - added by anonymous 2 years ago.
01.jpg (81.2 KB) - added by mahadiinfo@… 2 years ago.
WiFi Signal problem
02.2.jpg (155.3 KB) - added by mahadiinfo@… 2 years ago.
WiFi Signal problem

Download all attachments as: .zip

Change History (31)

comment:1 Changed 2 years ago by anonymous

please fix Antennas............

comment:4 in reply to: ↑ 3 Changed 2 years ago by anonymous

Replying to anonymous:

The changes necessary made it into OpenWrt trunk:
http://git.openwrt.org/?p=openwrt.git;a=commitdiff;h=75c0f8d51ffe17a64ccd31a0b38f3fa8c119d8dd
http://git.openwrt.org/?p=openwrt.git;a=commitdiff;h=1cd7e6c1fd07527d2a6a7660c85e7e90160956a9
...please backport to CC, too.

I do not understand you please wake image
and I can try it

comment:5 Changed 2 years ago by anonymous

+1

comment:6 Changed 2 years ago by anonymous

+1

comment:7 Changed 2 years ago by anonymous

+1

comment:8 Changed 2 years ago by anonymous

CC is still not fixed. Please backport

comment:9 Changed 2 years ago by marcobuijs@…

+1

Just wondering, if this has been fixed, will it also be available instantly through the "OpenWRT Image Generator (Image Builder) => https://wiki.openwrt.org/doc/howto/obtain.firmware.generate"?

comment:10 Changed 2 years ago by anonymous

+1

Is there a chance to get this also into Barrier Breaker?

comment:11 Changed 2 years ago by anonymous

+1 please make a image for us

comment:12 Changed 2 years ago by anonymous

+1

comment:13 follow-ups: Changed 2 years ago by anonymous

+1 important

Changed 2 years ago by anonymous

Changed 2 years ago by mahadiinfo@…

WiFi Signal problem

Changed 2 years ago by mahadiinfo@…

WiFi Signal problem

comment:14 in reply to: ↑ 13 ; follow-up: Changed 2 years ago by anonymous

Replying to anonymous:

+1 important

comment:15 in reply to: ↑ 14 Changed 2 years ago by anonymous

+1 important

comment:16 in reply to: ↑ 13 Changed 2 years ago by anonymous

Replying to anonymous:

+1 important

+1

comment:17 Changed 2 years ago by kouber@…

+1

Is the issue fixed in the "unofficial third party hack" image, provided on the site?

comment:18 Changed 2 years ago by reg

No, that has issues which everyone is asking a fix for :)

comment:19 Changed 2 years ago by jow

  • Resolution set to not_a_bug
  • Status changed from new to closed

Please stop spamming "+1" responses, we do no priorize tickets on the number of votes. Also please submit the required changes according to SubmittingPatches. Finally no, it will not get backported to BB.

Since this is a feature request and not a bug report, I'll close this. Please follow up on the mailing lists.

comment:20 Changed 2 years ago by kouber@…

What is a "feature request"? Is the wi-fi working properly on 15.05 or not? This is an important question, given version 10 is everywhere on the market now.

comment:21 Changed 2 years ago by jow

As far as I can see, support rev 10 has not been added to 15.05 so broken wifi is not even a problem there to begin with. Adding support for rev 10 to 15.05 would be a feature request which is certainly doable with the following things to keep in mind:

  • Proper patch adressing proper branch has to be sent to the development list
  • Updated images will not be made available until another point release for 15.05 is made

comment:22 Changed 2 years ago by anonymous

do you have to find a way to solve this problem?

comment:23 follow-ups: Changed 2 years ago by anonymous

I also just bought the TL-WR841N and it has the V10. So I can not flash the firmware. I hope that there will be an image for the V10 soon. Thank you.

comment:24 in reply to: ↑ 23 Changed 2 years ago by daniel.petre@…

Replying to anonymous:

I also just bought the TL-WR841N and it has the V10. So I can not flash the firmware. I hope that there will be an image for the V10 soon. Thank you.

If you are really eager to replace the original firmware you can use my customized OpenWrt (CC):
https://swrt.ro/descarcare/#1444232309304-9ff7ded1-141a

comment:25 Changed 2 years ago by zoon

@anoymous,all:

Maybe i misinterpretate what i read here, but usage of the V10 isn't a problem! Just use the snaphot version w/o LuCI, or use image-maker to make one based on that snapshotV10 w LuCI, or take the already image-maker compiled version in the forum thread, or the version hack from the forum. So this brand new hardware can be used, can't it ?
bst.rgards zoon(politikon)

comment:26 in reply to: ↑ 23 ; follow-up: Changed 2 years ago by anonymous

I have compiled a unofficial 15.05 image
https://forum.openwrt.org/viewtopic.php?pid=300231#p300231

comment:27 in reply to: ↑ 26 Changed 2 years ago by anonymous

Replying to anonymous:

I have compiled a unofficial 15.05 image
https://forum.openwrt.org/viewtopic.php?pid=300231#p300231

Are those links still working? Cause they don't work for me :(

comment:28 Changed 2 years ago by anonymous

The download links have been updated by jamest42, the images are now available again.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.