Opened 11 years ago

Closed 9 years ago

Last modified 4 years ago

#2074 closed defect (fixed)

MTU change problem

Reported by: mfricke@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version:
Keywords: Cc:



  • a running PPPoE connection configured via /etc/config/network with "option mtu 1492" being set
  • after a successful PPPoE connect ip change with a script in /etc/ppp/ip-up.d/ which just does a "ifconfig eth0" to make eth0 usable again


  • "ifconfig eth0 mtu xxxx" resets the PPPoE connection and "forces" a re-dail
  • after ppp0 is back up, eth0's MTU is again back at 1500

Attachments (0)

Change History (6)

comment:1 Changed 10 years ago by florian

Can you retest again now ?

comment:2 Changed 10 years ago by mfricke@…

i'm running kamikaze 7.09 now, and everything is still the same. i grabbed some logs, maybe they will help you out...
(first line came up when i typed 'ifconfig eth0 mtu 1492')

Oct 12 18:07:19 (none) daemon.notice pppd[696]: Modem hangup
Oct 12 18:07:19 (none) pppd[696]: Connect time 400.3 minutes.
Oct 12 18:07:19 (none) pppd[696]: Sent 6644048 bytes, received 216236149 bytes.
Oct 12 18:07:19 (none) daemon.warn pppd[696]: Couldn't increase MTU to 1500
Oct 12 18:07:19 (none) daemon.warn pppd[696]: Couldn't increase MRU to 1500
Oct 12 18:07:19 (none) daemon.notice pppd[696]: Connection terminated.
Oct 12 18:07:49 (none) daemon.err pppd[696]: Interface eth0 has MTU of 1492 -- should be 1500.  You may have serious connection problems.
Oct 12 18:07:49 (none) pppd[696]: PPP session is 14973
Oct 12 18:07:49 (none) pppd[696]: Using interface ppp0
Oct 12 18:07:49 (none) daemon.notice pppd[696]: Connect: ppp0 <--> eth0
Oct 12 18:07:49 (none) daemon.warn pppd[696]: Couldn't increase MRU to 1500

--- SNIP ----

the rest is normal pppd behaviour for opening a PPPoE connection

comment:3 Changed 10 years ago by uncleneg@…

I have same problem (and I think a lot of people have this also).
I have a lot of warning messages after disconnect or connect to a pppoe: "Couldn't increase MTU to 1500". Sometimes the connection is terminated.
I tried to change MTU to value from 1400 to 1500, but it doesn't help.
(Kamikaze 7.09 Kernel 2.4.34)

comment:4 Changed 9 years ago by stoile@…

I have the same problem. Is someone still working on this bug?

comment:5 Changed 9 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Should be fixed now if not please re-open.

comment:6 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

as closed .
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.