Modify

Opened 2 years ago

Last modified 2 years ago

#20734 new defect

sunxi boot fail

Reported by: anonymous Owned by: developers
Priority: high Milestone:
Component: kernel Version: Trunk
Keywords: Cc:

Description

I habe tried to boot my Bananapi with the last trunk image.

  1. the uboot files are missing in the Directory
  2. I tried to boot with the uboot form 15.05 reposity and i compile the uboot 2015.07. Both are not able to boot the kernel Image.

When i tried to compile the image from git, the make menueconfig exit with an error. After save i can't open the menueconfig again?

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by redfox1977

After Boot the System hang at:

U-Boot SPL 2015.07 (Oct 10 2015 - 13:07:59)
DRAM: 1024 MiB
CPU: 912000000Hz, AXI/AHB/APB: 3/2/2


U-Boot 2015.07 (Oct 10 2015 - 13:07:59 +0200) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
I2C:   ready
DRAM:  1 GiB
MMC:   SUNXI SD/MMC: 0
*** Warning - bad CRC, using default environment

HDMI connected: Setting up a 1920x1080 hdmi console
In:    serial
Out:   vga
Err:   vga
SCSI:  SUNXI SCSI INIT
SATA link 0 timeout.
AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
flags: ncq stag pm led clo only pmp pio slum part ccc apst
Net:   eth0: ethernet@01c50000
starting USB...
USB0:   USB EHCI 1.00
USB1:   USB OHCI 1.0
USB2:   USB EHCI 1.00
USB3:   USB OHCI 1.0
scanning bus 0 for devices... 1 USB Device(s) found
scanning bus 2 for devices... 1 USB Device(s) found
Hit any key to stop autoboot:  0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot.scr
reading /boot.scr
377 bytes read in 28 ms (12.7 KiB/s)
## Executing script at 43100000
reading uImage
2253080 bytes read in 144 ms (14.9 MiB/s)
reading dtb
23549 bytes read in 35 ms (656.3 KiB/s)
## Booting kernel from Legacy Image at 42000000 ...
   Image Name:   ARM OpenWrt Linux-4.1.10
   Image Type:   ARM Linux Kernel Image (uncompressed)
   Data Size:    2253016 Bytes = 2.1 MiB
   Load Address: 40008000
   Entry Point:  40008000
   Verifying Checksum ... OK
## Flattened Device Tree blob at 43000000
   Booting using the fdt blob at 0x43000000
   Loading Kernel Image ... OK
   Using Device Tree in place at 43000000, end 43008bfc
Cannot setup simplefb: node not found

Starting kernel ...

I have tried to compile a kernel with the imagebuilder this hangs too.
With the 15.05'er kernel it works?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.