Modify

Opened 11 years ago

Closed 10 years ago

Last modified 6 years ago

#2071 closed defect (worksforme)

suggested wds configuration not working on broadcom

Reported by: seniorr@… Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

On r7885 (plus the patch from r7901), trying to establish a link with a madwifi-ng wds peer (based on a Metrix Pyramid 1.0b5 image), the configuration suggested in ticket #2050 is not working (not passing traffic). The hardware in this case is a Buffalo WHRG54S.

/etc/config/wireless:

config wifi-device  wl0
        option type     broadcom
        option channel  1
        option disabled 0

config wifi-iface
       option device   wl0
       option network  wifi
       option mode     ap 
       option ssid     myssid
       option encryption none

config wifi-iface
        option device   wl0
        option network  wifi
        option mode     wds
        option ssid     myssid
        option bssid    00:0B:6B:xx:yy:zz
        option encryption none

/etc/config/network:

#### VLAN configuration 
config switch eth0
        option vlan0    "1 2 3 4 5*"
        option vlan1    "0 5"


#### Loopback configuration
config interface loopback
        option ifname   "lo"
        option proto    static
        option ipaddr   127.0.0.1
        option netmask  255.0.0.0


#### LAN configuration
config interface lan
        option type     bridge
        option ifname   "eth0.0"
        option proto    static
        option ipaddr   192.168.1.1
        option netmask  255.255.255.0


#### WAN configuration
config interface        wan
        option ifname   "eth0.1"
        option proto    none # dhcp

config interface        wifi
        option type     bridge
        option proto    static
        option ipaddr   10.xx.yy.zz
        option netmask  255.255.252.0
        option gateway  10.xx.yy.1

It appears the wds0.1 is not added to the br-wifi bridge. Also, the wds0.1 interface is not up. Adding those two operations manually seems to do the trick:

brctl addif br-wifi wds0.1
ifconfig wds0.1 up

Attachments (0)

Change History (2)

comment:1 Changed 10 years ago by KadettGTE ... devilboy@…

i opened a topic about it yesterday, i kind of solved it automatically and with support for multiple wds connections

http://forum.openwrt.org/viewtopic.php?id=12216

comment:2 Changed 10 years ago by thepeople

  • Resolution set to worksforme
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.