Modify

Opened 2 years ago

Closed 2 years ago

#20688 closed defect (fixed)

CC: connectivity down after pppoe reconnect (ifup wan)

Reported by: anonymous Owned by: developers
Priority: high Milestone:
Component: base system Version: Chaos Calmer 15.05
Keywords: Cc:

Description

I'm pretty sure this started with the latest bump of netifd in CC (final).

Manually running 'fw3 restart' after the link is up will restore connectivity.

root@x:~# ifup wan
root@x:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network is unreachable
root@x:~# waiting 20 seconds...
-ash: waiting: not found
root@x:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network is unreachable
root@x:~# fw3 restart
 * Flushing IPv4 filter table
 * Flushing IPv4 nat table
 * Flushing IPv4 mangle table
 * Flushing IPv4 raw table
 * Flushing IPv6 filter table
 * Flushing IPv6 mangle table
 * Flushing IPv6 raw table
 * Flushing conntrack table ...
 * Populating IPv4 filter table
   * Zone 'lan'
   * Zone 'wan'
   * Zone 'dmz'
   * Zone 'wlan'
   * Rule 'Allow-DHCP-Renew'
   * Rule 'wlan-dhcp'
   * Rule 'wlan-dns'
   * Forward 'dmz' -> 'wan'
   * Forward 'lan' -> 'dmz'
   * Forward 'lan' -> 'wan'
   * Forward 'wlan' -> 'wan'
   * Forward 'lan' -> 'wlan'
 * Populating IPv4 nat table
   * Zone 'lan'
   * Zone 'wan'
   * Zone 'dmz'
   * Zone 'wlan'
 * Populating IPv4 mangle table
   * Zone 'lan'
   * Zone 'wan'
   * Zone 'dmz'
   * Zone 'wlan'
 * Populating IPv4 raw table
   * Zone 'lan'
   * Zone 'wan'
   * Zone 'dmz'
   * Zone 'wlan'
 * Populating IPv6 filter table
   * Zone 'lan'
   * Zone 'wan'
   * Zone 'dmz'
   * Zone 'wlan'
   * Rule 'Allow-DHCPv6'
   * Rule 'Allow-ICMPv6-Input'
   * Rule 'Allow-ICMPv6-Forward'
   * Forward 'dmz' -> 'wan'
   * Forward 'lan' -> 'dmz'
   * Forward 'lan' -> 'wan'
   * Forward 'wlan' -> 'wan'
   * Forward 'lan' -> 'wlan'
 * Populating IPv6 mangle table
   * Zone 'lan'
   * Zone 'wan'   * Zone 'dmz'
   * Zone 'wlan'
 * Populating IPv6 raw table
   * Zone 'lan'
   * Zone 'wan'
   * Zone 'dmz'
   * Zone 'wlan'
 * Set tcp_ecn to off
 * Set tcp_syncookies to on
 * Set tcp_window_scaling to on
 * Running script '/etc/firewall.user'
 * Running script '/usr/share/miniupnpd/firewall.include'
root@x:~# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=53 time=67.171 ms
64 bytes from 8.8.8.8: seq=1 ttl=53 time=67.152 ms
64 bytes from 8.8.8.8: seq=2 ttl=53 time=67.669 ms
^C
--- 8.8.8.8 ping statistics ---
3 packets transmitted, 3 packets received, 0% packet loss
round-trip min/avg/max = 67.152/67.330/67.669 ms
root@x:~# 

The problem does appear to go away when resetting to a default configuration. So I assume it's something in the configuration that triggers it. The same configuration used to work fine up until a short time ago. The same configuration also works fine with trunk DD.

root@x:~# cat /etc/config/network 

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'xxxxxxxxxx::/48'

config interface 'lan'
	option force_link '1'
	option type 'bridge'
	option proto 'static'
	option netmask '255.255.255.0'
	option _orig_ifname 'eth0.1 wlan0'
	option _orig_bridge 'true'
	option ifname 'eth0.1'
	option ipaddr 'x'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option mirror_source_port '0'
	option mirror_monitor_port '0'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option vid '1'
	option ports '0t 2'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0t 1'
	option vid '2'

config interface 'wan'
	option proto 'pppoe'
	option ifname 'eth0.2'
	option _orig_ifname 'eth0.2'
	option _orig_bridge 'false'
	option password 'x'
	option username 'x'
	option ipv6 '0'

config switch_vlan
	option device 'switch0'
	option vlan '3'
	option vid '3'
	option ports '0t 5'

config interface 'dmz'
	option proto 'static'
	option ifname 'eth0.3'
	option netmask '255.255.255.0'
	option type 'bridge'
	option ipaddr 'x'

config interface 'modem'
	option proto 'static'
	option ifname 'eth0.2'
	option ipaddr 'x'
	option netmask '255.255.255.0'

config switch_vlan
	option device 'switch0'
	option vlan '4'
	option vid '99'
	option ports '0t 4 5t'

config interface 'dmz_wlan'
	option ifname 'eth0.99'
	option type 'bridge'
	option _orig_ifname 'eth0.99 wlan0-1'
	option _orig_bridge 'true'
	option proto 'none'

config interface 'wlan'
	option type 'bridge'
	option _orig_ifname 'wlan0 wlan1'
	option _orig_bridge 'true'
	option proto 'static'
	option ipaddr 'x'
	option netmask '255.255.255.0'

config switch_vlan
	option device 'switch0'
	option vlan '5'
	option vid '10'
	option ports '0t 2t 3 4t'

config interface 'lan_wlan'
	option proto 'none'
	option ifname 'eth0.10'
	option auto '1'
	option type 'bridge'

root@x:~# 

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by anonymous

with the most recent build of CC this problem appears to be solved by itself.

comment:2 Changed 2 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.