Modify

Opened 2 years ago

Last modified 2 years ago

#20678 new defect

Bridge Problem with Avila 2348

Reported by: anonymous Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Chaos Calmer 15.05
Keywords: Cc:

Description

<Also posted to forums:
https://forum.openwrt.org/viewtopic.php?pid=294651#p294651

I am upgrading my Avila boards from BB to CC and running into an issue with bridging. This one is stumping me and not sure what else to do to debug.
The initial symptom was with packets not being bridged between eth0 and wlan0 (ap) mode. However, some problem exists for the bridge on eth0 and eth1.

Here's the problem with eth0 & eth1
Avila board has 2 ethernets ports. I have change /etc/config/network file to include both eth0 and eth1 in the "lan" bridge
there is no WAN interface on this unit, as it will be used as a basic AP.

I have updated /etc/config/network to give this unit IP: 192.168.2.5
there's another router on the lan called 192.168.2.1

to test connectivity, I ran
ping 192.168.2.1

basically, ping is successful if my ethernet cable is plugged into eth0, but not if plugged into eth1.

here's the output on the console, as I ping 192.168.2.1 with cable in eth0 and switch to eth1

# ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1): 56 data bytes
64 bytes from 192.168.2.1: seq=0 ttl=64 time=1.156 ms
64 bytes from 192.168.2.1: seq=1 ttl=64 time=20.327 ms
64 bytes from 192.168.2.1: seq=2 ttl=64 time=0.908 ms
64 bytes from 192.168.2.1: seq=3 ttl=64 time=0.943 ms
[ 1762.334719] eth0: link down      <unplugged the cable>
[ 1762.337743] br-lan: port 1(eth0) entered disabled state
[ 1766.335016] eth1: link up, speed 100 Mb/s, full duplex    <plugged the cable in eth1>
[ 1766.340218] br-lan: port 2(eth1) entered forwarding state
[ 1766.345770] br-lan: port 2(eth1) entered forwarding state
[ 1768.344610] br-lan: port 2(eth1) entered forwarding state
^C
--- 192.168.2.1 ping statistics ---
16 packets transmitted, 4 packets received, 75% packet loss
round-trip min/avg/max = 0.908/5.833/20.327 ms

# ping 192.168.2.1
PING 192.168.2.1 (192.168.2.1): 56 data bytes
^C
--- 192.168.2.1 ping statistics ---
4 packets transmitted, 0 packets received, 100% packet loss  <eth1 not working...>

Here is the output of of some commands, hopefully relevant

all /etc/config file are the default, except for what's here.

my /etc/config/network

config interface 'loopback'
        option ifname 'lo'
        option proto 'static'
        option ipaddr '127.0.0.1'
        option netmask '255.0.0.0'

config interface 'lan'
        option ifname 'eth0 eth1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.2.5'
        option netmask '255.255.255.0'
        option ip6assign '60'

config globals 'globals'
        option ula_prefix 'fdf5:1d6b:6248::/48'

output of brctl command

# brctl show
bridge name     bridge id               STP enabled     interfaces
br-lan          7fff.00d0124bde0a       no              eth0
                                                        eth1

output of bridge command for when cable is in eth1

# bridge link
2: eth0 state DOWN : <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 master br-lan state disabled priority 32 cost 100
3: eth1 state UP : <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 master br-lan state forwarding priority 32 cost 19

here's the output of ifconfig

# ifconfig
br-lan    Link encap:Ethernet  HWaddr 00:D0:12:4B:DE:0A
          inet addr:192.168.2.5  Bcast:192.168.2.255  Mask:255.255.255.0
          inet6 addr: fe80::2d0:12ff:fe4b:de0a/64 Scope:Link
          inet6 addr: fdf5:1d6b:6248::1/60 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:2393 errors:0 dropped:0 overruns:0 frame:0
          TX packets:443 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:324845 (317.2 KiB)  TX bytes:38993 (38.0 KiB)

eth0      Link encap:Ethernet  HWaddr 00:D0:12:4B:DE:0A
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:152 errors:0 dropped:0 overruns:0 frame:0
          TX packets:67 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:14495 (14.1 KiB)  TX bytes:6652 (6.4 KiB)

eth1      Link encap:Ethernet  HWaddr 00:D0:12:4C:DE:0A
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:5369 errors:0 dropped:0 overruns:0 frame:0
          TX packets:414 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:1084729 (1.0 MiB)  TX bytes:35457 (34.6 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2831 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2831 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:191881 (187.3 KiB)  TX bytes:191881 (187.3 KiB)

output of ebtables

#ebtables -L
Bridge table: filter

Bridge chain: INPUT, entries: 0, policy: ACCEPT

Bridge chain: FORWARD, entries: 0, policy: ACCEPT

Bridge chain: OUTPUT, entries: 0, policy: ACCEPT

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by anonymous

any body had a chance to look at this?

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.