Modify

Opened 11 years ago

Closed 11 years ago

Last modified 4 years ago

#2066 closed defect (wontfix)

The openvpn up/down DNS helper scripts don't run

Reported by: tim_freedom@… Owned by: developers
Priority: high Milestone: Barrier Breaker 14.07
Component: packages Version:
Keywords: openvpn Cc:

Description

While using 7.07 and after getting openvpn installed and running I inquired
about how best to automatically update my /etc/resolv.conf and I was told to
use openvpn's up/down capabilities (ie. to call the appopriate scripts from
within the client.conf file). I was informed of the following two scripts
in,

http://svn.openvpn.net/projects/openvpn/trunk/openvpn/contrib/pull-resolv-conf/

yet the scripts have syntax errors within 'em (the openvpn application won't
start if those scripts are included due to invocations errors). For instance
the client.up notes,

48: Syntax error: Bad substitution

where line 48 is,

while fopt=foreign_option_$i; [ -n "${!fopt}" ]; do

Could someone please look into this important/serious topic. While at it do
please also address the fact that those scripts use 'bash' while bash isn't
available on openwrt (ie. s/bash/sh/).

Thanks.

Attachments (0)

Change History (3)

comment:1 Changed 11 years ago by nbd

  • Milestone changed from Kamikaze 7.07 to Kamikaze

comment:2 Changed 11 years ago by florian

  • Resolution set to wontfix
  • Status changed from new to closed

Well, this should rather be reported to the openvpn bug tracking system, we do not maintain such scripts.

comment:3 Changed 4 years ago by jow

  • Milestone changed from Attitude Adjustment 12.09 to Barrier Breaker 14.07

Milestone Attitude Adjustment 12.09 deleted

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.