Modify

Opened 2 years ago

Closed 2 years ago

#20655 closed defect (moved_to_github)

Trunk build broken

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

I have my config I used for the last years and do a trunk compile every month or two, I come from r46687, but newest trunk doesnt compile anymore:

root@dice-edge:~# screen -r
unk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/include  -I../include -I../include -DSYSCONFDIR=\"/etc\" -D_GNU_SOURCE -Wall  -I/home/openwrt/trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include  -I/home/openwrt/trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include/libnl3  -I/home/openwrt/trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/usr/include/libnl3  -Os -pipe -mno-branch-likely -mips32r2 -mtune=34kc -fno-caller-saves -fhonour-copts -Wno-error=unused-but-set-variable -msoft-float -mips16 -minterlink-mips16 -std=gnu99  -MT bmon-in_netlink.o -MD -MP -MF .deps/bmon-in_netlink.Tpo -c -o bmon-in_netlink.o `test -f 'in_netlink.c' || echo './'`in_netlink.c
in_netlink.c:42:29: fatal error: netlink/netlink.h: No such file or directory
 #include <netlink/netlink.h>
                             ^
compilation terminated.
Makefile:649: recipe for target 'bmon-in_netlink.o' failed
make[5]: *** [bmon-in_netlink.o] Error 1
make[5]: Leaving directory '/home/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/bmon-3.8/src'
Makefile:390: recipe for target 'all-recursive' failed
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory '/home/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/bmon-3.8'
Makefile:51: recipe for target '/home/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/bmon-3.8/.built' failed
make[3]: *** [/home/openwrt/trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/bmon-3.8/.built] Error 2
make[3]: Leaving directory '/home/openwrt/trunk/feeds/packages/net/bmon'
package/Makefile:191: recipe for target 'package/feeds/packages/bmon/compile' failed
make[2]: *** [package/feeds/packages/bmon/compile] Error 2
make[2]: Leaving directory '/home/openwrt/trunk'
package/Makefile:188: recipe for target '/home/openwrt/trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.package_compile' failed
make[1]: *** [/home/openwrt/trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.package_compile] Error 2
make[1]: Leaving directory '/home/openwrt/trunk'
/home/openwrt/trunk/include/toplevel.mk:179: recipe for target 'world' failed
make: *** [world] Error 2
openwrt@dice-edge:~/trunk$

It uses some old tools like bmon, which still worked though when I did a last compile of r46687.

Attachments (0)

Change History (3)

comment:1 Changed 2 years ago by anonymous

It seems bmon is broken, I have removed it and now compile runs through. Worked though last time I did a full compile with r46687.

comment:2 Changed 2 years ago by anon2

bmon seems indeed to be broken.
buildbot agrees with you:
http://buildbot.openwrt.org:8010/broken_packages/ar71xx/bmon/compile.txt

But bmon is maintained at the packages repo at github, so the issue should be reported there.

bmon was updated on 3 Sep 15, so that change has probably broken the package for at least some platforms.
https://github.com/openwrt/packages/commits/master/net/bmon

There is also a pull request that might fix things:
https://github.com/openwrt/packages/pull/1832

comment:3 Changed 2 years ago by nbd

  • Resolution set to moved_to_github
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.