Modify

Opened 2 years ago

Closed 2 years ago

#20636 closed defect (invalid)

missing symlinks / missing busybox applets - CC 15.05 / r47065

Reported by: bittorf@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

a totally fresh built for ar71xx / Buffalo WZR-HP-AG300H

i have seen this before, but could not believe it - now again:

root@box:~ echo A,B | cut -d',' -f2
-ash: cut: not found

root@box:~ which cut
-ash: which: not found

root@box:~ /bin/busybox cut --help
BusyBox v1.23.2 (2015-09-29 09:13:23 CEST) multi-call binary.

Usage: cut [OPTIONS] [FILE]...

Print selected fields from each input FILE to stdout

        -b LIST Output only bytes from LIST
        -c LIST Output only characters from LIST
        -d CHAR Use CHAR instead of tab as the field delimiter
        -s      Output only the lines containing delimiter
        -f N    Print only these fields
        -n      Ignored

root@box:~ df -h
Filesystem                Size      Used Available Use% Mounted on
rootfs                   22.0M    784.0K     21.2M   3% /
/dev/root                 8.4M      8.4M         0 100% /rom
tmpfs                    61.6M      1.1M     60.5M   2% /tmp
/dev/mtdblock8           22.0M    784.0K     21.2M   3% /overlay
overlayfs:/overlay       22.0M    784.0K     21.2M   3% /
tmpfs                   512.0K         0    512.0K   0% /dev
tmpfs                    22.0M    784.0K     21.2M   3% /

root@box:~ ls -l /bin
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 ash -> busybox
-rwxr-xr-x    1 root     root           265 Sep 29 08:44 board_detect
-rwxr-xr-x    1 root     root        298188 Sep 29 09:13 busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 cat -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 chgrp -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 chmod -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 chown -> busybox
-rwxr-xr-x    1 root     root          3311 Sep 29 08:44 config_generate
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 cp -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 date -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 dd -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 df -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 dmesg -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 echo -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 egrep -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 false -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 fgrep -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 fsync -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 grep -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 gunzip -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 gzip -> busybox
-rwxr-xr-x    1 root     root          1550 Sep 29 08:44 ipcalc.sh
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 kill -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 ln -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 lock -> busybox
-rwxr-xr-x    1 root     root           729 Sep 29 08:53 login.sh
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 ls -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 mkdir -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 mknod -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 mktemp -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 mount -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 mv -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 netmsg -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 netstat -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 nice -> busybox
-rwxr-xr-x    1 root     root        102180 Sep 29 09:15 opkg
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 pidof -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 ping -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 ping6 -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 ps -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 pwd -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 rm -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 rmdir -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 sed -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 sh -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 sleep -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 sync -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 tar -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 touch -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 true -> busybox
-rwxr-xr-x    1 root     root          8964 Sep 29 09:14 ubus
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 umount -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 uname -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 vi -> busybox
lrwxrwxrwx    1 root     root             7 Sep 29 09:21 zcat -> busybox

root@box:~ ls -l /bin/ | wc -l
-ash: wc: not found

root@box:~ ls -l /bin/ | busybox wc -l
55

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by bittorf@…

the problem is this directory, all symlinks are 'red'

root@box:~ ls -l /usr/bin
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 [ -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 [[ -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 awk -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 basename -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 bunzip2 -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 bzcat -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 clear -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 cmp -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 crontab -> ../../bin/busybox
-rwxr-xr-x    1 root     root         75240 Sep 29 09:15 curl
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 cut -> ../../bin/busybox
-rwxr-xr-x    1 root     root         11004 Sep 29 09:15 cx18-ctl
lrwxrwxrwx    1 root     root            16 Sep 29 09:21 dbclient -> ../sbin/dropbear
-rwxr-xr-x    1 root     root         43836 Sep 29 09:15 decode_tm6000
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 dirname -> ../../bin/busybox
lrwxrwxrwx    1 root     root            16 Sep 29 09:21 dropbearkey -> ../sbin/dropbear
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 du -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 env -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 expr -> ../../bin/busybox
-rwxr-xr-x    1 root     root        177268 Sep 29 09:21 ffmpeg
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 find -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 free -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 head -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 hexdump -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 hostid -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 id -> ../../bin/busybox
-rwxr-xr-x    1 root     root         63452 Sep 29 09:15 ir-keytable
-rwxr-xr-x    1 root     root         15864 Sep 29 09:15 ivtv-ctl
-rwxr-xr-x    1 root     root         14792 Sep 29 09:14 iwinfo
-rwxr-xr-x    1 root     root          8900 Sep 29 09:14 jshn
-rwxr-xr-x    1 root     root         12852 Sep 29 09:14 jsonfilter
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 killall -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 less -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 logger -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 md5sum -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 mkfifo -> ../../bin/busybox
-rwxr-xr-x    1 root     root        165700 Sep 29 09:14 motion
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 nc -> ../../bin/busybox
-rwxr-xr-x    1 root     root          1823 Sep 29 08:53 neigh
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 nslookup -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 passwd -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 pgrep -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 printf -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 readlink -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 reset -> ../../bin/busybox
-rwxr-xr-x    1 root     root          5140 Sep 29 09:13 resolveip
-rwxr-xr-x    1 root     root         14544 Sep 29 09:15 rrdtool
-rwxr-xr-x    1 root     root         11716 Sep 29 09:15 rrdupdate
-rwxr-xr-x    1 root     root          1865 Sep 29 08:53 scheduler
lrwxrwxrwx    1 root     root            16 Sep 29 09:21 scp -> ../sbin/dropbear
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 seq -> ../../bin/busybox
lrwxrwxrwx    1 root     root             5 Sep 29 09:21 signify -> usign
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 sort -> ../../bin/busybox
lrwxrwxrwx    1 root     root            16 Sep 29 09:21 ssh -> ../sbin/dropbear
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 strings -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 tail -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 tee -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 telnet -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 test -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 time -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 top -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 tr -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 traceroute -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 traceroute6 -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 uniq -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 uptime -> ../../bin/busybox
-rwxr-xr-x    1 root     root         23188 Sep 29 09:14 usign
-rwxr-xr-x    1 root     root        173796 Sep 29 09:15 v4l2-compliance
-rwxr-xr-x    1 root     root        212396 Sep 29 09:15 v4l2-ctl
-rwxr-xr-x    1 root     root         34372 Sep 29 09:15 v4l2-sysfs-path
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 wc -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 wget -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 which -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 xargs -> ../../bin/busybox
lrwxrwxrwx    1 root     root            17 Sep 29 09:21 yes -> ../../bin/busybox

root@box:~ cd /usr/bin

root@box:/usr/bin ls -l ../../bin/busybox
ls: ../../bin/busybox: No such file or directory

root@box:/usr/bin ls -l ../
drwxr-xr-x    2 root     root          1051 Sep 29 08:53 bin
drwxr-xr-x    6 root     root          1655 Sep 29 09:21 lib
drwxr-xr-x    2 root     root          1406 Sep 29 08:53 sbin
drwxr-xr-x    6 root     root            73 Sep 29 09:21 share

root@box:/usr/bin ls -l ../../
<empty>

nothing obious in klog/dmesg

comment:2 Changed 2 years ago by jow

But ls -l / looks correct? (/bin, /lib, /usr, etc.)
Is there something special about /usr/bin itself?
Can you check the permissions of /, /bin etc. ?

comment:3 Changed 2 years ago by bittorf@…

ahh! what is wrong here is the 'tmpfs' on '/'
this is a local fuck with *wrong* mounting an additional tmpfs.
please close this ticket and sorry for noise.

root@EG-superbuffi76-MESH:~ mount
rootfs on / type rootfs (rw)
/dev/root on /rom type squashfs (ro,relatime)
proc on /proc type proc (rw,noatime)
sysfs on /sys type sysfs (rw,noatime)
tmpfs on /tmp type tmpfs (rw,nosuid,nodev,noatime)
/dev/mtdblock8 on /overlay type jffs2 (rw,noatime)
overlayfs:/overlay on / type overlay (rw,noatime,lowerdir=/,upperdir=/overlay/upper,workdir=/overlay/work)
tmpfs on /dev type tmpfs (rw,relatime,size=512k,mode=755)
devpts on /dev/pts type devpts (rw,relatime,mode=600)
debugfs on /sys/kernel/debug type debugfs (rw,noatime)
tmpfs on /coredumps type tmpfs (rw,nosuid,nodev,relatime,size=2048k)
tmpfs on / type tmpfs (rw,nosuid,nodev,relatime,size=63076k)

comment:4 Changed 2 years ago by jow

  • Resolution set to invalid
  • Status changed from new to closed

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.