Modify

Opened 2 years ago

Closed 2 years ago

#20607 closed defect (fixed)

LuCI stalls at 'Collecting data...'

Reported by: George-TL Owned by:
Priority: normal Milestone:
Component: luci Version: Trunk
Keywords: luci stall Cc:

Description

Hi,

Model - TP-Link TL-WR842N/ND v2
Firmware Version - OpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45)
Flash image (bin) from OpenWRT page.

After update from BB to CC 'Network/Interfaces' page (and others too) needs much more time (20s) to fill data in "Status" column.

Yes, javascript is enabled.

This is clean upgrade to CC using device recovery mode - full flash. No old configuration.

Regards,
George

Attachments (0)

Change History (15)

comment:1 Changed 2 years ago by anonymous

The same issue (BT Home Hub 5A r47015 / LuCI Master (git-15.262.40644-13f3ad9))
Network/Interfaces page requires much more time than usual.
Status/Overview page never completes.

comment:2 Changed 2 years ago by George-TL

After setting device for my needs web interface started to work just fine.
All my configuration changes were made by LuCI only.
Wild guess that some option mitigates/fixes this bug.
I've second router to update. This time all setup will be done in following order:
a) change one option
b) save
c) check for improvement
d) reboot
e) check for improvement again
Slow but I hope it will help narrow root of this issue.

comment:3 Changed 2 years ago by anonymous

I have this issue when moving from CC to DD.

comment:4 Changed 2 years ago by swalker

  • Resolution set to moved_to_github
  • Status changed from new to closed

luci is maintained here: https://github.com/openwrt/luci

comment:5 Changed 2 years ago by anonymous

Try using Internet Explorer / Edge, it's working there for me but not with Chrome. This problem exists over a year or so.

comment:6 Changed 2 years ago by DocMAX

same issue!

Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: /usr/lib/lua/luci/dispatcher.lua:433: Failed to execute function dispatcher target for entry '/'.
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: The called action terminated with an exception:
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: /usr/lib/lua/luci/dispatcher.lua:433: Failed to execute firstchild dispatcher target for entry '/admin'.
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: The called action terminated with an exception:
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: /usr/lib/lua/luci/dispatcher.lua:433: Failed to execute function dispatcher target for entry '/admin/status'.
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: The called action terminated with an exception:
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: /usr/lib/lua/luci/dispatcher.lua:433: Failed to execute template dispatcher target for entry '/admin/status/overview'.
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: The called action terminated with an exception:
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: /usr/lib/lua/luci/template.lua:97: Failed to execute template 'admin_status/index'.
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: A runtime error occured: [string "/usr/lib/lua/luci/view/admin_status/index.h..."]:85: attempt to call local 'dsl_func' (a nil value)
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: stack traceback:
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: [C]: in function 'assert'
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: /usr/lib/lua/luci/dispatcher.lua:433: in function 'dispatch'
Sat Oct 3 15:25:01 2015 daemon.err uhttpd[1694]: /usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>

comment:7 Changed 2 years ago by DocMAX

  • Resolution moved_to_github deleted
  • Status changed from closed to reopened

comment:8 Changed 2 years ago by anonymous

Also tested with EDGE

comment:9 Changed 2 years ago by DocMAX

root@router:~# /etc/init.d/dsl_control lucistat
local dsl={}
dsl.atuc_vendor_id="B5,00,42,44,43,4D,A1,8E"
dsl.atuc_system_vendor_id="B5,00,42,44,43,4D,00,00"
dsl.chipset="Ifx-AR9 1.2"
dsl.firmware_version="4.4.1.7.0.2"
dsl.api_version="3.24.4.4"
dsl.xtse1=0x0
dsl.xtse2=0x0
dsl.xtse3=0x0
dsl.xtse4=0x0
dsl.xtse5=0x0
dsl.xtse6=0x4
dsl.xtse7=0x0
dsl.xtse8=0x0
dsl.xtse_s="0x0, 0x0, 0x0, 0x0, 0x0, 0x4, 0x0, 0x0"
dsl.annex_s="B"
dsl.line_mode_s="G.992.5 (ADSL2+)"
dsl.line_state_num=0x801
dsl.line_state_detail="showtime_tc_sync"
dsl.line_state="UP"
dsl.errors_fec_near=449
dsl.errors_fec_far=8813
dsl.errors_es_near=0
dsl.errors_es_far=15
dsl.errors_ses_near=0
dsl.errors_ses_far=0
dsl.errors_loss_near=0
dsl.errors_loss_far=0
dsl.errors_uas_near=47
dsl.errors_uas_far=47
dsl.errors_hec_near=0
dsl.errors_hec_far=4306
dsl.errors_crc_p_near=
dsl.errors_crc_p_far=
dsl.errors_crcp_p_near=
dsl.errors_crcp_p_far=
dsl.power_mode_num=0
dsl.power_mode_s="L0 - Synchronized"
dsl.latency_num_down="7.50 ms"
dsl.latency_num_up="8.0 ms"
dsl.latency_s_down="Interleave"
dsl.latency_s_up="Interleave"
dsl.data_rate_down=10708686
dsl.data_rate_up=1112718
dsl.data_rate_down_s="10.708 Mb"
dsl.data_rate_up_s="1.112 Mb"
dsl.line_attenuation_down=22.1
dsl.line_attenuation_up=9.4
dsl.noise_margin_down=9.3
dsl.noise_margin_up=9.4
dsl.signal_attenuation_down=20.6
dsl.signal_attenuation_up=15.3
dsl.actatp_down=18.1
dsl.actatp_up=12.6
dsl.max_data_rate_down=10832000
dsl.max_data_rate_up=1119000
dsl.max_data_rate_down_s="10.832 Mb"
dsl.max_data_rate_up_s="1.119 Mb"
dsl.line_uptime=3408
dsl.line_uptime_s="56m 48s"
return dsl

comment:12 Changed 2 years ago by DocMAX

It seems the problem is still not resolved.
Altthough i have no error in syslog, LUCI still stalls at Collecting data...

comment:13 Changed 2 years ago by anonymous

I have the problem though also on my ar71xx WNDR3800, no dsl modem there at all.

comment:14 Changed 2 years ago by jow

Try clearing your browser cache and make sure you have only one browser tab open with luci.

comment:15 Changed 2 years ago by jow

  • Resolution set to fixed
  • Status changed from reopened to closed

The stall at "Collecting data..." should be fixed with r47161, r47162

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.