Modify

Opened 2 years ago

Last modified 2 years ago

#20591 new defect

pptp error autenticating

Reported by: finas Owned by: developers
Priority: high Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

Just installed lastest source:
OpenWrt Designated Driver r47045 / LuCI Master (git-15.265.73096-a60184d)

and pptp interfaces stoped working. bad auth:

Thu Sep 24 18:58:47 2015 daemon.info pppd[24720]: Using interface pptp-SS
Thu Sep 24 18:58:47 2015 daemon.notice pppd[24720]: Connect: pptp-SS <--> pptp (edited.xxxx.com)
Thu Sep 24 18:58:47 2015 daemon.err pppd[24720]: MS-CHAP authentication failed: Good luck!
Thu Sep 24 18:58:47 2015 daemon.err pppd[24720]: CHAP authentication failed
Thu Sep 24 18:58:47 2015 daemon.notice pppd[24720]: Connection terminated.
Thu Sep 24 18:58:47 2015 daemon.info pppd[24720]: Exit

I haven't changed the config, just regular firmware update.
if I do a "ps" on command line the user and passwords are ok.
I have three diferent pptp interfaces and all they are failing with the same error.

The last firmware that worked and that I was using was from about 2 weeks ago.

Attachments (0)

Change History (11)

comment:1 Changed 2 years ago by finas

I can confirm that it also happens when OpenWRT acts like a pptp server. auth is rejected.

comment:2 Changed 2 years ago by finas

OpenWrt Designated Driver r46941 / LuCI Branch (git-15.265.73096-a60184d) also fails so the problem is before this.

comment:3 Changed 2 years ago by finas

I tried svn://svn.openwrt.org/openwrt/trunk@46797 ( the one with support for 5.2.0 with fix ) and the problem remains, so then I tried to build an even older version:

OpenWrt Chaos Calmer r46560 / LuCI Master (git-15.269.59850-64bfe90)

and it works perfectly. The problem lies somewhere between 46560 and 46797.

I have very little time to bissect this. can a developer give me a hint on what revision to try?

In the tests I made I didn't downgrade the packages so I'm using the latest packages.

The ones that don't work are also all built with gcc 5.2.0 and the one that worked with gcc 4.9


comment:4 Changed 2 years ago by finas

OpenWrt Chaos Calmer r46609 / LuCI Master (git-15.269.59850-64bfe90)

this one also works

comment:5 Changed 2 years ago by finas

OpenWrt Chaos Calmer r46739 / LuCI Master (git-15.269.59850-64bfe90)

this one also works so it appears that the issue appeared between 46739 and 46797, or maybe it's from the GCC 5.2 version?

comment:6 Changed 2 years ago by finas

OpenWrt Chaos Calmer r46821 / LuCI Master (git-15.269.59850-64bfe90)

this one does not work ( built with gcc 4.8 ) so the problem lies between r46739 and r46821

comment:7 Changed 2 years ago by finas

OpenWrt Chaos Calmer r46815 / LuCI Master (git-15.269.59850-64bfe90)

this one works, so it's now between r46815 and r46821

comment:8 Changed 2 years ago by finas

OpenWrt Chaos Calmer r46816 / LuCI Master (git-15.269.59850-64bfe90)

does not work so it is with this commit that the problem started.

comment:9 Changed 2 years ago by finas

nbd?

comment:10 Changed 2 years ago by finas

anyone?

comment:11 Changed 2 years ago by finas

working with latest source.

Thanks!

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.