Modify

Opened 2 years ago

Last modified 2 years ago

#20539 new defect

Unable to handle kernel paging request (CC release, Olinuxino, amixer)

Reported by: rmanzanares@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Olinuxino, amixer, Chaos Calmer release Cc:

Description

alsamixer/amixer don't work anymore with the CC release on an Olinuxino Maxi board (obtained with 'git clone git://git.openwrt.org/15.05/openwrt.git').
It worked with CC RC3 and Linux 3.18.14 but not with Linux 3.18.20/21 (the release has changed?)

CHAOS CALMER (Chaos Calmer, r46943)

-----------------------------------------------------

  • 1 1/2 oz Gin Shake with a glassful
  • 1/4 oz Triple Sec of broken ice and pour
  • 3/4 oz Lime Juice unstrained into a goblet.
  • 1 1/2 oz Orange Juice
  • 1 tsp. Grenadine Syrup

-----------------------------------------------------

root@OpenWrt:/# amixer[ 61.150000] random: nonblocking pool is initialized
[ 66.730000] Unable to handle kernel paging request at virtual address ffffff04
[ 66.740000] pgd = c2cbc000
[ 66.740000] [ffffff04] *pgd=43ffd831, *pte=00000000, *ppte=00000000
[ 66.750000] Internal error: Oops: 17 #1 ARM
[ 66.750000] Modules linked in: pppoe ppp_async iptable_nat smsc95xx pppox ppp_generic nf_nat_ipv4 nf_conntrack_ipv6 nf_conntrack_ipv4 ipt_REJECT ipt_MASQUERADE xt_time xt_tcpudp xt_state xt_nat xt_multiport xt_mark xt_mac xt_limit xt_id xt_conntrack xt_comment xt_TCPMSS xt_REDIRECT xt_LOG xt_CT usbnet spi_mxs slhc nf_reject_ipv4 nf_nat_masquerade_ipv4 nf_nat_ftp nf_nat nf_log_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 nf_conntrack_rtcache nf_conntrack_ftp nf_conntrack iptable_raw iptable_mangle iptable_filter ip_tables crc_ccitt mxs_dcp mxs_lradc snd_soc_mxs_builtin_audio snd_soc_mxs_builtin_codec snd_soc_mxs_builtin_dai snd_soc_mxs_builtin_pcm snd_soc_core industrialio_triggered_buffer i2c_mxs stmp3xxx_rtc_wdt rtc_stmp3xxx ledtrig_heartbeat ip6t_REJECT nf_reject_ipv6 nf_log_ipv6 nf_log_common ip6table_raw ip6table_mangle ip6table_filter ip6_tables x_tables gpio_mcp23s08 snd_pcm_dmaengine snd_compress snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd_rawmidi snd_seq_device snd_hwdep snd soundcore ipv6 des_generic authenc crypto_blkcipher leds_gpio phy_mxs_usb ci_hdrc_imx usbmisc_imx ci_hdrc udc_core mii aead
[ 66.750000] CPU: 0 PID: 898 Comm: amixer Not tainted 3.18.21 #1
[ 66.750000] task: c2c79aa0 ti: c2c6e000 task.ti: c2c6e000
[ 66.750000] PC is at dac_get_volsw+0x18/0x80 [snd_soc_mxs_builtin_codec]
[ 66.750000] LR is at snd_ctl_ioctl+0x584/0xb08 [snd]

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by rmanzanares@…

I'm trying to find the version when amixer stopped working and I've realized that it didn't worked with Linux 3.18.14.
I'm just sure that it worked with Linux 3.14.

comment:2 Changed 2 years ago by rmanzanares@…

r45087 was the last one with mxs Linux 3.14 support.
I've tested it with 3.18.9 kernel and amixer failed to work.
Nevertheless, I've been able to make it work after setting the KERNEL_PATCHVER to 3.14.
I hope this helps to solve the defect.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.