Modify

Opened 2 years ago

Last modified 2 years ago

#20488 new defect

Archer C5 5 GHz radio missing in CC final

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

This was working in rc2, at least.

root@OpenWrt:~# iwinfo 
wlan0     ESSID: unknown
          Access Point: 00:00:00:00:00:00
          Mode: Client  Channel: unknown (unknown)
          Tx-Power: 20 dBm  Link Quality: unknown/70
          Signal: unknown  Noise: unknown
          Bit Rate: unknown
          Encryption: unknown
          Type: nl80211  HW Mode(s): 802.11bgn
          Hardware: unknown [Generic MAC80211]
          TX power offset: unknown
          Frequency offset: unknown
          Supports VAPs: yes  PHY name: phy0

Attachments (0)

Change History (9)

comment:1 follow-up: Changed 2 years ago by anonymous

opkg update && opkg install kmod-ath10k

comment:2 in reply to: ↑ 1 Changed 2 years ago by anonymous

Replying to anonymous:

opkg update && opkg install kmod-ath10k

Thanks, that (and a reboot) solved it.

This should be built-in for the Archer C5, though.

comment:3 Changed 2 years ago by asayler

This is an issue with Archer C7 as well. CC rc3 worked fine, but the release seems to be missing the the 10k driver.

Furthermore, I get the following error trying to install by hand:

$ opkg install kmod-ath10k
Installing kmod-ath10k (3.18.17+2015-03-09-3) to root...
Downloading http://downloads.openwrt.org/chaos_calmer/15.05-rc3/ar71xx/generic/packages/base/kmod-ath10k_3.18.17+2015-03-09-3_ar71xx.ipk.
Collected errors:
 * satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-ath10k:
 * 	kernel (= 3.18.17-1-5dcb66d04a38219f7fd91c748f0e9a32) * 
 * opkg_install_cmd: Cannot install package kmod-ath10k.

comment:4 Changed 2 years ago by asayler

So I'm able to install kmod-ath10k if I overwrite the opkg sources with the CC defaults:

$ cp /rom/etc/opkg.conf /etc/opkg.conf

But the fact that kmod-ath10k isn't included by default in the C5 or C7 CC release builds is still an issue. Seems to be a regression relative to rc3.

Last edited 2 years ago by asayler (previous) (diff)

comment:5 Changed 2 years ago by ufo@…

on archer c7 v1.1, using imagebuilder openwrt cc final:

[ 12.520000] Data bus error, epc == 87109128, ra == 87109128
[ 12.520000] Oops#1:
[ 12.520000] CPU: 0 PID: 650 Comm: kmodloader Not tainted 3.18.20 #1

http://pastebin.com/KSAg5A6A

comment:6 Changed 2 years ago by asayler

This issue has been brought up in an old ticket as well: /ticket/16589.html.

comment:7 Changed 2 years ago by asayler

This seems to be working again on the latest CC release downloads. Not sure if it was updated without a version bump or what, but today's (10/04/15) download (https://downloads.openwrt.org/chaos_calmer/15.05/ar71xx/generic/openwrt-15.05-ar71xx-generic-archer-c7-v2-squashfs-sysupgrade.bin) seems to work (md5: 7e359b386242b066ed439e6a96212bff).

That said, this build seems to have dropped Luci TLS/SSL support. See /ticket/20671.html.

comment:8 follow-up: Changed 2 years ago by Tomin

I downloaded and installed this version of OpenWRT and 5 GHz is not working.
https://downloads.openwrt.org/latest/ar71xx/generic/openwrt-15.05-ar71xx-generic-archer-c5-squashfs-factory.bin

Should I try the sysupgrade image mentioned on comment above or what?

comment:9 in reply to: ↑ 8 Changed 2 years ago by Tomin

Replying to Tomin:

Should I try the sysupgrade image mentioned on comment above or what?

Oh, just noticed that it's for C7 v2.0. Mine is C5 1.20.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.