Modify

Opened 2 years ago

Last modified 22 months ago

#20475 new defect

No WLAN available if router cant connect to WWAN

Reported by: frietpan Owned by: developers
Priority: high Milestone:
Component: base system Version: Trunk
Keywords: WLAN, wifi, SSID, Travel, Lockout, Connect Cc:

Description

When i configure OpenWRT With a WWAN SSID that connects to another router to connect to the web and a WLAN SSID (or multiple WLAN SSID's) All works fine.

But, when the WWAN SSID is not available WWAN does not connect AND as a result WLAN does not seem to come alive.
In case of the ever more populair travel router this is a massive headache.

In case you travel with a travel router you need to connect to different SSID's when you are at different locations. So this is going to lock people out. More so because the idea of wireless travel routers is traveling without wires...
The only way to access the router is by using a CAT cable or over UART. But that's not in everyones backpack.

I have tested this on:

  • NEXX WT3020 (Mediatek 7620) with CCrc2 and CCrc3
  • GL.iNet 6416 and D-link DIR-505 (both Atheros 3133) With BB and CCrc3

When WLAN is not connected the Atheros devices behave a little different then the Mediatek
When adding WLAN's to the device they seem to be activated for a little wile however the wrong SSID becomes active. (not the one I last configured)

dmesg and log: I will add ASAP

So what I at least expect:
Since WLAN's are configured I expext that WLAN's will become available even when the router isn't able to connect to a WWAN. So that a traveler can still access his travel router. And is not forced to travel with CAT cable. (and people with tablet or Android they don't even have a RJ45 connector so it's even worse..)

Another thing that gets messed up is NoDogSplash. I haven't been able to fully configure NoDogSplash so I can't say much more about this. It's still on my todo list.
When configured on WAN NoDogSplash worked, when I switched to WWAN NoDogSplash nolonger worked. Also not when I went back to WAN. There seems to be a connection to this. But that's all I can say at this point.

Please read this forum topic:
https://forum.openwrt.org/viewtopic.php?pid=291182#p291182
There are a few old bug that seem to be related. But those bugs fail to describe the bigger issue. In my poinion this bug manifest itself in differnt ways depending on different configuration goals. So if this can be revisited I think it could fix several bugs, annouances and config weirdnesses at the same time.

I have set the priority to high because of the nature of the travel router. In this case OpenWRT is not very user friendly.

I really hope that this can be fixed.

This is not a duplicate bug, although a few bugs seem closely connected
https://forum.openwrt.org/viewtopic.php?pid=290840#p290840

Thank you!

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by anonymous

I have a similar issue. I use a BCM6358 as a wireless wifi extender. If the primary router is unavailable, the extender wifi AP disappears and the BCM6358 can only be accessed via a wired ethernet port.

comment:2 Changed 2 years ago by frietpan

I think there should be a way to fix this.
If there is no WWAN then only start WLAN. So that there is a way to connect to the router over wifi.
OR
first bring up WLAN, then connect to WWAN, and then reconfigure the channel to the channel where WWAN needs to be on.

BUT I don't know how hard that is to code. If possible at all...

comment:3 Changed 2 years ago by raphael.preuss@…

I am using an external USB-Wifi adapter for WWAN now because the wifi is disabled if WWAN is unavaillable.

comment:4 Changed 22 months ago by gfunkdave

I too am running into this problem and would appreciate it being fixed.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.