Modify

Opened 2 years ago

#20431 new defect

IPV6 connection for working for Bonjour

Reported by: tingluo Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: IPV6, odhcp6c Cc: cyrus

Description

Dear Developers,
This is a follow up question to ticket #20401
I have enabled odhcp6c as instructed using following /etc/config/network, and was able to get IPV6 connection connected (Can ping6 and ssh in most case).
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config interface 'lan'

option ifname 'eth0.1'
option proto 'dhcp'

config switch

option name 'switch0'
option reset '1'
option enable_vlan '1'

config switch_vlan

option device 'switch0'
option vlan '1'
option ports '0 4 6t'

Issue:
Apple Bonjour service on the device wasn't able to receive bonjour service probing denial send from other device via IPV6.

Reference:
When the device have odhcpd, this channel was working.

NOTE:
During bootup, I did notice that IPV6 connection might not be stable (ping6/ssh failed).
The observing device is always able to receive the service probing from openwrt, but openwrt seems never received it.

Question:
Is my /etc/config/network setup properly?
I also tried the method outlined in here: http://wiki.openwrt.org/doc/uci/network6
However, using this config would not even give me a ipv6 connection(ping6/ssh):
Native IPv6 connection

For an uplink with native IPv6-connectivity you can use the following example configuration. It will work both for uplinks supporting DHCPv6 with Prefix Delegation and those that don't support DHCPv6-PD or DHCPv6 at all (SLAAC-only).

/etc/config/network

config interface wan

option ipv6 1 # only required for PPP-based protocols
...

config interface wan6

option ifname eth1 # use same ifname as in wan-section or "@wan"
option proto dhcpv6

config interface lan

option proto static
option ip6assign 60
...

The package odhcp6c must be installed to use dhcpv6. See protocol.dhcpv6 for advanced configuration options.

Thanks very much for your help!

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.