Modify

Opened 2 years ago

#20399 new defect

/etc/config/network, bridge, ifname multiple @interfaces

Reported by: gongtao0607@… Owned by: developers
Priority: normal Milestone: Barrier Breaker 14.07
Component: base system Version: Barrier Breaker 14.07
Keywords: uci network bridge ifname Cc:

Description

Very interesting behaviour of handling multiple "@" in the ifname list of a bridge.
Here's my configuration


config interface 'lan'

option type 'bridge'
option proto 'static'
option ipaddr '192.168.1.1'
option netmask '255.255.255.0'
option stp '1'
option ifname '@a_b.1 @a_c.1 eth0.1 eth1'

config interface 'a_b'

option proto 'gretap'
option peeraddr '137.99.11.230'
option mtu '1458'
option zone 'lan'


config interface 'a_c'

option proto 'gretap'
option peeraddr '137.99.10.203'
option mtu '1458'
option zone 'lan'


After /etc/init.d/network restart, the brctl show gives me:
root@OpenWrt-A:~# /etc/init.d/network restart
'radio0' is disabled
root@OpenWrt-A:~# brctl show
bridge name bridge id STP enabled interfaces
br-lan 7fff.c63dc7af1f22 yes eth0.1

eth1
wlan1
gre-a_b.1

Which is missing @a_c.1.
With either '@a_b.1 eth0.1 eth1' or '@a_c.1 eth0.1 eth1' it works perfectly, but not both.
What I guess is that the network script only handle the first @interface.

However, the interesting thing is, if I do a "/etc/init.d/network reload", they both appear to be there!
root@OpenWrt-A:~# /etc/init.d/network reload
'radio0' is disabled
'radio0' is disabled
root@OpenWrt-A:~# brctl show
bridge name bridge id STP enabled interfaces
br-lan 7fff.c63dc7af1f22 yes eth0.1

eth1
wlan1
gre-a_b.1
gre-a_c.1

My device is Netgear WNDR3700v2, I think it is reproducible on other device.

To conclude:
Multiple @interface in the ifname of bridge.
After /etc/init.d/network restart, only the first @interface showed up in the bridge
After /etc/init.d/network reload, both appear
After boot, same as a restart.

Attachments (1)

network (1.9 KB) - added by gongtao0607@… 2 years ago.
/etc/config/network

Download all attachments as: .zip

Change History (1)

Changed 2 years ago by gongtao0607@…

/etc/config/network

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.