Modify

Opened 11 years ago

Closed 11 years ago

#2038 closed defect (fixed)

YAFFS support for RB532 {still|again} broken

Reported by: giampaolo.mancini@… Owned by: florian
Priority: normal Milestone: Kamikaze 7.07
Component: kernel Version:
Keywords: Cc:

Description

It seems that the YAFFS support for RB532 is broken:

root@OpenWRT:/# cf2nand 
Copying from ext2 to yaffs2
Erasing filesystem...
yaffs: dev is 32505856 name is "mtdblock0"
yaffs: passed flags ""
yaffs: Attempting MTD mount on 31.0, "mtdblock0"
yaffs: dev is 32505857 name is "mtdblock1"
yaffs: passed flags ""
yaffs: Attempting MTD mount on 31.1, "mtdblock1"
Copying kernel...
**>> Block 1 needs retiring
**>> Block 1 retired
**>> Block 2 needs retiring
**>> Block 2 retired
**>> Block 3 needs retiring
**>> Block 3 retired
**>> Block 4 needs retiring
**>> Block 4 retired

snip

**>> Block 992 needs retiring
**>> Block 992 retired
yaffs tragedy: no more eraased blocks
!!!!!!!!! Allocator out !!!!!!!!!!!!!!!!!
**>> yaffs write required 32 attempts
yaffs tragedy: no more eraased blocks
yaffs tragedy: no more eraased blocks
yaffs tragedy: no more eraased blocks
yaffs tragedy: no more eraased blocks

and so on either trying to erase or write the NAND.

Any clue or suggestion?

Thanx in advance,
mancho.

Attachments (1)

rb532-nand.log (10.4 KB) - added by giampaolo.mancini@… 11 years ago.
Log file of rb532 nand broken yaffs support

Download all attachments as: .zip

Change History (12)

comment:1 Changed 11 years ago by jirif <jiri.fojtasek@…>

I have no problem with it. Try format NAND in "bios". BTW mtd command do nothing for nand device.

comment:2 Changed 11 years ago by nbd

  • Milestone set to Kamikaze 7.07

comment:3 Changed 11 years ago by florian

  • Resolution set to worksforme
  • Status changed from new to closed

Changed 11 years ago by giampaolo.mancini@…

Log file of rb532 nand broken yaffs support

comment:4 Changed 11 years ago by giampaolo.mancini@…

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Sorry, but i can confirm that YAFFS support for RB532 is broken.
The attached log was generated with a fresh build of OpenWRT r8020.
Trying to write on the second nand partition (/dev/mtdblock0) leads to similar results.

None of the OpenWRT default configuration has been changed (apart the rb532-target selection and the madwifi support).

The RouterBOARD is a RB532A.
I've also tried with different RB532 boards ever getting the same errors.

Am i missing some special manual configuration to get yaffs on rb532 work?

Is the initramfs image interfering in some manner?

Would someone track the revision at which the yaffs support got broken?

Thanks in advance,
mancho.

comment:5 Changed 11 years ago by xxiao

i saw similar problems on RB532A, tried everything i could image. if you boot from CF then chroot to the NAND block it will not report problems though. however this is not the preferrable way to use NAND.

The biggest concern I had was to use NAND to store kernel/root-file-system, NAND is too unsafe for that no matter what error-resistant filesystem you use. I decided to get rid of RB532A all together unless they put a larger NOR onboard for all code to be run.

comment:6 Changed 11 years ago by anonymous

It probably needs the same fixes that were put into the RB1xx support.

comment:7 Changed 11 years ago by florian

The same fix is applied for both rb1xx and rb500, since the yaffs patch is in generic-2.6/. I will be able to do some tests tomorrow on a rb500

comment:8 Changed 11 years ago by florian

  • Owner changed from developers to florian
  • Status changed from reopened to new

Do you get this error even when you format the NAND flash with routerbooot ?

comment:9 Changed 11 years ago by giampaolo.mancini@…

Hi,
it seems that jirif spotted the solution: old RB532 motherboards (pre-revision 5) only works with swapped nand pins. Reverting from r7777 makes YAFFS on those old RB532 work again.

To cope with this issue, is there any mean to detect the RB532 motherboard version at run-time?

Thanks to evreybody!

comment:10 Changed 11 years ago by florian

Thanks giampaolo for testing. Can you paste me the contents of the routerboot information menu ? So that I can see whether we can make runtime detection of the board. Thank you.

comment:11 Changed 11 years ago by florian

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with [8063].

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.