Modify

Opened 2 years ago

Last modified 2 years ago

#20354 new defect

Statefull IPv6 adressing does not broadcast correct IPv6 gateway

Reported by: gnutella Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: ipv6 dhcpv6 gateway ra_management nexthop Cc: cyrus@…

Description

Using OpenWRT latest development build:

OpenWRT is configured to serve stateful IPv6 only:

config dhcp 'lan'
        ....
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '2'

config host
        option name 'sony-vaio'
        option ip '192.168.1.x'
        option mac '54:42:49:xx:xx:xx'
        option duid '0004901071a15f278795axxxxxxxxxxxxxxxxxxxxx'
        option hostid '3'

/etc/config/networking

config globals 'globals'
        option ula_prefix 'fe80:ea94:f6ff:febb::'

....
config interface 'lan'
        option ifname 'eth0.1'
        option force_link '1'
        option type 'bridge'
        option proto 'static'
        option ipaddr '192.168.1.x'
        option netmask '255.255.255.0'
        option proto 'static'
        option ip6addr '2a01:e35:xxxx:xxx::1:fe/64'
        option ip6prefix  '2a01:e35:xxxx:xxxx::/64'
        option ip6gw '2a01:e35:xxxx:xxxx::1'
        option ip6assign '64'

The client is a Debian workstation with IPv6 support.

The client receives the correct IPv6:
2a01:e35:xxxx:xxxx::1

But the route is not set to IPv6 adress of the gateway within the ula_prefix range. As a result, client cannot connect to IPv6.

Client routing address is;

/sbin/route -A inet6 
Table de routage IPv6 du noyau
Destination                    Next Hop                   Flag Met Ref Use If
2a01:e35:87d8:61b0::3/128      ::                         U    256 0     0 eth0
fe80::/64                      ::                         U    256 0     7 eth0
::/0                           ::                         !n   -1  1286863 lo
::1/128                        ::                         Un   0   11   135 lo
2a01:e35:87d8:61b0::3/128      ::                         Un   0   1    21 lo
fe80::5642:49ff:fe87:4f74/128  ::                         Un   0   1    37 lo
ff00::/8                       ::                         U    256 0     0 eth0
::/0                           ::                         !n   -1  1286863 lo

There is a missing entry:

::/0                           fe80::ea94:f6ff:febb:ae16  UG   100 3     0 eth0

What is your opinion? Is this a bug or a feature which needs more configuration? How can server a default IPv6 gateway to client, correctly set to openWRT gateway ula_prefix + suffix?

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by cyrus

The following settings work fine for me in /etc/config/dhcp:
The clients get a default route via RAs

config dhcp 'lan'
        option interface 'lan'
        option ra 'server'
        option dhcpv6 'server'
        option ra_management '2'
....

Why do you set ip6prefix and ip6gw in the lan-interface config?
This seems counter-intuitive to me. Shouldn't those two be in some wan related section?

In any case what does: "ifstatus lan" return?
Are there any odhcpd related log entries in the syslog ("logread")?

comment:2 Changed 2 years ago by cyrus

  • Cc cyrus@… added

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.