Modify

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#20323 closed defect (fixed)

Mikrotik subtarget fails to build with default config

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: base system Version: Trunk
Keywords: Cc:

Description

Target System (Atheros AR7xxx/AR9xxx)
Subtarget (Mikrotik devices with NAND flash)

Make V=s fails :

Configuring uci.
Configuring wpad-mini.
Configuring dropbear.
Configuring mtd.
Configuring ppp.
Configuring kmod-gpio-button-hotplug.
Configuring iptables.
Configuring ip6tables.
Configuring ppp-mod-pppoe.
Setting flags for package kernel to hold.
Setting flags for package kmod-crypto-core to hold.
Setting flags for package kmod-crypto-arc4 to hold.
Setting flags for package kmod-ledtrig-usbdev to hold.
Setting flags for package kmod-lib-crc-ccitt to hold.
Setting flags for package kmod-nf-ipt to hold.
Setting flags for package kmod-nf-ipt6 to hold.
Setting flags for package kmod-ipt-core to hold.
Setting flags for package kmod-nf-conntrack to hold.
Setting flags for package kmod-nf-conntrack6 to hold.
Setting flags for package kmod-nf-nat to hold.
Setting flags for package kmod-ipt-conntrack to hold.
Setting flags for package kmod-ipt-nat to hold.
Setting flags for package kmod-nf-nathelper to hold.
Setting flags for package kmod-ip6tables to hold.
Setting flags for package kmod-ipv6 to hold.
Setting flags for package kmod-slhc to hold.
Setting flags for package kmod-ppp to hold.
Setting flags for package kmod-pppox to hold.
Setting flags for package kmod-pppoe to hold.
Setting flags for package kmod-nls-base to hold.
Setting flags for package kmod-usb-core to hold.
Setting flags for package kmod-usb-ohci to hold.
Setting flags for package kmod-usb2 to hold.
Setting flags for package libc to hold.
Setting flags for package libgcc to hold.
make[3]: Entering directory '/home/user/trunk/openwrt'
make[3]: Nothing to be done for 'package/preconfig'.
make[3]: Leaving directory '/home/user/trunk/openwrt'
rm -f /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/root-ar71xx/usr/lib/opkg/info/*.postinst*
rm -f /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/root-ar71xx/usr/lib/opkg/info/*.prerm*
make[2]: Leaving directory '/home/user/trunk/openwrt'
make[2]: Entering directory '/home/user/trunk/openwrt'
make[3]: Entering directory '/home/user/trunk/openwrt/target/linux'
make[4]: Entering directory '/home/user/trunk/openwrt/target/linux/ar71xx'
/home/user/trunk/openwrt/scripts/kconfig.pl  + + /home/user/trunk/openwrt/target/linux/generic/config-4.1 /home/user/trunk/openwrt/target/linux/ar71xx/config-4.1 /home/user/trunk/openwrt/target/linux/ar71xx/mikrotik/config-default > /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.target
awk '/^(#[[:space:]]+)?CONFIG_KERNEL/{sub("CONFIG_KERNEL_","CONFIG_");print}' /home/user/trunk/openwrt/.config >> /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.target
echo "# CONFIG_KALLSYMS_EXTRA_PASS is not set" >> /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.target
echo "# CONFIG_KALLSYMS_ALL is not set" >> /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.target
echo "# CONFIG_KALLSYMS_UNCOMPRESSED is not set" >> /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.target
/home/user/trunk/openwrt/scripts/metadata.pl kconfig /home/user/trunk/openwrt/tmp/.packageinfo /home/user/trunk/openwrt/.config 4.1 > /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.override
/home/user/trunk/openwrt/scripts/kconfig.pl 'm+' '+' /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.target /dev/null /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.override > /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config
mv /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.old
grep -v INITRAMFS /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config.old > /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config
echo 'CONFIG_INITRAMFS_SOURCE=""' >> /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config
rm -rf /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/modules
export MAKEFLAGS= ; [ -d /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/user_headers ] || make -C /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4 HOSTCFLAGS="-O2 -I/home/user/trunk/openwrt/staging_dir/host/include -I/home/user/trunk/openwrt/staging_dir/host/usr/include -Wall -Wmissing-prototypes -Wstrict-prototypes" CROSS_COMPILE="mips-openwrt-linux-musl-" ARCH="mips" KBUILD_HAVE_NLS=no CONFIG_SHELL="bash" V='' CC="mips-openwrt-linux-musl-gcc" INSTALL_HDR_PATH=/home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/user_headers headers_install
. /home/user/trunk/openwrt/include/shell.sh; grep '=[ym]' /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.config | LC_ALL=C sort | md5s > /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.vermagic
touch /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.configured
rm -f /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/root-ar71xx/init
make -C /home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4 HOSTCFLAGS="-O2 -I/home/user/trunk/openwrt/staging_dir/host/include -I/home/user/trunk/openwrt/staging_dir/host/usr/include -Wall -Wmissing-prototypes -Wstrict-prototypes" CROSS_COMPILE="mips-openwrt-linux-musl-" ARCH="mips" KBUILD_HAVE_NLS=no CONFIG_SHELL="bash" V='' CC="mips-openwrt-linux-musl-gcc" all modules
make[5]: Entering directory '/home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4'
scripts/kconfig/conf  --silentoldconfig Kconfig
net/sched/Kconfig:44: warning: menuconfig statement without prompt
#
# configuration written to .config
#
  CHK     include/config/kernel.release
  CHK     include/generated/uapi/linux/version.h
  CHK     include/generated/utsrelease.h
  CHK     include/generated/bounds.h
  CHK     include/generated/asm-offsets.h
  CALL    scripts/checksyscalls.sh
  CHK     include/generated/compile.h
  CC      fs/yaffs2/yaffs_vfs.o
fs/yaffs2/yaffs_vfs.c: In function 'yaffs_readpage_nolock':
fs/yaffs2/yaffs_vfs.c:286:29: error: 'struct file' has no member named 'f_dentry'
  obj = yaffs_dentry_to_obj(f->f_dentry);
                             ^
fs/yaffs2/yaffs_vfs.c:218:39: note: in definition of macro 'yaffs_inode_to_obj_lv'
 #define yaffs_inode_to_obj_lv(iptr) ((iptr)->i_private)
                                       ^
fs/yaffs2/yaffs_vfs.c:225:35: note: in expansion of macro 'yaffs_inode_to_obj'
 #define yaffs_dentry_to_obj(dptr) yaffs_inode_to_obj((dptr)->d_inode)
                                   ^
fs/yaffs2/yaffs_vfs.c:286:8: note: in expansion of macro 'yaffs_dentry_to_obj'
  obj = yaffs_dentry_to_obj(f->f_dentry);
        ^
fs/yaffs2/yaffs_vfs.c: In function 'yaffs_hold_space':
fs/yaffs2/yaffs_vfs.c:484:29: error: 'struct file' has no member named 'f_dentry'
  obj = yaffs_dentry_to_obj(f->f_dentry);
                             ^
fs/yaffs2/yaffs_vfs.c:218:39: note: in definition of macro 'yaffs_inode_to_obj_lv'
 #define yaffs_inode_to_obj_lv(iptr) ((iptr)->i_private)
                                       ^
fs/yaffs2/yaffs_vfs.c:225:35: note: in expansion of macro 'yaffs_inode_to_obj'
 #define yaffs_dentry_to_obj(dptr) yaffs_inode_to_obj((dptr)->d_inode)
                                   ^
fs/yaffs2/yaffs_vfs.c:484:8: note: in expansion of macro 'yaffs_dentry_to_obj'
  obj = yaffs_dentry_to_obj(f->f_dentry);
        ^
fs/yaffs2/yaffs_vfs.c: In function 'yaffs_release_space':
fs/yaffs2/yaffs_vfs.c:502:29: error: 'struct file' has no member named 'f_dentry'
  obj = yaffs_dentry_to_obj(f->f_dentry);
                             ^
fs/yaffs2/yaffs_vfs.c:218:39: note: in definition of macro 'yaffs_inode_to_obj_lv'
 #define yaffs_inode_to_obj_lv(iptr) ((iptr)->i_private)
                                       ^
fs/yaffs2/yaffs_vfs.c:225:35: note: in expansion of macro 'yaffs_inode_to_obj'
 #define yaffs_dentry_to_obj(dptr) yaffs_inode_to_obj((dptr)->d_inode)
                                   ^
fs/yaffs2/yaffs_vfs.c:502:8: note: in expansion of macro 'yaffs_dentry_to_obj'
  obj = yaffs_dentry_to_obj(f->f_dentry);
        ^
fs/yaffs2/yaffs_vfs.c: In function 'yaffs_file_write':
fs/yaffs2/yaffs_vfs.c:594:29: error: 'struct file' has no member named 'f_dentry'
  obj = yaffs_dentry_to_obj(f->f_dentry);
                             ^
fs/yaffs2/yaffs_vfs.c:218:39: note: in definition of macro 'yaffs_inode_to_obj_lv'
 #define yaffs_inode_to_obj_lv(iptr) ((iptr)->i_private)
                                       ^
fs/yaffs2/yaffs_vfs.c:225:35: note: in expansion of macro 'yaffs_inode_to_obj'
 #define yaffs_dentry_to_obj(dptr) yaffs_inode_to_obj((dptr)->d_inode)
                                   ^
fs/yaffs2/yaffs_vfs.c:594:8: note: in expansion of macro 'yaffs_dentry_to_obj'
  obj = yaffs_dentry_to_obj(f->f_dentry);
        ^
fs/yaffs2/yaffs_vfs.c:606:11: error: 'struct file' has no member named 'f_dentry'
  inode = f->f_dentry->d_inode;
           ^
fs/yaffs2/yaffs_vfs.c: In function 'yaffs_file_flush':
fs/yaffs2/yaffs_vfs.c:730:50: error: 'struct file' has no member named 'f_dentry'
  struct yaffs_obj *obj = yaffs_dentry_to_obj(file->f_dentry);
                                                  ^
fs/yaffs2/yaffs_vfs.c:218:39: note: in definition of macro 'yaffs_inode_to_obj_lv'
 #define yaffs_inode_to_obj_lv(iptr) ((iptr)->i_private)
                                       ^
fs/yaffs2/yaffs_vfs.c:225:35: note: in expansion of macro 'yaffs_inode_to_obj'
 #define yaffs_dentry_to_obj(dptr) yaffs_inode_to_obj((dptr)->d_inode)
                                   ^
fs/yaffs2/yaffs_vfs.c:730:26: note: in expansion of macro 'yaffs_dentry_to_obj'
  struct yaffs_obj *obj = yaffs_dentry_to_obj(file->f_dentry);
                          ^
fs/yaffs2/yaffs_vfs.c: At top level:
fs/yaffs2/yaffs_vfs.c:779:10: error: 'new_sync_read' undeclared here (not in a function)
  .read = new_sync_read,
          ^
fs/yaffs2/yaffs_vfs.c:781:11: error: 'new_sync_write' undeclared here (not in a function)
  .write = new_sync_write,
           ^
fs/yaffs2/yaffs_vfs.c: In function 'yaffs_iterate':
fs/yaffs2/yaffs_vfs.c:1733:29: error: 'struct file' has no member named 'f_dentry'
  obj = yaffs_dentry_to_obj(f->f_dentry);
                             ^
fs/yaffs2/yaffs_vfs.c:218:39: note: in definition of macro 'yaffs_inode_to_obj_lv'
 #define yaffs_inode_to_obj_lv(iptr) ((iptr)->i_private)
                                       ^
fs/yaffs2/yaffs_vfs.c:225:35: note: in expansion of macro 'yaffs_inode_to_obj'
 #define yaffs_dentry_to_obj(dptr) yaffs_inode_to_obj((dptr)->d_inode)
                                   ^
fs/yaffs2/yaffs_vfs.c:1733:8: note: in expansion of macro 'yaffs_dentry_to_obj'
  obj = yaffs_dentry_to_obj(f->f_dentry);
        ^
scripts/Makefile.build:258: recipe for target 'fs/yaffs2/yaffs_vfs.o' failed
make[7]: *** [fs/yaffs2/yaffs_vfs.o] Error 1
scripts/Makefile.build:403: recipe for target 'fs/yaffs2' failed
make[6]: *** [fs/yaffs2] Error 2
Makefile:946: recipe for target 'fs' failed
make[5]: *** [fs] Error 2
make[5]: Leaving directory '/home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4'
Makefile:24: recipe for target '/home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.image' failed
make[4]: *** [/home/user/trunk/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_mikrotik/linux-4.1.4/.image] Error 2
make[4]: Leaving directory '/home/user/trunk/openwrt/target/linux/ar71xx'
Makefile:13: recipe for target 'install' failed
make[3]: *** [install] Error 2
make[3]: Leaving directory '/home/user/trunk/openwrt/target/linux'
target/Makefile:21: recipe for target 'target/linux/install' failed
make[2]: *** [target/linux/install] Error 2
make[2]: Leaving directory '/home/user/trunk/openwrt'
target/Makefile:17: recipe for target '/home/user/trunk/openwrt/staging_dir/target-mips_34kc_musl-1.1.10/stamp/.target_install' failed
make[1]: *** [/home/user/trunk/openwrt/staging_dir/target-mips_34kc_musl-1.1.10/stamp/.target_install] Error 2
make[1]: Leaving directory '/home/user/trunk/openwrt'
/home/user/trunk/openwrt/include/toplevel.mk:181: recipe for target 'world' failed
make: *** [world] Error 2

Attachments (0)

Change History (4)

comment:1 Changed 2 years ago by Stappers

I think it is (related to) /ticket/19046.html

comment:3 Changed 2 years ago by hauke

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed in r46609.

I do not have such a device and only compile tested this, please do some runtime tests.

comment:4 Changed 2 years ago by Stappers

Confirm on the clean compile.

Actual test with YAFFS2 will not be happen soon by me,
so here is help welcome from all those who have the hardware also.

This ticket is to tell that is upstream YAFFS2 knows that the issue is fixed in OpenWRT
(message in their mailinglist archive:

http://lists.aleph1.co.uk/lurker/message/20150817.165749.b36116f6.en.html )

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.