Modify

Opened 2 years ago

Closed 2 years ago

#20310 closed defect (duplicate)

wireless: WEXT signal reporting broken

Reported by: koniu@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version:
Keywords: Cc:

Description

CC-rc3 kernel 3.18.17 on ar71xx

Noticed that wavemon gives constant signal reading making it totally useless. Only having that issue with wavemon. iwinfo and iw report real values.

Upon some googling found these:

https://github.com/uoaerg/wavemon/issues/10
https://bugzilla.kernel.org/show_bug.cgi?id=99691
http://article.gmane.org/gmane.linux.kernel.wireless.general/138816 [patch]

Seems to be the same problem except the kernel version differs but I suppose yous are still pulling your own fresh compat-wireless (or whatever it's called these days - been a while since I've last done any wrt hacking).

In a nutshell, recent changes to mac80211 broke WEXT signal reporting.

Looking at github this is still broken in trunk.
https://github.com/openwrt/linux/blob/master/net/wireless/wext-compat.c#L1347

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by hauke

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #20311

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.