Modify

Opened 11 years ago

Closed 11 years ago

Last modified 10 years ago

#2031 closed enhancement (fixed)

[patch] fix vim so 7.1 can be used without making the binary huge

Reported by: h3sp4wn Owned by: developers
Priority: normal Milestone:
Component: packages Version:
Keywords: Cc:

Description

Index: package/vim/Makefile
===================================================================
--- package/vim/Makefile	(revision 7872)
+++ package/vim/Makefile	(working copy)
@@ -9,18 +9,24 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=vim
-PKG_VERSION:=5.8
+PKG_VERSION:=7.1
 PKG_RELEASE:=1
 
-PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix/
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-src.tar.gz
-PKG_MD5SUM:=89ab05bb5cd39eeb9e259503436c11ed
-PKG_CAT:=zcat
+PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_MD5SUM:=44c6b4914f38d6f9aa959640b89da329
+PKG_CAT:=bzcat
 
-PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)71
 
 include $(INCLUDE_DIR)/package.mk
 
+CONFIGURE_ARGS += \
+	--enable-gui=none --disable-gtktest \
+	--disable-xim --with-features=tiny \
+	--disable-gpm --without-x --disable-netbeans \
+	--with-tlib=ncurses
+
 define Package/vim
   SECTION:=utils
   CATEGORY:=Utilities
@@ -29,18 +35,6 @@
   URL:=http://www.vim.org/
 endef
 
-define Build/Configure
-	$(call Build/Configure/Default, \
-		--enable-min-features \
-		--disable-gui \
-		--without-x \
-		--disable-multibyte \
-		--disable-cscope \
-		--disable-gpm \
-		--with-tlib=ncurses \
-	)
-endef
-
 define Package/vim/install	
 	$(INSTALL_DIR) $(1)/usr/bin
 	$(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
include $(TOPDIR)/rules.mk

PKG_NAME:=vim
PKG_VERSION:=7.1
PKG_RELEASE:=1

PKG_SOURCE_URL:=ftp://ftp.vim.org/pub/vim/unix
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
PKG_MD5SUM:=44c6b4914f38d6f9aa959640b89da329
PKG_CAT:=bzcat

PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)71

include $(INCLUDE_DIR)/package.mk

CONFIGURE_ARGS += \
	--enable-gui=none --disable-gtktest \
	--disable-xim --with-features=tiny \
	--disable-gpm --without-x --disable-netbeans \
	--with-tlib=ncurses

define Package/vim
  SECTION:=utils
  CATEGORY:=Utilities
  DEPENDS:=+libncurses
  TITLE:=VI Improved
  URL:=http://www.vim.org/
endef

define Package/vim/install	
	$(INSTALL_DIR) $(1)/usr/bin
	$(CP) $(PKG_BUILD_DIR)/src/$(PKG_NAME) $(1)/usr/bin/
	$(INSTALL_DIR) $(1)/usr/share/vim
	$(CP) ./files/vimrc $(1)/usr/share/vim/
endef

$(eval $(call BuildPackage,vim))

the patch from when it was added before was fine.

Attachments (2)

Makefile (1.0 KB) - added by h3sp4wn 11 years ago.
vim Makefile
001-cross_compile.patch (24.0 KB) - added by h3sp4wn 11 years ago.
cross compile patch (from when 7.1 was in before)

Download all attachments as: .zip

Change History (5)

Changed 11 years ago by h3sp4wn

vim Makefile

Changed 11 years ago by h3sp4wn

cross compile patch (from when 7.1 was in before)

comment:1 follow-up: Changed 11 years ago by h3sp4wn

At least for my target the ac_ variable is not needed.

comment:2 Changed 11 years ago by olli

  • Resolution set to fixed
  • Status changed from new to closed

Fixed with r7880.

comment:3 in reply to: ↑ 1 Changed 10 years ago by gnanasekaran-a.c@…

Replying to h3sp4wn:

At least for my target the ac_ variable is not needed.

I would like to cross comple vim but i don't have any idea abt this ...
Can you help me or tell me step by step what i should do

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.