Modify

Opened 2 years ago

Last modified 2 years ago

#20307 new defect

Strange OpenVPN problem

Reported by: Daniel Owned by: developers
Priority: normal Milestone:
Component: base system Version: Trunk
Keywords: OpenVPN, udp, nat Cc:

Description

I'm administering a remote server via OpenVPN. The OpenVPN is running on my own notebook, not on the router. Until now, I used a TP-Link 1043NDv1 router with Chaos Calmer 15.05-rc3 and the OpenVPN connection was ok. I've upgraded to a TP-Link WDR3600v1.5, also running Chaos Calmer 15.05-rc3, however the OpenVPN client stucks before authentication.

The VPN client stops with a message UDPv4 WRITE [42] failed.
The OpenVPN server is accessed by UDP and on the non-standard port 220.

To find out the problem, I've resetted both routers to their factory settings, so now both TP-Link are running Chaos Calmer 15.05-rc3. I also tried to download the configuration tgz from both routers to compare them, but they differ only in wifi settings. (I was testing only with ethernet cable, no wifi).

Since I have no access to the OpenVPN server, I can not make changes on that.
I've reverted to the stock firmware on WDR3600, but I would happily help to identify the root cause, if there is any suggestion that I could try.

Attachments (0)

Change History (1)

comment:1 Changed 2 years ago by marczi

I've forgot to write that I've tested with 14.07 with same results

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.