Modify

Opened 3 years ago

Closed 3 years ago

#20271 closed defect (fixed)

The AR71xx kernel fails to compile (gpio_count)

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: kernel Version: Trunk
Keywords: gpio, ath79 Cc:

Description

This is what I get when I try to build the current trunk sources with default configuration:

net/sched/Kconfig:44: warning: menuconfig statement without prompt
arch/mips/ath79/gpio.c: In function 'ath79_gpio_output_select':
arch/mips/ath79/gpio.c:241:5: error: 'gpio_count' may be used uninitialized in this function [-Werror=maybe-uninitialized]
  if (gpio >= gpio_count)
     ^
cc1: all warnings being treated as errors
make[7]: *** [arch/mips/ath79/gpio.o] Error 1
make[6]: *** [arch/mips/ath79] Error 2
make[5]: *** [arch/mips] Error 2
make[4]: *** [/root/openwrt/build_dir/target-mips_34kc_musl-1.1.10/linux-ar71xx_generic/linux-4.1.3/.image] Error 2
make[3]: *** [install] Error 2

I think this might be caused by the patches in #46459 (or the update to 4.1.x without a proper revision of these patches).

Attachments (0)

Change History (1)

comment:1 Changed 3 years ago by nbd

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r46547

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.