Modify

Opened 3 years ago

Last modified 2 years ago

#20261 new defect

Luci web interface doesn't list wireless associations when dynamic vlans are being used

Reported by: merpmerp Owned by: developers
Priority: normal Milestone:
Component: base system Version: Trunk
Keywords: Cc:

Description

This was tested on a build put together about an hour ago

I'm using an Archer C7 v2 with two ssids on each radio (four total), one that is authenticated with EAP/Radius and one that is just plain PSK

Clients that are connected to the PSK ssid show up in luci (in the main status screen and in wireless) under the "Associated Stations" section

Clients that are connected to the EAP/dynamic vlan ssid do not show up anywhere in luci

Dynamic vlans were set up following this guide, http://wiki.openwrt.org/doc/howto/wireless.security.8021x

Attachments (0)

Change History (2)

comment:1 Changed 2 years ago by anonymous

iwinfo DEV assoclist returns associated clients correctly, assuming i issue the command for all the weird interfaces that are created, currently i have the following interfaces:

wlan1.100
wlan1-1
wlan1
wlan0.100
wlan0-1
wlan0

and the following commands returns an accurate listing of all associated clients:
for foo in $(iw dev | grep Interface | cut -f 2 -s -d" "); do iwinfo $foo assoclist; done

I'm having a hard time finding the logic in Luci that populates the list of associations, my Lua is very bad :(

comment:2 Changed 2 years ago by matteo@…

I have the same issue on this two devices:

TP-Link TL-WDR4900 v1
OpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45)

TP-Link Archer C7 v2
OpenWrt Chaos Calmer 15.05 / LuCI (git-15.248.30277-3836b45)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.