Modify

Opened 3 years ago

Last modified 2 years ago

#20207 new defect

Chaos Calmer RC3 on DIR-615 E4 no wifi

Reported by: octopus Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: wifi, rc3, cc, chaos calmer, e4, dir615, dir-615, Cc:

Description

There is no Wifi under Interfaces after flashing, tried flashing several times, erasing nvram, etc.
If I restore my backed up settings, Wifi appears but does not work at all. Trying to apply new Wifi settings leads to this:

/usr/lib/lua/luci/dispatcher.lua:433: Failed to execute arcombine dispatcher target for entry '/admin/network/wireless/radio0.network1'.
The called action terminated with an exception:
/usr/lib/lua/luci/model/cbi/admin_network/wifi.lua:177: attempt to index field 'hwmodelist' (a nil value)
stack traceback:
	[C]: in function 'assert'
	/usr/lib/lua/luci/dispatcher.lua:433: in function 'dispatch'
	/usr/lib/lua/luci/dispatcher.lua:168: in function </usr/lib/lua/luci/dispatcher.lua:167>

So I cannot even add new Wifi after deleting the old ones. Operating frequency option is not functional too.

Attachments (0)

Change History (10)

comment:1 Changed 3 years ago by anonymous

Exact same error.

comment:2 Changed 2 years ago by anonymous

I confirm this bug.

comment:3 Changed 2 years ago by anonymous

I have the same problem.

comment:4 Changed 2 years ago by anonymous

I am experiencing this problem as well.

comment:5 Changed 2 years ago by anonymous

I think the priority of this defect should be changed to 'high' since it severely impairs the functionality of the router.

comment:6 Changed 2 years ago by anonymous

I've figured out why the wifi isn't working. It is missing the kmod-ath9k and wpad-mini which can be installed via opkg. However, upon trying to install these packages, it will not work since for some reason in this version of Chaos Calmer, there is not enough available space in rootfs.

http://i.imgur.com/K23yHRU.png

Before trying to install the driver:
http://i.imgur.com/ij1haNd.png

After trying to install the driver:
http://i.imgur.com/9mJDGbn.png

comment:7 Changed 2 years ago by anonymous

Surprisingly, in Barrier Breaker 14.07 there is even less space assigned to rootfs, yet WiFi runs perfectly in this build.
http://i.imgur.com/QJiqe0x.png

comment:8 Changed 2 years ago by anonymous

The same problem exists in the final Chaos Calmer 15.05. No kmod-ath9k, no kmod-ath9k-common, no wpad-mini and no space to install. I wonder if some unneeded packages can be safely removed to free up space as a workaround

comment:9 Changed 2 years ago by octopus

I confirm this problem on Chaos Calmer 15.05.

I opened new ticket for this: /ticket/20522.html

Last edited 2 years ago by octopus (previous) (diff)

comment:10 Changed 2 years ago by anonymous

Can someone please update the table list here:
https://wiki.openwrt.org/toh/start?dataflt[Model*~]=615
So that DIR-615 isn't listed against 15.05,

I installed it and then wasted hours until I found this bug report that there isn't enough space to support Wifi !

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.