Modify

Opened 3 years ago

Last modified 2 years ago

#20201 new defect

TL-wdr4900 max txpower for country BG (Bulgaria)

Reported by: vlado@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: Cc:

Description

Recently I build CHAOS CALMER (Chaos Calmer, r46494)

uname -a
Linux wdr4900 3.18.19 #2 Sun Jul 26 02:43:17 EEST 2015 ppc GNU/Linux

The problem is max txpower for both radios (2.4/5GHz) when country is set to BG.
I can't set more than 16 dBm (39 mW) for 5GHz and 18 dBm (63 mW) for 2.4GHz.
If you need more info just ask.

root@wdr4900:~# cat /etc/config/wireless
config wifi-device radio0

option type mac80211
option channel 48
option hwmode 11a
option path 'ffe09000.pcie/pci0000:00/0000:00:00.0/0000:01:00.0'
option htmode HT40
option txpower 20
option country 'BG'
option noscan 1

config wifi-iface

option device 'radio0'
option network 'vlan41'
option mode 'ap'
option ssid 'ssid5'
option encryption 'psk2'
option key 'key'

config wifi-device radio1

option type mac80211
option channel 2
option hwmode 11g
option path 'ffe0a000.pcie/pci0001:02/0001:02:00.0/0001:03:00.0'
option htmode HT40
option txpower 20
option country 'BG'
option noscan 1

config wifi-iface

option device 'radio1'
option network 'vlan41'
option mode 'ap'
option ssid 'ssid24'
option encryption 'psk2'
option key 'key'

root@wdr4900:~# iwinfo
wlan0 ESSID: "ssid5"

Access Point: 64:XX:B3:XX:63:XX
Mode: Master Channel: 48 (5.240 GHz)
Tx-Power: 16 dBm Link Quality: unknown/70
Signal: unknown Noise: -91 dBm
Bit Rate: unknown
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11an
Hardware: 168C:0033 168C:A120 [Atheros AR9580]
TX power offset: none
Frequency offset: none
Supports VAPs: yes PHY name: phy0

wlan1 ESSID: "ssid24"

Access Point: 64:XX:B3:XX:63:XX
Mode: Master Channel: 2 (2.417 GHz)
Tx-Power: 18 dBm Link Quality: 47/70
Signal: -63 dBm Noise: -90 dBm
Bit Rate: 111.1 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: 168C:0030 0000:0000 [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy1

root@wdr4900:~# iwinfo wlan0 tx

0 dBm ( 1 mW)
1 dBm ( 1 mW)
2 dBm ( 1 mW)
3 dBm ( 1 mW)
4 dBm ( 2 mW)
5 dBm ( 3 mW)
6 dBm ( 3 mW)
7 dBm ( 5 mW)
8 dBm ( 6 mW)
9 dBm ( 7 mW)

10 dBm ( 10 mW)
11 dBm ( 12 mW)
12 dBm ( 15 mW)
13 dBm ( 19 mW)
14 dBm ( 25 mW)
15 dBm ( 31 mW)

  • 16 dBm ( 39 mW) 17 dBm ( 50 mW) 18 dBm ( 63 mW) 19 dBm ( 79 mW) 20 dBm ( 100 mW)

root@wdr4900:~# iwinfo wlan1 tx

0 dBm ( 1 mW)
1 dBm ( 1 mW)
2 dBm ( 1 mW)
3 dBm ( 1 mW)
4 dBm ( 2 mW)
5 dBm ( 3 mW)
6 dBm ( 3 mW)
7 dBm ( 5 mW)
8 dBm ( 6 mW)
9 dBm ( 7 mW)

10 dBm ( 10 mW)
11 dBm ( 12 mW)
12 dBm ( 15 mW)
13 dBm ( 19 mW)
14 dBm ( 25 mW)
15 dBm ( 31 mW)
16 dBm ( 39 mW)
17 dBm ( 50 mW)

  • 18 dBm ( 63 mW) 19 dBm ( 79 mW) 20 dBm ( 100 mW)

root@wdr4900:~# iw reg get
country BG: DFS-ETSI

(2402 - 2482 @ 40), (N/A, 20), (N/A)
(5170 - 5250 @ 80), (N/A, 20), (N/A)
(5250 - 5330 @ 80), (N/A, 20), (0 ms), DFS
(5490 - 5710 @ 160), (N/A, 27), (0 ms), DFS
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

root@wdr4900:~# iw list

............

Frequencies:

  • 2412 MHz [1] (20.0 dBm)
  • 2417 MHz [2] (20.0 dBm)
  • 2422 MHz [3] (20.0 dBm)
  • 2427 MHz [4] (20.0 dBm)
  • 2432 MHz [5] (20.0 dBm)
  • 2437 MHz [6] (20.0 dBm)
  • 2442 MHz [7] (20.0 dBm)
  • 2447 MHz [8] (20.0 dBm)
  • 2452 MHz [9] (20.0 dBm)
  • 2457 MHz [10] (20.0 dBm)
  • 2462 MHz [11] (20.0 dBm)
  • 2467 MHz [12] (20.0 dBm)
  • 2472 MHz [13] (20.0 dBm)
  • 2484 MHz [14] (disabled)

............
Frequencies:

  • 5180 MHz [36] (20.0 dBm)
  • 5200 MHz [40] (20.0 dBm)
  • 5220 MHz [44] (20.0 dBm)
  • 5240 MHz [48] (20.0 dBm)
  • 5260 MHz [52] (20.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5280 MHz [56] (20.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5300 MHz [60] (20.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5320 MHz [64] (20.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5500 MHz [100] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5520 MHz [104] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5540 MHz [108] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5560 MHz [112] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5580 MHz [116] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5600 MHz [120] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5620 MHz [124] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5640 MHz [128] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5660 MHz [132] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5680 MHz [136] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5700 MHz [140] (22.0 dBm) (radar detection) DFS state: usable (for 45495 sec) DFS CAC time: 60000 ms
  • 5745 MHz [149] (disabled)
  • 5765 MHz [153] (disabled)
  • 5785 MHz [157] (disabled)
  • 5805 MHz [161] (disabled)
  • 5825 MHz [165] (disabled)

...........

Attachments (0)

Change History (4)

comment:1 Changed 3 years ago by e7e1@…

D-Link DIR-835 rev. A1 CHAOS CALMER (Bleeding Edge, r46547), have the same problem country is set to RU.

root@OpenWrt:~# uname -a
Linux OpenWrt 4.1.3 #1 Mon Aug 3 12:31:50 MSK 2015 mips GNU/Linux
root@OpenWrt:~# cat /etc/config/wireless

config wifi-device 'radio0'

option type 'mac80211'
option hwmode '11g'
option path 'platform/ar934x_wmac'
option noscan '1'
option distance '5'
option htmode 'HT40'
option channel '8'
option txpower '20'
option country 'RU'

config wifi-iface

option device 'radio0'
option network 'lan'
option mode 'ap'
option ssid '*'
option key '
*'
option wpa_group_rekey '0'
option encryption 'psk2'

config wifi-device 'radio1'

option type 'mac80211'
option hwmode '11a'
option path 'pci0000:00/0000:00:00.0'
option htmode 'HT40'
option txpower '20'
option country 'RU'
option channel '40'

config wifi-iface

option device 'radio1'
option network 'lan'
option mode 'ap'
option ssid '*'
option encryption 'psk2'
option key '
*'
option disabled '1'

root@OpenWrt:~# iwinfo
wlan0 ESSID: "*"

Access Point: BX:AX:8X:6X:DX:DX
Mode: Master Channel: 8 (2.447 GHz)
Tx-Power: 16 dBm Link Quality: 63/70
Signal: -47 dBm Noise: -95 dBm
Bit Rate: 150.0 MBit/s
Encryption: WPA2 PSK (CCMP)
Type: nl80211 HW Mode(s): 802.11bgn
Hardware: unknown [Generic MAC80211]
TX power offset: unknown
Frequency offset: unknown
Supports VAPs: yes PHY name: phy0

root@OpenWrt:~# iwinfo wlan0 tx

0 dBm ( 1 mW)
1 dBm ( 1 mW)
2 dBm ( 1 mW)
3 dBm ( 1 mW)
4 dBm ( 2 mW)
5 dBm ( 3 mW)
6 dBm ( 3 mW)
7 dBm ( 5 mW)
8 dBm ( 6 mW)
9 dBm ( 7 mW)

10 dBm ( 10 mW)
11 dBm ( 12 mW)
12 dBm ( 15 mW)
13 dBm ( 19 mW)
14 dBm ( 25 mW)
15 dBm ( 31 mW)

  • 16 dBm ( 39 mW) 17 dBm ( 50 mW) 18 dBm ( 63 mW) 19 dBm ( 79 mW) 20 dBm ( 100 mW)

root@OpenWrt:~# iw reg get
global
country RU: DFS-ETSI

(2402 - 2482 @ 40), (N/A, 20), (N/A)
(5170 - 5250 @ 40), (N/A, 20), (N/A)
(5250 - 5330 @ 40), (N/A, 20), (0 ms), DFS
(5650 - 5730 @ 40), (N/A, 30), (0 ms), DFS
(5735 - 5835 @ 40), (N/A, 30), (N/A)
(57000 - 66000 @ 2160), (N/A, 40), (N/A)

phy#1
country US: DFS-FCC

(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 17), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)

phy#0
country US: DFS-FCC

(2402 - 2472 @ 40), (N/A, 30), (N/A)
(5170 - 5250 @ 80), (N/A, 17), (N/A), AUTO-BW
(5250 - 5330 @ 80), (N/A, 23), (0 ms), DFS, AUTO-BW
(5490 - 5730 @ 160), (N/A, 23), (0 ms), DFS
(5735 - 5835 @ 80), (N/A, 30), (N/A)
(57240 - 63720 @ 2160), (N/A, 40), (N/A)
option mode 'ap'
option ssid 'gorilla 5'
option encryption 'psk2'
option key 'StepleR1971'
option disabled '1'

root@OpenWrt:~# iw list
Wiphy phy1

max # scan SSIDs: 4
max scan IEs length: 2261 bytes
max # sched scan SSIDs: 0
max # match sets: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 0 (up to 0m)
Device supports AP-side u-APSD.
Device supports T-DLS.
Available Antennas: TX 0x7 RX 0x7
Configured Antennas: TX 0x7 RX 0x7
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • WDS
  • monitor
  • mesh point
  • P2P-client
  • P2P-GO

Band 2:

Capabilities: 0x11ef

RX LDPC
HT20/HT40
SM Power Save disabled
RX HT20 SGI
RX HT40 SGI
TX STBC
RX STBC 1-stream
Max AMSDU length: 3839 bytes
DSSS/CCK HT40

Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 8 usec (0x06)
HT TX/RX MCS rate indexes supported: 0-23
Frequencies:

  • 5180 MHz [36] (20.0 dBm)
  • 5200 MHz [40] (20.0 dBm)
  • 5220 MHz [44] (20.0 dBm)
  • 5240 MHz [48] (20.0 dBm)
  • 5260 MHz [52] (20.0 dBm) (radar detection) DFS state: usable (for 55062 sec) DFS CAC time: 60000 ms
  • 5280 MHz [56] (20.0 dBm) (radar detection) DFS state: usable (for 55062 sec) DFS CAC time: 60000 ms
  • 5300 MHz [60] (20.0 dBm) (radar detection) DFS state: usable (for 55062 sec) DFS CAC time: 60000 ms
  • 5320 MHz [64] (20.0 dBm) (radar detection) DFS state: usable (for 55062 sec) DFS CAC time: 60000 ms
  • 5500 MHz [100] (disabled)
  • 5520 MHz [104] (disabled)
  • 5540 MHz [108] (disabled)
  • 5560 MHz [112] (disabled)
  • 5580 MHz [116] (disabled)
  • 5600 MHz [120] (disabled)
  • 5620 MHz [124] (disabled)
  • 5640 MHz [128] (disabled)
  • 5660 MHz [132] (24.0 dBm) (radar detection) DFS state: usable (for 55062 sec) DFS CAC time: 60000 ms
  • 5680 MHz [136] (24.0 dBm) (radar detection) DFS state: usable (for 55062 sec) DFS CAC time: 60000 ms
  • 5700 MHz [140] (24.0 dBm) (radar detection) DFS state: usable (for 55062 sec) DFS CAC time: 60000 ms
  • 5745 MHz [149] (24.0 dBm)
  • 5765 MHz [153] (24.0 dBm)
  • 5785 MHz [157] (24.0 dBm)
  • 5805 MHz [161] (24.0 dBm)
  • 5825 MHz [165] (24.0 dBm)

valid interface combinations:

  • #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1, total <= 2048, #channels <= 1, STA/AP BI must match
  • #{ WDS } <= 2048, total <= 2048, #channels <= 1, STA/AP BI must match

HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff
  • maximum A-MSDU length
  • supported channel width
  • short GI for 40 MHz
  • max A-MPDU length exponent
  • min MPDU start spacing

Wiphy phy0

max # scan SSIDs: 4
max scan IEs length: 2257 bytes
max # sched scan SSIDs: 0
max # match sets: 0
Retry short limit: 7
Retry long limit: 4
Coverage class: 1 (up to 450m)
Device supports AP-side u-APSD.
Device supports T-DLS.
Available Antennas: TX 0x3 RX 0x3
Configured Antennas: TX 0x3 RX 0x3
Supported interface modes:

  • IBSS
  • managed
  • AP
  • AP/VLAN
  • WDS
  • monitor
  • mesh point
  • P2P-client
  • P2P-GO

Band 1:

Capabilities: 0x11ef

RX LDPC
HT20/HT40
SM Power Save disabled
RX HT20 SGI
RX HT40 SGI
TX STBC
RX STBC 1-stream
Max AMSDU length: 3839 bytes
DSSS/CCK HT40

Maximum RX AMPDU length 65535 bytes (exponent: 0x003)
Minimum RX AMPDU time spacing: 8 usec (0x06)
HT TX/RX MCS rate indexes supported: 0-15
Frequencies:

  • 2412 MHz [1] (20.0 dBm)
  • 2417 MHz [2] (20.0 dBm)
  • 2422 MHz [3] (20.0 dBm)
  • 2427 MHz [4] (20.0 dBm)
  • 2432 MHz [5] (20.0 dBm)
  • 2437 MHz [6] (20.0 dBm)
  • 2442 MHz [7] (20.0 dBm)
  • 2447 MHz [8] (20.0 dBm)
  • 2452 MHz [9] (20.0 dBm)
  • 2457 MHz [10] (20.0 dBm)
  • 2462 MHz [11] (20.0 dBm)
  • 2467 MHz [12] (20.0 dBm)
  • 2472 MHz [13] (20.0 dBm)
  • 2484 MHz [14] (disabled)

valid interface combinations:

  • #{ managed } <= 2048, #{ AP, mesh point } <= 8, #{ P2P-client, P2P-GO } <= 1, #{ IBSS } <= 1, total <= 2048, #channels <= 1, STA/AP BI must match
  • #{ WDS } <= 2048, total <= 2048, #channels <= 1, STA/AP BI must match

HT Capability overrides:

  • MCS: ff ff ff ff ff ff ff ff ff ff
  • maximum A-MSDU length
  • supported channel width
  • short GI for 40 MHz
  • max A-MPDU length exponent
  • min MPDU start spacing

root@OpenWrt:~#

comment:2 Changed 2 years ago by vlado@…

I think that it's bug in atk9 driver. The following output is from my Archer C7. Only atk9 (2.4Ghz - wlan1) is affected by this bug. wlan0 (atk10) is working as it should.

root@C7:~# cat /etc/openwrt_release
DISTRIB_ID='OpenWrt'
DISTRIB_RELEASE='Chaos Calmer'
DISTRIB_REVISION='r46581'
DISTRIB_CODENAME='chaos_calmer'
DISTRIB_TARGET='ar71xx/generic'
DISTRIB_DESCRIPTION='OpenWrt Chaos Calmer 15.05'
DISTRIB_TAINTS='no-all'

root@C7:~# cat /etc/config/wireless
config wifi-device radio0

option type mac80211
option channel 36
option hwmode 11a
option path 'pci0000:01/0000:01:00.0'
option htmode VHT80
option country 'BG'
option noscan '1'
option txpower '20'

config wifi-iface

option device radio0
option network vlan41
option mode sta
option ssid ssid
option encryption psk2
option key 'key'
option wds '1'

config wifi-device radio1

option type mac80211
option channel 2
option hwmode 11g
option path 'platform/qca955x_wmac'
option htmode HT40
option noscan '1'
option country 'BG'
option txpower '20'
option disabled '0'

config wifi-iface

option device radio1
option network vlan41
option mode ap
option ssid ssid
option encryption psk2
option key 'key'

root@C7:~# iwinfo wlan0 tx

0 dBm ( 1 mW)
1 dBm ( 1 mW)
2 dBm ( 1 mW)
3 dBm ( 1 mW)
4 dBm ( 2 mW)
5 dBm ( 3 mW)
6 dBm ( 3 mW)
7 dBm ( 5 mW)
8 dBm ( 6 mW)
9 dBm ( 7 mW)

10 dBm ( 10 mW)
11 dBm ( 12 mW)
12 dBm ( 15 mW)
13 dBm ( 19 mW)
14 dBm ( 25 mW)
15 dBm ( 31 mW)
16 dBm ( 39 mW)
17 dBm ( 50 mW)
18 dBm ( 63 mW)
19 dBm ( 79 mW)

  • 20 dBm ( 100 mW)

root@C7:~# iwinfo wlan1 tx

0 dBm ( 1 mW)
1 dBm ( 1 mW)
2 dBm ( 1 mW)
3 dBm ( 1 mW)
4 dBm ( 2 mW)
5 dBm ( 3 mW)
6 dBm ( 3 mW)
7 dBm ( 5 mW)
8 dBm ( 6 mW)
9 dBm ( 7 mW)

10 dBm ( 10 mW)
11 dBm ( 12 mW)
12 dBm ( 15 mW)
13 dBm ( 19 mW)
14 dBm ( 25 mW)
15 dBm ( 31 mW)
16 dBm ( 39 mW)

  • 17 dBm ( 50 mW) 18 dBm ( 63 mW) 19 dBm ( 79 mW) 20 dBm ( 100 mW)

comment:3 Changed 2 years ago by anonymous

This bug should be gone in recent trunk.

comment:4 Changed 2 years ago by vlado@…

Hi,
Do you know in which revision and can it be backported to CC?
Thanks!

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.