Modify

Opened 3 years ago

#20194 new defect

X86 32 bit target doesn't build OpenSSL with AES-NI support

Reported by: linuxdude9+openwrt@… Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

The x86_64 build correctly builds OpenSSL with AES-NI support, but the x86_32(kvm_guest, etc), do not.

I've been trying to use AES-NI with the kvm_guest target, and have tracked down the issue.

The issue is with the OpenSSL patch 110-optimize-for-size.patch

The x86 targets used the target in this file "linux-generic-openwrt". After the patch is applied, the target Makefile for OpenSSL does not build the required modules for aes-ni support in OpenSSL. I think it's related to the no_asm setting in the patch 110-optimize-for-size.patch file.

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.