Modify

Opened 3 years ago

Last modified 3 years ago

#20150 new defect

30% speed degradation since r44656: mac80211: Use newer firmware for ath10k

Reported by: gvalkov Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: kernel Version: Trunk
Keywords: wireless speed mac80211 ath10k TL-WR1043ND v2.1 Cc: nbd@…

Description

I am experiencing about 30% speed degradation since r44656 on TL-WR1043ND v2.1. v1.8 is not affected since it is using a different version of the Atheros driver.

On r44653- I can achieve average 8500 KB/s up + 8500 KB/s down.
On r44656+ I can achieve average 6600 KB/s up + 6600 KB/s down.

The testing environment uses v2.1 as WDS AP/main and 1.8 as WDS client/extender. The main router connects to the computer over gigabit LAN. The extender is running r46391 and forwards a TCP port back to the computer.

I used a binary search to locate the problematic commits:

r44655
mac80211: update to wireless-testing 2015-03-09
commit d680f50dd7473d566ebd57cca3bb6a2ea39c76fc

r44656
mac80211: Use newer firmware for ath10k
commit b71a676030e81dbcf536a2e9349120eb64f32849

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

ath10k driver is for AC cards and WR1043ND (both hardware versions - v1 and v2) doesn't use it.

comment:2 Changed 3 years ago by gvalkov

Thank you for pointing this out. I have performed a lot of testing and switching from one commit to another and I got a consistent results about the speed difference. On r44655 I got no wireless interface in ifconfig, so I was forced to go to r44656 where the interface is back and working, but, the speed is slower.

I can easily track a small patch to reverse it and fix the issue, but an entire package update is something too big and I have no clue how to manage this. Can anyone give me an advice or help me to investigate this?

comment:3 Changed 3 years ago by gvalkov

Seems like both routers are affected. Installing r44653 on both of them allowed me to reach as high as 9150 KB/s up + down. A total transfer of 143 Mbit/s is near the limit of a 300 Mbit/s phy. It would be great if someone can restore this performance. Builds after r44656 are 38% slower at 103 Mbit/s. :(

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.