Modify

Opened 3 years ago

Closed 18 months ago

#20113 closed defect (worksforme)

15.05-rc3 does not boot on ASUS WL-500g Deluxe

Reported by: MoDaX Owned by: hauke
Priority: high Milestone: Chaos Calmer 15.05
Component: base system Version:
Keywords: Cc:

Description

Hello,

I have a ASUS WL-500g Deluxe router. Up to this point, it was running Barrier Breaker 14.07 openwrt-brcm47xx-legacy-squashfs.trx image. I decided to try out a new Chaos Calmer 15.05-rc3 release.

Unfortunately, it does not seem to boot on my router. While in failure mode, once I tftp the image, wait a bit and re-plugin the router, it boots straight into failure mode again. Obviously, firstly I tried openwrt-15.05-rc3-brcm47xx-legacy-squashfs.trx image, then openwrt-15.05-rc3-brcm47xx-legacy-squashfs-gz.trx, openwrt-15.05-rc3-brcm47xx-legacy-squashfs-noloader-nodictionary.trx and even openwrt-15.05-rc3-brcm47xx-legacy-asus-wl-500gp-v1-squashfs.trx without success.

Then as a last resort, I decided to try out trunk image from https://downloads.openwrt.org/snapshots/trunk/brcm47xx/legacy/openwrt-brcm47xx-legacy-squashfs.trx and to my big suprise, it worked right away! Router booted and is running "CHAOS CALMER (Bleeding Edge, r46407)" now.

I would still like to be able to install a final 15.05 release rather than resort to a snapshot. Hopefully, this will help you to identify the difference between trunk r46407 and 15.05-rc3 which broke wl-500gd support. If you need more information, please let me know.

Attachments (0)

Change History (9)

comment:1 Changed 3 years ago by hauke

Hi,

Thanks for the report. Do you have a serial connected and can you provide me with the serial log of the failing image?

openwrt-15.05-rc3-brcm47xx-legacy-squashfs.trx should be the correct image.

comment:2 Changed 3 years ago by MoDaX

Hi,

unfortunately, I don't have a serial connected and I can't provide a boot log.

comment:3 Changed 2 years ago by hauke

  • Owner changed from developers to hauke
  • Status changed from new to assigned

comment:4 Changed 2 years ago by JimmyHedman

I have an ASUS WL-500g router that I just installed 15.05rc3 (not legacy) on. It worked fine there.
I'll add an serial port to it and install the legacy and to see if I have the same problem.

comment:5 Changed 2 years ago by JimmyHedman

I just tested some different installations:

  • 15.05rc3 legacy from 15.03rc3 generic.
  • 15.05rc3 legacy from 14.07 legacy.
  • 15.05rc3 legacy from 14.07 generic.

I didn't keep the configuration, but all of them worked.

Is there anything else I should try?

comment:6 Changed 2 years ago by rmilecki

JimmyHedman: not really, thanks a lot for testing!

MoDaX: in this case if looks like something specific to your unit. I'm afraid the only way to resolve this is to attach serial console to your device. Otherwise we can't guess what's going on :(

comment:7 Changed 2 years ago by hauke

I tested the final release on a Asus WL-520, and it booted, luci was more or less unusable because of too less RAM. The images for the rc3 were bigger because it contained the kernel symbols, this caused problems on devices with 4MB flash, please retry the final release where this was fixed.

comment:8 Changed 18 months ago by anonymous

I just upgraded an old wl-500gd to 15.05.1, and it worked.

Subjectively, it feels more sluggish than Barrier Breaker, the previous release running on this device.

comment:9 Changed 18 months ago by rmilecki

  • Resolution set to worksforme
  • Status changed from assigned to closed

It seems noone can reproduce MoDaX's problems. We also didn't get serial output for a year. Closing.

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.