Modify

Opened 3 years ago

Last modified 2 years ago

#20092 new defect

GRE (gretap) not working

Reported by: mario_lopes Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi all.

I have installed gre and kmod-gre but after reboot, some problems rise.

On LuCI, interface gretap0 appeared on interfaces but no way to set it up. It appears greyed out, like it's down.

Doing 'ip link add gretap0 type gretap local 192.168.1.1 remote 192.168.2.1' gives:
RTNETLINK answers: File exists

(192.168.1.1 is eth0.3 ip of local router, 192.168.2.1 is eth0 ip of remote router)

Then deleting with 'ip link del gretap0', doesn't delete, because doing 'ip link show':

gretap0@NONE: <BROADCAST,MULTICAST> mtu 1462 qdisc noop state DOWN mode DEFAULT group default qlen 1000
    link/ether 00:00:00:00:00:00 brd ff:ff:ff:ff:ff:ff

Doing again 'ip link add ... ' throws same error.

Doing 'ip link set gretap0 type gretap local 192.168.1.1 remote 192.168.2.1' throws 'Segmentation fault'.

Also, I have followed this configuration /changeset/41897.html but interface doesn't work.

On syslog/dmesg, no errors found.

Using r46384 on TL-Link TL-WR1043ND v1.

Thanks.

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

Please post your /etc/config/network

comment:2 Changed 3 years ago by mario_lopes

Now it's this, with interface bridged but same problems with ip command:

config interface 'loopback'
	option ifname 'lo'
	option proto 'static'
	option ipaddr '127.0.0.1'
	option netmask '255.0.0.0'

config globals 'globals'
	option ula_prefix 'fd70:a48e:4be0::/48'

config interface 'lan'
	option ifname 'eth0.1'
	option force_link '1'
	option proto 'static'
	option netmask '255.255.255.0'
	option ipaddr '192.168.0.250'

config interface 'wan6'
	option ifname 'eth0.2'
	option proto 'dhcpv6'

config switch
	option name 'switch0'
	option reset '1'
	option enable_vlan '1'
	option mirror_source_port '0'
	option mirror_monitor_port '0'
	option enable_vlan4k '1'

config switch_vlan
	option device 'switch0'
	option vlan '1'
	option ports '2 5t'

config switch_vlan
	option device 'switch0'
	option vlan '2'
	option ports '0 5t'

config switch_vlan
	option device 'switch0'
	option ports '1t 5t'
	option vlan '10'

config switch_vlan
	option device 'switch0'
	option vlan '11'
	option ports '3 4 5t'

config switch_vlan
	option device 'switch0'
	option ports '1t 5t'
	option vlan '20'

config switch_vlan
	option device 'switch0'
	option ports '1t 5t'
	option vlan '30'

config interface 'WAN1'
	option proto 'static'
	option ifname 'eth0.10'
	option ipaddr 'VALID_IPv4'
	option netmask 'VALID_NETMASK'
	option gateway 'VALID_IPv4'
	option dns 'VALID_IPv4'

config interface 'LAN2'
	option proto 'static'
	option ifname 'eth0.11'
	option ipaddr '192.168.1.1'
	option netmask '255.255.255.0'

config interface 'WAN2'
	option _orig_ifname 'eth0.30'
	option _orig_bridge 'false'
	option proto 'dhcp'
	option hostname 'VALID_HOSTNAME'
	option type 'bridge'
	option ifname 'eth0.30 gretap0'

comment:3 Changed 2 years ago by anonymous

gretap0 is a default configured interface -- which is why you can't re-create or edit it. Perhaps you should be using gretap1 or any other name.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.