Modify

Opened 3 years ago

Last modified 3 years ago

#20031 new defect

ar71xx sta-ap mode connectivity problem, if sta mistake,ap will disabled

Reported by: anonymous Owned by: developers
Priority: normal Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

It is working only when sta wifi-iface correctly configured. If any mistake occurs it will disable ap/sta iface altogether.

/etc/config/wireless
config wifi-device radio0

option type mac80211
#option channel 11
option channel 3
option hwmode 11g
option path 'platform/ar933x_wmac'
option htmode HT20
# REMOVE THIS LINE TO ENABLE WIFI:
option disabled 0
option txpower '18'
option country 'US'

config wifi-iface

option network 'wwan'
option ssid 'wifi_1'
option encryption 'psk2'
option device 'radio0'
option mode 'sta'
option bssid 'xxxxx'
option key 'password'

config wifi-iface

option device radio0
option network lan
option mode ap
option ssid Openwrt_6789AB
option encryption none
option wpa_group_rekey '0'

/etc/config/network
config interface 'loopback'

option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'

option ula_prefix 'fd1c:8c41:845b::/48'

config 'interface' 'lan'

option 'type' 'bridge'
option 'proto' 'static'
option 'ipaddr' '192.168.188.1'
option 'netmask' '255.255.255.0'

config interface 'wan'

option ifname 'eth0'
option proto 'dhcp'

config interface 'wwan'

option proto 'dhcp'

if the key of wifi_1 is error, ap Openwrt_6789AB will be disable.

demsg:
[ 10.280000] NET: Registered protocol family 24
[ 10.360000] cfg80211: Calling CRDA for country: US
[ 10.370000] cfg80211: Regulatory domain changed to country: US
[ 10.370000] cfg80211: DFS Master region: FCC
[ 10.370000] cfg80211: (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 10.380000] cfg80211: (2402000 KHz - 2472000 KHz @ 40000 KHz), (N/A, 3000 mBm), (N/A)
[ 10.390000] cfg80211: (5170000 KHz - 5250000 KHz @ 80000 KHz), (N/A, 1700 mBm), (N/A)
[ 10.400000] cfg80211: (5250000 KHz - 5330000 KHz @ 80000 KHz), (N/A, 2300 mBm), (0 s)
[ 10.410000] cfg80211: (5735000 KHz - 5835000 KHz @ 80000 KHz), (N/A, 3000 mBm), (N/A)
[ 10.420000] cfg80211: (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[ 10.420000] ieee80211 phy0: Atheros AR9330 Rev:1 mem=0xb8100000, irq=2
procd: - init complete -
[ 20.000000] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[ 20.010000] IPv6: ADDRCONF(NETDEV_UP): br-lan: link is not ready
[ 22.280000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
[ 22.290000] device wlan0-1 entered promiscuous mode
[ 22.960000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
[ 24.370000] wlan0: authenticate with d4:ee:07:28:90:30
[ 24.380000] wlan0: send auth to d4:ee:07:28:90:30 (try 1/3)
[ 24.390000] wlan0: authenticated
[ 24.400000] wlan0: associate with d4:ee:07:28:90:30 (try 1/3)
[ 24.400000] wlan0: RX AssocResp from d4:ee:07:28:90:30 (capab=0x411 status=0 aid=12)
[ 24.410000] wlan0: associated
[ 24.410000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
[ 31.650000] wlan0: deauthenticated from d4:ee:07:28:90:30 (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)

Attachments (0)

Change History (3)

comment:1 Changed 3 years ago by anonymous

trunk and Barrier Breaker 14.07 have the same problem

comment:2 follow-up: Changed 3 years ago by anonymous

problem ? ...

comment:3 in reply to: ↑ 2 Changed 3 years ago by anonymous

Replying to anonymous:

problem ? ...

yes,when openwrt use relay(sta+ap), if sta is not conneted the main router, the openwrt ap of itself will lost

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.