Modify

Opened 3 years ago

Closed 3 years ago

#19987 closed defect (duplicate)

Last Trunk Build Failed (ncurses)

Reported by: anonymous Owned by: developers
Priority: highest Milestone:
Component: packages Version: Trunk
Keywords: Cc:

Description

{ return wmemcpy(s1, s2, n); }


/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/char_traits.h: In static member function 'static std::char_traits<wchar_t>::char_type* std::char_traits<wchar_t>::assign(std::char_traits<wchar_t>::char_type*, std::size_t, std::char_traits<wchar_t>::char_type)':
/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/char_traits.h:346:37: error: 'wmemset' was not declared in this scope

{ return wmemset(s, a, n); }


/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/char_traits.h: In static member function 'static std::char_traits<wchar_t>::int_type std::char_traits<wchar_t>::eof()':
/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/char_traits.h:362:38: error: 'WEOF' was not declared in this scope

{ return static_cast<int_type>(WEOF); }


In file included from /home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/ios:41:0,

from /home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/ostream:38,
from /home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/iostream:39,
from ../c++/cursesmain.cc:38:

/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/localefwd.h: At global scope:
/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/localefwd.h:133:40: error: 'mbstate_t' was not declared in this scope

template<> class codecvt<char, char, mbstate_t>;


/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/localefwd.h:133:49: error: template argument 3 is invalid

template<> class codecvt<char, char, mbstate_t>;


/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/localefwd.h:135:43: error: 'mbstate_t' was not declared in this scope

template<> class codecvt<wchar_t, char, mbstate_t>;


/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/localefwd.h:135:52: error: template argument 3 is invalid

template<> class codecvt<wchar_t, char, mbstate_t>;


Makefile:359: recipe for target '../obj_s/cursesmain.o' failed
make[5]: * obj_s/cursesmain.o Error 1
make[5]: Leaving directory '/home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9/c++'
Makefile:174: recipe for target 'libs' failed
make[4]:
* [libs] Error 2
make[4]: Leaving directory '/home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9'
Makefile:179: recipe for target '/home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9/.built' failed
make[3]: * /home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9/.built Error 2
make[3]: Leaving directory '/home/netwalker/openwrt-trunk/package/libs/ncurses'
package/Makefile:191: recipe for target 'package/libs/ncurses/compile' failed
make[2]:
* [package/libs/ncurses/compile] Error 2
make[2]: Leaving directory '/home/netwalker/openwrt-trunk'
package/Makefile:188: recipe for target '/home/netwalker/openwrt-trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.package_compile' failed
make[1]: * /home/netwalker/openwrt-trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.package_compile Error 2
make[1]: Leaving directory '/home/netwalker/openwrt-trunk'
/home/netwalker/openwrt-trunk/include/toplevel.mk:181: ошибка выполнения рецепта для цели «world»
make:
* [world] Ошибка 2
[netwalker@archlinux openwrt-trunk]$

Attachments (0)

Change History (5)

comment:1 Changed 3 years ago by swalker

  • Resolution set to duplicate
  • Status changed from new to closed

comment:2 Changed 3 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

And again:

/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/localefwd.h:135:43: error: 'mbstate_t' was not declared in this scope

template<> class codecvt<wchar_t, char, mbstate_t>;


/home/netwalker/openwrt-trunk/staging_dir/toolchain-mips_34kc_gcc-4.8-linaro_uClibc-0.9.33.2/mips-openwrt-linux-uclibc/include/c++/4.8.3/bits/localefwd.h:135:52: error: template argument 3 is invalid

template<> class codecvt<wchar_t, char, mbstate_t>;


Makefile:359: recipe for target '../obj_s/cursesmain.o' failed
make[5]: * obj_s/cursesmain.o Error 1
make[5]: Leaving directory '/home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9/c++'
Makefile:174: recipe for target 'libs' failed
make[4]:
* [libs] Error 2
make[4]: Leaving directory '/home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9'
Makefile:179: recipe for target '/home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9/.built' failed
make[3]: * /home/netwalker/openwrt-trunk/build_dir/target-mips_34kc_uClibc-0.9.33.2/libncurses/ncurses-5.9/.built Error 2
make[3]: Leaving directory '/home/netwalker/openwrt-trunk/package/libs/ncurses'
package/Makefile:191: recipe for target 'package/libs/ncurses/compile' failed
make[2]:
* [package/libs/ncurses/compile] Error 2
make[2]: Leaving directory '/home/netwalker/openwrt-trunk'
package/Makefile:188: recipe for target '/home/netwalker/openwrt-trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.package_compile' failed
make[1]: * /home/netwalker/openwrt-trunk/staging_dir/target-mips_34kc_uClibc-0.9.33.2/stamp/.package_compile Error 2
make[1]: Leaving directory '/home/netwalker/openwrt-trunk'
/home/netwalker/openwrt-trunk/include/toplevel.mk:181: ошибка выполнения рецепта для цели «world»
make:
* [world] Ошибка 2

comment:3 Changed 3 years ago by swalker

  • Resolution set to duplicate
  • Status changed from reopened to closed

And again:

it's a duplicate ticket

comment:4 Changed 3 years ago by anonymous

  • Resolution duplicate deleted
  • Status changed from closed to reopened

What am I supposed to do with this?

comment:5 Changed 3 years ago by jow

  • Resolution set to duplicate
  • Status changed from reopened to closed

Nothing, you're supposed to wait until it is resolved. This ticket is still a duplicate of the yet open #19976

Add Comment

Modify Ticket

Action
as closed .
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.