Modify

Opened 3 years ago

Last modified 20 months ago

#19957 new defect

Chaos Calmer USB issue

Reported by: corsarangelo@… Owned by: developers
Priority: high Milestone: Chaos Calmer 15.05
Component: packages Version: Trunk
Keywords: Cc:

Description

Hi all,
I got the latest version from trunck and I compiled a subset of sw.
I coming from 14.07 ver and I would upgrade to the latest version: once complied and installed I found an issue in the USB section: the modem cannot detect an old pstn modem connected to the usb port.
Here I report the lsusb command from both versions (14.07 and 15.05): now I reverted to barrier breaker waiting for a fix ;)

BusyBox v1.22.1 (2015-06-13 11:22:11 CEST) built-in shell (ash)
Enter 'help' for a list of built-in commands.

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

-----------------------------------------------------
BARRIER BREAKER (Barrier Breaker, r45951)
-----------------------------------------------------

  • 1/2 oz Galliano Pour all ingredients into
  • 4 oz cold Coffee an irish coffee mug filled
  • 1 1/2 oz Dark Rum with crushed ice. Stir.
  • 2 tsp. Creme de Cacao

-----------------------------------------------------

root@ARV7510PW22:~# lsusb
Bus 003 Device 002: ID 0572:1329 Conexant Systems (Rockwell), Inc.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

root@ARV7510PW22:~# opkg list-installed | grep usb
kmod-ledtrig-usbdev - 3.10.49-1
kmod-usb-core - 3.10.49-1
kmod-usb-ohci - 3.10.49-1
kmod-usb-printer - 3.10.49-1
kmod-usb-serial - 3.10.49-1
kmod-usb-storage - 3.10.49-1
kmod-usb-storage-extras - 3.10.49-1
kmod-usb-uhci - 3.10.49-1
kmod-usb2 - 3.10.49-1
kmod-usb2-pci - 3.10.49-1
libusb-1.0 - 1.0.9-1
usbreset - 4
usbutils - 007-1

BusyBox v1.23.2 (2015-06-19 09:49:32 CEST) built-in shell (ash)

_

| |.-----.-----.-----.| | | |.----.| |_

| - |_
_ | -| | | _ _|
|_||| ||

|| W I R E L E S S F R E E D O M

-----------------------------------------------------
CHAOS CALMER (Chaos Calmer, r46060)
-----------------------------------------------------

  • 1 1/2 oz Gin Shake with a glassful
  • 1/4 oz Triple Sec of broken ice and pour
  • 3/4 oz Lime Juice unstrained into a goblet.
  • 1 1/2 oz Orange Juice
  • 1 tsp. Grenadine Syrup

-----------------------------------------------------

root@ARV7510PW22:~# lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

root@ARV7510PW22:~# opkg list-installed | grep usb
kmod-ledtrig-usbdev - 3.18.16-1
kmod-usb-core - 3.18.16-1
kmod-usb-hid - 3.18.16-1
kmod-usb-ohci - 3.18.16-1
kmod-usb-ohci-pci - 3.18.16-1
kmod-usb-printer - 3.18.16-1
kmod-usb-serial - 3.18.16-1
kmod-usb-storage - 3.18.16-1
kmod-usb-storage-extras - 3.18.16-1
kmod-usb-uhci - 3.18.16-1
kmod-usb2 - 3.18.16-1
libusb-1.0 - 1.0.19-1
usbreset - 4
usbutils - 007-1

I have no error in the compiling and during the boot. I can report here the dmesg or any other info to fix this issue.

Angelo

Attachments (0)

Change History (5)

comment:1 Changed 21 months ago by anonymous

no one ping in 11 months ....

comment:2 Changed 21 months ago by corsaroangelo@…

I installed also the latest images from opwenwrt.org, but with always the same issue: no devices on the usb....
if I'm using the 14.07 version:
lsusb
Bus 001 Device 002: ID 0718:070a Imation Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

but whit 15.05.1

lsusb
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

comment:3 Changed 21 months ago by anonymous

I'm using a ARV7510PW22 - Astoria Networks

comment:4 Changed 20 months ago by corsaroangelo@…

I did some tests and I found an interesting issue:
on the modem there are three usb port.. looking from the back, one in the upper left (where can be attached the data usb key), one in the edge of the lower back and another on the edge of the right.
If I plug an usb drive in ther upper left port, I have this from the dmeg:

[ 432.559583] usb 2-1: new high-speed USB device number 2 using ifxusb_hcd
[ 432.760960] usb-storage 2-1:1.0: USB Mass Storage device detected
[ 432.770923] scsi host0: usb-storage 2-1:1.0
[ 433.849902] scsi 0:0:0:0: Direct-Access TDK LoR TF10 PMAP PQ: 0 ANSI: 4
[ 434.797023] sd 0:0:0:0: [sda] 15122432 512-byte logical blocks: (7.74 GB/7.21 GiB)
[ 434.804625] sd 0:0:0:0: [sda] Write Protect is off
[ 434.808031] sd 0:0:0:0: [sda] Mode Sense: 23 00 00 00
[ 434.809618] sd 0:0:0:0: [sda] No Caching mode page found
[ 434.813540] sd 0:0:0:0: [sda] Assuming drive cache: write through
[ 434.853763] sda: sda1
[ 434.868819] sd 0:0:0:0: [sda] Attached SCSI removable disk

so, it seems to work, but using the usb ports on the edge of the board, I see nothing on the dmesg.

looking at the dmesg, there are few differences from the 14.07 and 15.05:

from 15.05
[ 0.186422] usbcore: registered new interface driver usbfs
[ 0.192056] usbcore: registered new interface driver hub
[ 0.197479] usbcore: registered new device driver usb
[ 6.789902] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 6.812682] ehci-pci 0000:00:0f.2: new USB bus registered, assigned bus number 1
[ 6.835589] ehci-pci 0000:00:0f.2: USB 2.0 started, EHCI 1.00
[ 6.841916] hub 1-0:1.0: USB hub found
[ 6.853599] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 6.868678] uhci_hcd: USB Universal Host Controller Interface driver
[ 6.908941] IFXUSB: ifxusb_hcd: version 3.2 B110801
[ 7.416233] IFXUSB: USB core #0 soft-reset
[ 7.620144] IFXUSB: USB core #0 soft-reset
[ 7.622782] ifxusb_hcd ifxusb_hcd: IFX USB Controller
[ 7.627776] ifxusb_hcd ifxusb_hcd: new USB bus registered, assigned bus number 2
[ 7.634937] ifxusb_hcd ifxusb_hcd: irq 62, io mem 0xbe101000
[ 7.640378] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[ 7.646454] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[ 7.652541] IFXUSB: Init: Power Port (0)
[ 7.667230] hub 2-0:1.0: USB hub found
[ 7.674212] ifxusb_hcd ifxusb_hcd: requested GPIO 488

from the 14.07
[ 0.128000] usbcore: registered new interface driver usbfs
[ 0.132000] usbcore: registered new interface driver hub
[ 0.136000] usbcore: registered new device driver usb
[ 7.000000] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[ 7.020000] ehci-pci 0000:00:0f.2: new USB bus registered, assigned bus number 1
[ 7.044000] ehci-pci 0000:00:0f.2: USB 2.0 started, EHCI 1.00
[ 7.048000] hub 1-0:1.0: USB hub found
[ 7.060000] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[ 7.068000] uhci_hcd: USB Universal Host Controller Interface driver
[ 7.080000] uhci_hcd 0000:00:0f.0: new USB bus registered, assigned bus number 2
[ 7.092000] hub 2-0:1.0: USB hub found
[ 7.104000] uhci_hcd 0000:00:0f.1: new USB bus registered, assigned bus number 3
[ 7.120000] hub 3-0:1.0: USB hub found
[ 7.132000] IFXUSB: ifxusb_hcd: version 3.2 B110801
[ 7.640000] IFXUSB: USB core #0 soft-reset
[ 7.844000] IFXUSB: USB core #0 soft-reset
[ 7.848000] ifxusb_hcd ifxusb_hcd: IFX USB Controller
[ 7.852000] ifxusb_hcd ifxusb_hcd: new USB bus registered, assigned bus number 4
[ 7.860000] ifxusb_hcd ifxusb_hcd: irq 62, io mem 0xbe101000
[ 7.864000] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[ 7.868000] IFXUSB: Mode Mismatch Interrupt: currently in Host mode
[ 7.876000] IFXUSB: Init: Power Port (0)
[ 7.880000] hub 4-0:1.0: USB hub found
[ 7.888000] ifxusb_hcd ifxusb_hcd: requested GPIO 232
[ 7.900000] usbcore: registered new interface driver usb-storage
[ 9.328000] usb 3-2: new full-speed USB device number 2 using uhci_hcd

I have no more ideas. It seems something releated to the kernel.

Cheers,
Angelo

comment:5 Changed 20 months ago by corsaroangelo@…

/ticket/18369.html

I found a solution.

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.