Modify

Opened 3 years ago

#19922 new defect

Default network NFS101U (adm5120/router_le) fails

Reported by: Mijzelf@… Owned by: developers
Priority: normal Milestone: Chaos Calmer 15.05
Component: base system Version: Trunk
Keywords: network NFS101U Cc:

Description

The default network fails (no network on the only network port)
The default config is:

#### VLAN configuration
config switch

option eth0 "0 1 2 3"
option eth1 "4"



#### Loopback configuration
config interface loopback

option ifname "lo"
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0



#### LAN configuration
config interface lan

option type bridge
option ifname "eth0"
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0
option ip6assign 60



#### WAN configuration
config interface wan

option ifname "eth1"
option proto dhcp



#### WAN6 configuration
config interface wan6

option ifname "eth1"
option proto dhcpv6



#### Network global configuration
config globals globals

option ula_prefix auto


I solved it by inserting the config of Backfire:

# Copyright (C) 2006 OpenWrt.org


config interface loopback

option ifname lo
option proto static
option ipaddr 127.0.0.1
option netmask 255.0.0.0


config interface lan

option ifname eth0
option type bridge
option proto static
option ipaddr 192.168.1.1
option netmask 255.255.255.0

This works. I guess it's the switch setting which is the problem. (Although there is no swconfig in the firmware, and AFAIK the box doesn't have a switch either)

BTW, I tested this on a Sitecom LN-350, which AFAIK is hardware identical.

Attachments (0)

Change History (0)

Add Comment

Modify Ticket

Action
as new .
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.